aboutsummaryrefslogtreecommitdiff
path: root/x11/peeper
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-08-09 09:17:29 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-08-09 09:17:29 +0000
commit51dbaec8d6f60d47d7770e71335d45b6d184693c (patch)
tree6ca1d5dd04dcfc163ea7f5fb2563dcc7c5c27382 /x11/peeper
parentf270d47e9276ce47ee5722fc8774803edeb154f4 (diff)
downloadports-51dbaec8d6f60d47d7770e71335d45b6d184693c.tar.gz
ports-51dbaec8d6f60d47d7770e71335d45b6d184693c.zip
add peeper 0.1
View an area of the screen at a certain magnification
Notes
Notes: svn path=/head/; revision=64272
Diffstat (limited to 'x11/peeper')
-rw-r--r--x11/peeper/Makefile31
-rw-r--r--x11/peeper/distinfo1
-rw-r--r--x11/peeper/pkg-comment1
-rw-r--r--x11/peeper/pkg-descr3
-rw-r--r--x11/peeper/pkg-plist1
5 files changed, 37 insertions, 0 deletions
diff --git a/x11/peeper/Makefile b/x11/peeper/Makefile
new file mode 100644
index 000000000000..6dca2dbfe5cb
--- /dev/null
+++ b/x11/peeper/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: peeper
+# Date created: Aug 9, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= peeper
+PORTVERSION= 0.1
+CATEGORIES= x11
+MASTER_SITES= http://peeper.sourceforge.net/
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_REINPLACE= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12 imlib
+USE_GMAKE= yes
+ALL_TARGET= peeper
+MAKE_ENV= LIBS="-L${LOCALBASE}/lib -lpng -ljpeg -lungif -ltiff"
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|^CC|#CC|g" -e "s|CFLAGS=|CFLAGS+=|g" \
+ -e "s|gtk-config|${GTK_CONFIG}|g" -e "s|-ldl||g" \
+ -e "s|LIBS=|LIBS+=|g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/peeper ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/x11/peeper/distinfo b/x11/peeper/distinfo
new file mode 100644
index 000000000000..8d0000fa3194
--- /dev/null
+++ b/x11/peeper/distinfo
@@ -0,0 +1 @@
+MD5 (peeper-0.1.tar.gz) = 418585fdcf214990b1028c60a6ef1c10
diff --git a/x11/peeper/pkg-comment b/x11/peeper/pkg-comment
new file mode 100644
index 000000000000..1c4e6f673934
--- /dev/null
+++ b/x11/peeper/pkg-comment
@@ -0,0 +1 @@
+View an area of the screen at a certain magnification
diff --git a/x11/peeper/pkg-descr b/x11/peeper/pkg-descr
new file mode 100644
index 000000000000..60269e0bd2eb
--- /dev/null
+++ b/x11/peeper/pkg-descr
@@ -0,0 +1,3 @@
+Peeper is a GTK program to view an area of the screen at a certain
+magnification. It has the ability to magnify animations, and view
+the screen at different levels of magnification.
diff --git a/x11/peeper/pkg-plist b/x11/peeper/pkg-plist
new file mode 100644
index 000000000000..d4f496e68220
--- /dev/null
+++ b/x11/peeper/pkg-plist
@@ -0,0 +1 @@
+bin/peeper