aboutsummaryrefslogtreecommitdiff
path: root/x11/plasma-scriptengine-python
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-02-18 14:23:03 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-02-18 14:23:03 +0000
commite9c34f4c34b0640b3613f03cd96e9f19730b2a07 (patch)
treeef2b2b24dfacf6def95c54d3379c421565b1fe2b /x11/plasma-scriptengine-python
parent4dc7ccc95d370549c7c9c7c9c253d64aa92881ae (diff)
downloadports-e9c34f4c34b0640b3613f03cd96e9f19730b2a07.tar.gz
ports-e9c34f4c34b0640b3613f03cd96e9f19730b2a07.zip
KDE/FreeBSD team presents KDE SC 4.12.2 and KDE Workspace 4.11.6!
Among changes: - Switch KDE4_PREFIX to ${LOCALBASE} - Remove now needless misc/kde4-shared-mime-info port - Add stage support - Remove ancient CONFLICTS (KDE 4.9 and less) and LATEST_LINK - Squeeze MASTER_SITES/MASTER_SITE_SUBDIR - Convert LIB_DEPENDS to new style - Use options helpers - Drop support for FreeBSD 7.x - Remove Qt/KDE 3 related workarounds - Remove local patches and use upstream version scheme for libraries - sysutils/kdeadmin4, net/kdenetwork4, devel/kdesdk4, and x11-clocks/kdetoys4 ports have been split. - devel/kcachegrind is now a part of KDE SC [1] - more logs in area51 repo... New ports: devel/kde-dev-scripts: KDE development scripts devel/kde-dev-utils: KDE development utilities games/klickety: Tetris themed solitaire games/picmi: Single player logic-based puzzle game textproc/libkomparediff2: Library to compare files and strings The area51 repository features commits by Schaich Alonso, avilla, rakuco and myself. PR: ports/186491 Exp-run: by bdrewery Approved by: beat (former maintainer) [1]
Notes
Notes: svn path=/head/; revision=344893
Diffstat (limited to 'x11/plasma-scriptengine-python')
-rw-r--r--x11/plasma-scriptengine-python/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/x11/plasma-scriptengine-python/Makefile b/x11/plasma-scriptengine-python/Makefile
index 2c21ea0fa8ac..9ebd090c2a75 100644
--- a/x11/plasma-scriptengine-python/Makefile
+++ b/x11/plasma-scriptengine-python/Makefile
@@ -1,11 +1,9 @@
# $FreeBSD$
PORTNAME= plasma-scriptengine-python
-PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
+PORTVERSION= ${KDE4_WORKSPACE_VERSION}
CATEGORIES= x11 kde
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+MASTER_SITES= KDE/${KDE4_BRANCH}/${KDE4_VERSION}/src
DISTNAME= kde-workspace-${PORTVERSION}
DIST_SUBDIR= KDE/${PORTVERSION}
@@ -14,14 +12,13 @@ COMMENT= Plasma scriptengine for Python
USE_KDE4= kdehier kdelibs kdeprefix pykde4 automoc4
USE_QT4= qmake_build moc_build uic_build rcc_build
-USE_PYTHON= yes
+USE_PYTHON= 2
DISTINFO_FILE= ${PORTSDIR}/x11/kde4-workspace/distinfo
USE_XZ= yes
USES= cmake:outsource
CMAKE_SOURCE_PATH= ${WRKSRC}/plasma/generic/scriptengines/python
-NO_STAGE= yes
pre-configure:
${REINPLACE_CMD} -e 's,$${PYTHON_SITE_PACKAGES_DIR},${PYTHONPREFIX_SITELIBDIR},g' \
${CMAKE_SOURCE_PATH}/CMakeLists.txt