aboutsummaryrefslogtreecommitdiff
path: root/x11/rofi
diff options
context:
space:
mode:
authorVeniamin Gvozdikov <vg@FreeBSD.org>2015-04-09 08:53:42 +0000
committerVeniamin Gvozdikov <vg@FreeBSD.org>2015-04-09 08:53:42 +0000
commit656b1ea17a4d84221bcc02640f0fb33191bd346d (patch)
treed73e6ba7b9f5bb51f570b6140e8ac125f36f3b8b /x11/rofi
parent15da689cce3fcd8dca996c4f162a00a4d1f634b5 (diff)
downloadports-656b1ea17a4d84221bcc02640f0fb33191bd346d.tar.gz
ports-656b1ea17a4d84221bcc02640f0fb33191bd346d.zip
- Update to 0.15.2
PR: ports/198733 Submitted by: nomoo@nomoo.ru (maintainer)
Notes
Notes: svn path=/head/; revision=383629
Diffstat (limited to 'x11/rofi')
-rw-r--r--x11/rofi/Makefile12
-rw-r--r--x11/rofi/distinfo4
-rw-r--r--x11/rofi/files/patch-source_helper.c10
-rw-r--r--x11/rofi/files/patch-source_i3-support.c11
4 files changed, 29 insertions, 8 deletions
diff --git a/x11/rofi/Makefile b/x11/rofi/Makefile
index b6618c9ba09a..1bb85a79c7fb 100644
--- a/x11/rofi/Makefile
+++ b/x11/rofi/Makefile
@@ -1,9 +1,9 @@
# $FreeBSD$
PORTNAME= rofi
-PORTVERSION= 0.14.12
+PORTVERSION= 0.15.2
CATEGORIES= x11
-MASTER_SITES= GHL
+MASTER_SITES= GH
MAINTAINER= nomoo@nomoo.ru
COMMENT= Window switcher, run dialog and dmenu replacement
@@ -12,12 +12,12 @@ LICENSE= MIT
USE_GITHUB= yes
GH_ACCOUNT= DaveDavenport
-GH_COMMIT= 9b33197
-GH_TAGNAME= 0.14.12
+GH_TAGNAME= 0.15.2
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
GNU_CONFIGURE= yes
-USES= autoreconf pkgconfig
-USE_XORG= x11 xinerama
+USES= autoreconf pkgconfig gmake
+USE_XORG= x11 xinerama xft
USE_GNOME= pango
PLIST_FILES= bin/rofi man/man1/rofi.1.gz
diff --git a/x11/rofi/distinfo b/x11/rofi/distinfo
index ec2b4c035f15..a8de37b59c16 100644
--- a/x11/rofi/distinfo
+++ b/x11/rofi/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rofi-0.14.12.tar.gz) = 7298098b8d49a5922e3f9cf9154c12f93be3249adba0475d47ff1a4e96ad859f
-SIZE (rofi-0.14.12.tar.gz) = 52356
+SHA256 (DaveDavenport-rofi-0.15.2-0.15.2_GH0.tar.gz) = f666398a85d1809fe482bf97ca929105e40319d2c496a849facaf127082b01a2
+SIZE (DaveDavenport-rofi-0.15.2-0.15.2_GH0.tar.gz) = 63627
diff --git a/x11/rofi/files/patch-source_helper.c b/x11/rofi/files/patch-source_helper.c
new file mode 100644
index 000000000000..148a7d0bc73a
--- /dev/null
+++ b/x11/rofi/files/patch-source_helper.c
@@ -0,0 +1,10 @@
+--- source/helper.c.orig 2015-02-27 14:12:52 UTC
++++ source/helper.c
+@@ -35,6 +35,7 @@
+ #include <fcntl.h>
+ #include <sys/types.h>
+ #include <sys/file.h>
++#include <sys/stat.h>
+ #include "helper.h"
+ #include "rofi.h"
+
diff --git a/x11/rofi/files/patch-source_i3-support.c b/x11/rofi/files/patch-source_i3-support.c
new file mode 100644
index 000000000000..2a8f45bfa49e
--- /dev/null
+++ b/x11/rofi/files/patch-source_i3-support.c
@@ -0,0 +1,11 @@
+--- source/i3-support.c.orig 2015-02-27 14:12:52 UTC
++++ source/i3-support.c
+@@ -36,7 +36,7 @@
+ #include <X11/X.h>
+ #include <X11/Xlib.h>
+ #include <sys/socket.h>
+-#include <linux/un.h>
++#include <sys/un.h>
+
+ #include "rofi.h"
+ #include "x11-helper.h"