aboutsummaryrefslogtreecommitdiff
path: root/x11/rsibreak
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-03-21 17:48:46 +0000
committerAlex Dupre <ale@FreeBSD.org>2006-03-21 17:48:46 +0000
commita8fcb08c85c83daaba92f8c5b9c8bffab2c1591f (patch)
tree2c16c72f288b5599aee3061d6aa5c15308ea0556 /x11/rsibreak
parent6f9bc91b6d3fcc9e917038989a071b7b3615ddc4 (diff)
downloadports-a8fcb08c85c83daaba92f8c5b9c8bffab2c1591f.tar.gz
ports-a8fcb08c85c83daaba92f8c5b9c8bffab2c1591f.zip
Hopefully unbreak on FreeBSD 4.
Notes
Notes: svn path=/head/; revision=157905
Diffstat (limited to 'x11/rsibreak')
-rw-r--r--x11/rsibreak/Makefile8
-rw-r--r--x11/rsibreak/files/patch-rsibreak_src_rsiwidget.cpp19
2 files changed, 20 insertions, 7 deletions
diff --git a/x11/rsibreak/Makefile b/x11/rsibreak/Makefile
index 41b84fb773d2..09a9c435cdd2 100644
--- a/x11/rsibreak/Makefile
+++ b/x11/rsibreak/Makefile
@@ -19,14 +19,8 @@ USE_KDELIBS_VER=3
USE_AUTOTOOLS= libtool:15
USE_GETTEXT= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= Doesn't compile on FreeBSD 4.X
-.endif
-
post-patch:
@${REINPLACE_CMD} 's/install-data-local: install-apidox/install-data-local:/' \
${WRKSRC}/rsibreak/Makefile.in ${WRKSRC}/rsibreak/src/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11/rsibreak/files/patch-rsibreak_src_rsiwidget.cpp b/x11/rsibreak/files/patch-rsibreak_src_rsiwidget.cpp
new file mode 100644
index 000000000000..20cd32f25ca0
--- /dev/null
+++ b/x11/rsibreak/files/patch-rsibreak_src_rsiwidget.cpp
@@ -0,0 +1,19 @@
+--- rsibreak/src/rsiwidget.cpp.orig Tue Mar 21 18:38:48 2006
++++ rsibreak/src/rsiwidget.cpp Tue Mar 21 18:39:14 2006
+@@ -41,6 +41,7 @@
+
+ #include <stdlib.h>
+ #include <math.h>
++#include <time.h>
+
+ #include "rsiwidget.h"
+ #include "rsitimer.h"
+@@ -235,7 +236,7 @@
+
+ QDir dir( folder);
+
+- if ( !dir.exists() or !dir.isReadable() )
++ if ( !dir.exists() || !dir.isReadable() )
+ {
+ kdWarning() << "Folder does not exist or is not readable: "
+ << folder << endl;