aboutsummaryrefslogtreecommitdiff
path: root/x11/slim
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2014-11-02 09:44:01 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2014-11-02 09:44:01 +0000
commit95d9ca648e94804096b0edb9e32f9f4e3039909b (patch)
treee79f6f6735234f3647b2468fcda5d7f0dd5106e1 /x11/slim
parentb9346b31fa8df9f5d5c89a928999495dddc84c57 (diff)
downloadports-95d9ca648e94804096b0edb9e32f9f4e3039909b.tar.gz
ports-95d9ca648e94804096b0edb9e32f9f4e3039909b.zip
- Modify sample config to not listen on the net by default [1]
- Fix paths in man page [2] - While here, silence some portlint warnings and modernize plist PR: 194252 [1], 194518 [2] Submitted by: uffe at uffe.org [1] adrian@ [2] Approved by: Henry Hu <henry.hu.sh at gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=372060
Diffstat (limited to 'x11/slim')
-rw-r--r--x11/slim/Makefile7
-rw-r--r--x11/slim/files/patch-slim.119
-rw-r--r--x11/slim/files/patch-slim.conf2
-rw-r--r--x11/slim/pkg-plist7
4 files changed, 19 insertions, 16 deletions
diff --git a/x11/slim/Makefile b/x11/slim/Makefile
index 58c6ef8141b4..b1c3e27927e7 100644
--- a/x11/slim/Makefile
+++ b/x11/slim/Makefile
@@ -3,7 +3,7 @@
PORTNAME= slim
PORTVERSION= 1.3.6
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11
MASTER_SITES= ftp://ftp.berlios.de/pub/slim/ \
SF/slim.berlios
@@ -23,8 +23,9 @@ LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus \
USES= cmake pkgconfig
USE_XORG= ice sm x11 xau xcb xdmcp xext xft xmu xorg-server xrandr \
- xrender xt
+ xrender xt
USE_RC_SUBR= slim
+USE_LDCONFIG= yes
SUB_FILES= pkg-message
CMAKE_ARGS= -DUSE_CONSOLEKIT=yes \
@@ -57,7 +58,7 @@ post-patch:
@${CP} ${WRKSRC}/slim.conf ${WRKSRC}/slim.conf.sample
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/slim.conf.sample
- @${REINPLACE_CMD} -e 's,/etc/slim.conf,${PREFIX}&,' \
+ @${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' \
${WRKSRC}/slim.1
post-install:
diff --git a/x11/slim/files/patch-slim.1 b/x11/slim/files/patch-slim.1
index 9608b1a697f1..50d0eb0c076e 100644
--- a/x11/slim/files/patch-slim.1
+++ b/x11/slim/files/patch-slim.1
@@ -1,8 +1,12 @@
-$FreeBSD$
-
---- slim.1.orig 2014-03-10 21:18:36.740597788 +0000
-+++ slim.1 2014-03-10 21:22:07.373025770 +0000
-@@ -42,6 +42,9 @@
+--- slim.1.orig 2013-10-01 22:38:05 UTC
++++ slim.1
+@@ -37,13 +37,16 @@ display version information
+ run \fBslim\fP in daemon mode
+ .TP
+ .B
+-\fBslim\fP \fB-p\fP /usr/share/\fBslim\fP/themes/default
++\fBslim\fP \fB-p\fP %%PREFIX%%/share/\fBslim\fP/themes/default
+ preview of the default theme
.SH STARTING SLIM AT BOOT
Please refer to documentation of your Operating System to make \fBslim\fP
automatically startup after the system boots.
@@ -10,5 +14,8 @@ $FreeBSD$
+For \fBFreeBSD\fP, you should add the line slim_enable=yes to /etc/rc.conf
+to make \fBslim\fP start on boot.
.SH CONFIGURATION
- Global configuration is stored in the /etc/slim.conf file. See the comments
+-Global configuration is stored in the /etc/slim.conf file. See the comments
++Global configuration is stored in the %%PREFIX%%/etc/slim.conf file. See the comments
inside the file for a detailed explanation of the \fIoptions\fP.
+ .SH USAGE AND SPECIAL USERNAMES
+ When started, \fBslim\fP will show a login panel; enter the username and
diff --git a/x11/slim/files/patch-slim.conf b/x11/slim/files/patch-slim.conf
index 8c8b5d538b5b..6edb8a30bf41 100644
--- a/x11/slim/files/patch-slim.conf
+++ b/x11/slim/files/patch-slim.conf
@@ -11,7 +11,7 @@
+default_xserver %%LOCALBASE%%/bin/X
+# The X server needs to be started on an unused virtual terminal,
+# for FreeBSD in a default configuration, the first one of those is #09
-+xserver_arguments vt09
++xserver_arguments -nolisten tcp vt09
# Commands for halt, login, etc.
-halt_cmd /sbin/shutdown -h now
diff --git a/x11/slim/pkg-plist b/x11/slim/pkg-plist
index d9f75023aed4..b0fb4b4e47e4 100644
--- a/x11/slim/pkg-plist
+++ b/x11/slim/pkg-plist
@@ -5,12 +5,7 @@ lib/libslim.so.%%VERSION%%
%%DATADIR%%/themes/default/panel.png
%%DATADIR%%/themes/default/slim.theme
man/man1/slim.1.gz
-@dirrmtry %%DATADIR%%/themes/default
-@dirrmtry %%DATADIR%%/themes
-@dirrmtry %%DATADIR%%
-@unexec if cmp -s %D/etc/slim.conf.sample %D/etc/slim.conf; then rm -f %D/etc/slim.conf; fi
-etc/slim.conf.sample
-@exec if [ ! -f %D/etc/slim.conf ]; then cp -p %D/%F %B/slim.conf; fi
+@sample etc/slim.conf.sample
%%PAM%%@unexec if cmp -s %D/etc/pam.d/slim.default %D/etc/pam.d/slim; then rm -f %D/etc/pam.d/slim; fi
%%PAM%%etc/pam.d/slim.default
%%PAM%%@exec if [ ! -f %D/etc/pam.d/slim ]; then cp -p %D/%F %B/slim; fi