aboutsummaryrefslogtreecommitdiff
path: root/x11/xautomation
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-11 13:21:31 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-11 13:21:31 +0000
commitdba1f776921389460b25b1a9b97cd1a0be6872c2 (patch)
treee44fa0a32fa2e9a2b686e3d8c25b32dca3af460b /x11/xautomation
parentf0dbe5a9164a7f0f8c6a5f6c647d37fbef0b4de2 (diff)
downloadports-dba1f776921389460b25b1a9b97cd1a0be6872c2.tar.gz
ports-dba1f776921389460b25b1a9b97cd1a0be6872c2.zip
add xautomation 0.86
Control X from the command line for scripts
Notes
Notes: svn path=/head/; revision=66124
Diffstat (limited to 'x11/xautomation')
-rw-r--r--x11/xautomation/Makefile24
-rw-r--r--x11/xautomation/distinfo1
-rw-r--r--x11/xautomation/pkg-comment1
-rw-r--r--x11/xautomation/pkg-descr8
-rw-r--r--x11/xautomation/pkg-plist6
5 files changed, 40 insertions, 0 deletions
diff --git a/x11/xautomation/Makefile b/x11/xautomation/Makefile
new file mode 100644
index 000000000000..7b053c12131c
--- /dev/null
+++ b/x11/xautomation/Makefile
@@ -0,0 +1,24 @@
+# ex:ts=8
+# Ports collection makefile for: xautomation
+# Date created: Sep 11, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= xautomation
+PORTVERSION= 0.86
+CATEGORIES= x11
+MASTER_SITES= http://hoopajoo.net/static/projects/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= png:${PORTSDIR}/graphics/png
+
+USE_XLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= \
+ CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/x11/xautomation/distinfo b/x11/xautomation/distinfo
new file mode 100644
index 000000000000..43a6172b83a2
--- /dev/null
+++ b/x11/xautomation/distinfo
@@ -0,0 +1 @@
+MD5 (xautomation-0.86.tar.gz) = 16bae976298ddee496dbd8d8eb09c640
diff --git a/x11/xautomation/pkg-comment b/x11/xautomation/pkg-comment
new file mode 100644
index 000000000000..daba23a0c74e
--- /dev/null
+++ b/x11/xautomation/pkg-comment
@@ -0,0 +1 @@
+Control X from the command line for scripts
diff --git a/x11/xautomation/pkg-descr b/x11/xautomation/pkg-descr
new file mode 100644
index 000000000000..35695ff99d8d
--- /dev/null
+++ b/x11/xautomation/pkg-descr
@@ -0,0 +1,8 @@
+Control X from the command line for scripts, and do "visual scraping" to find
+things on the screen. The conrol interface allows mouse movement, clicking,
+button up/down, key up/down, etc, and uses the XTest extension so you don't
+have the annoying problems that xse has when apps ignore sent events. The
+visgrep program find images inside of images and reports the coordinates,
+allowing progams to find buttons, etc, on the screen to click on.
+
+WWW: http://hoopajoo.net/projects/xautomation.html
diff --git a/x11/xautomation/pkg-plist b/x11/xautomation/pkg-plist
new file mode 100644
index 000000000000..f3e9dc444e70
--- /dev/null
+++ b/x11/xautomation/pkg-plist
@@ -0,0 +1,6 @@
+bin/pat2ppm
+bin/patextract
+bin/png2pat
+bin/rgb2pat
+bin/visgrep
+bin/xte