aboutsummaryrefslogtreecommitdiff
path: root/x11/xbanner/Makefile
diff options
context:
space:
mode:
authorSeiichirou Hiraoka <flathill@FreeBSD.org>1999-01-20 08:18:57 +0000
committerSeiichirou Hiraoka <flathill@FreeBSD.org>1999-01-20 08:18:57 +0000
commit7fe2cd9939a366c2ac6a612e03c6b42e07da7c68 (patch)
tree646f41e8dfa5e82b1a056ad7b5c1ba9a63a4f895 /x11/xbanner/Makefile
parentf27be325bdd031ee5e715c1a75814b8e56e5eec8 (diff)
downloadports-7fe2cd9939a366c2ac6a612e03c6b42e07da7c68.tar.gz
ports-7fe2cd9939a366c2ac6a612e03c6b42e07da7c68.zip
PR: ports/9575
Submitted by: giffunip@asme.org make your XDM login screen look beautiful
Notes
Notes: svn path=/head/; revision=16198
Diffstat (limited to 'x11/xbanner/Makefile')
-rw-r--r--x11/xbanner/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11/xbanner/Makefile b/x11/xbanner/Makefile
new file mode 100644
index 000000000000..5bb522fffeb1
--- /dev/null
+++ b/x11/xbanner/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: xbanner
+# Version required: 1.31
+# Date created: 13 Jan 1999
+# Whom: giffunip@asme.org
+#
+# $Id: Exp $
+#
+
+DISTNAME= XBanner1.31
+PKGNAME= xbanner-1.31
+CATEGORIES= x11
+MASTER_SITES= ftp://physics.fullerton.edu/pub/Linux/XBanner/ \
+ ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR=X11/xutils
+
+MAINTAINER= ports@FreeBSD.ORG
+
+USE_X_PREFIX= yes
+#USE_IMAKE= yes
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/samples/XBanner.ad \
+ $(X11BASE)/lib/X11/app-defaults/XBanner
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/XBanner
+ $(CP) ${WRKSRC}/QuickStart ${PREFIX}/share/doc/XBanner
+ ${CP} ${WRKSRC}/docs/* ${PREFIX}/share/doc/XBanner
+ ${MKDIR} ${PREFIX}/share/examples/XBanner
+ $(CP) ${WRKSRC}/samples/_other_ideas/* ${PREFIX}/share/examples/XBanner
+.endif
+
+.include <bsd.port.mk>