aboutsummaryrefslogtreecommitdiff
path: root/x11/xcb
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-07-27 08:51:37 +0000
committerJohn Marino <marino@FreeBSD.org>2014-07-27 08:51:37 +0000
commite891dad7f23c2ab54f71139b86a8f2dfde7e00f9 (patch)
treee0c8c0fd9a31a19ce684725f18a1ef432ea8b7ff /x11/xcb
parent1b3c11ac02fccafc0cdf6d58dae43b0894181a55 (diff)
downloadports-e891dad7f23c2ab54f71139b86a8f2dfde7e00f9.tar.gz
ports-e891dad7f23c2ab54f71139b86a8f2dfde7e00f9.zip
x11/xcb: Fix incorrectly built app-defaults file
The app-defaults file for xcb was not built correctly as a consequence of the switch to clang and replacement of gcc's cpp to tradcpp which is more strict about the order of the parameters. The filename must be last on the command line otherwise a zero-length file is created. Fixed by moving the filename parameter to the end of the cpp command PR: 188203 Submitted by: callum (omma.gibson.athome)
Notes
Notes: svn path=/head/; revision=363029
Diffstat (limited to 'x11/xcb')
-rw-r--r--x11/xcb/Makefile2
-rw-r--r--x11/xcb/files/patch-Imakefile10
2 files changed, 11 insertions, 1 deletions
diff --git a/x11/xcb/Makefile b/x11/xcb/Makefile
index 68df584e833c..be5fe28cf6eb 100644
--- a/x11/xcb/Makefile
+++ b/x11/xcb/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xcb
PORTVERSION= 2.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
MASTER_SITES= http://oldhome.schmorp.de/marc/data/ \
http://ftp.lyx.org/pub/pcg/marc/ \
diff --git a/x11/xcb/files/patch-Imakefile b/x11/xcb/files/patch-Imakefile
new file mode 100644
index 000000000000..b605aadad806
--- /dev/null
+++ b/x11/xcb/files/patch-Imakefile
@@ -0,0 +1,10 @@
+--- Imakefile.orig 2002-11-25 15:28:17.000000000 +0000
++++ Imakefile
+@@ -20,6 +20,6 @@ OBJS = xcb.o
+ ComplexProgramTarget(xcb)
+
+ Xcb.ad: Xcb.ad.base
+- $(CPP) -P Xcb.ad.base $(GUI) > $@ # -P removes line directives.
++ $(CPP) $(GUI) -P Xcb.ad.base > $@ # -P removes line directives.
+
+ InstallAppDefaults(Xcb)