aboutsummaryrefslogtreecommitdiff
path: root/x11/xfce4-conf/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2009-03-02 16:29:48 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2009-03-02 16:29:48 +0000
commitd5fe11f3b29ae034cec7fb4438d0efe80b56ffbd (patch)
treeb453cd59ced6872e9da4444aa5985849efafba1a /x11/xfce4-conf/Makefile
parent367a1b469f842b555062c5c52d13a50209ed48e2 (diff)
downloadports-d5fe11f3b29ae034cec7fb4438d0efe80b56ffbd.tar.gz
ports-d5fe11f3b29ae034cec7fb4438d0efe80b56ffbd.zip
add xfce4-conf:
XFce 4 configuration mananger WWW: http://www.xfce.org/projects/libraries/
Notes
Notes: svn path=/head/; revision=229338
Diffstat (limited to 'x11/xfce4-conf/Makefile')
-rw-r--r--x11/xfce4-conf/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11/xfce4-conf/Makefile b/x11/xfce4-conf/Makefile
new file mode 100644
index 000000000000..3d1599310389
--- /dev/null
+++ b/x11/xfce4-conf/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: xfce4-conf
+# Date created: 28 August 2008
+# Whom: Oliver Lehmann <oliver@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-conf
+PORTVERSION= 4.6.0
+CATEGORIES= x11 xfce
+MASTER_SITES= ${MASTER_SITE_XFCE}
+DISTNAME= xfconf-${PORTVERSION}
+DIST_SUBDIR= xfce4
+
+MAINTAINER= oliver@FreeBSD.org
+COMMENT= XFce 4 configuration mananger
+
+LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+
+USE_AUTOTOOLS= libtool:15
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= glib20 gnometarget gnomehack gtk20 intltool intlhack pkgconfig
+USE_LDCONFIG= yes
+USE_XFCE= configenv libutil
+
+OPTIONS= GTKDOC "install the library documentation" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GTKDOC)
+BUILD_DEPENDS+= gtkdocize:${PORTSDIR}/textproc/gtk-doc
+CONFIGURE_ARGS+=--enable-gtk-doc
+.else
+CONFIGURE_ARGS+=--disable-gtk-doc
+.endif
+
+.include <bsd.port.post.mk>