aboutsummaryrefslogtreecommitdiff
path: root/x11/xloadimage
diff options
context:
space:
mode:
authorJean-Marc Zucconi <jmz@FreeBSD.org>2008-07-21 19:11:36 +0000
committerJean-Marc Zucconi <jmz@FreeBSD.org>2008-07-21 19:11:36 +0000
commit6799782b77a34c251f87ec1b5e0df53949c2844c (patch)
tree77f438229de614f6dcc2c3fa5ac220c0f119a643 /x11/xloadimage
parentaa266dbb06d8f0daae10f0b0ccfadce7cfd726e8 (diff)
downloadports-6799782b77a34c251f87ec1b5e0df53949c2844c.tar.gz
ports-6799782b77a34c251f87ec1b5e0df53949c2844c.zip
Add another 64-bit fix.
Notes
Notes: svn path=/head/; revision=217260
Diffstat (limited to 'x11/xloadimage')
-rw-r--r--x11/xloadimage/Makefile2
-rw-r--r--x11/xloadimage/files/patch-lp6423
2 files changed, 24 insertions, 1 deletions
diff --git a/x11/xloadimage/Makefile b/x11/xloadimage/Makefile
index 607a83b66f48..7ca68a9d5416 100644
--- a/x11/xloadimage/Makefile
+++ b/x11/xloadimage/Makefile
@@ -7,7 +7,7 @@
VERSION= 4.1
REVISION= 16
-PORTREVISION= 3
+PORTREVISION= 4
PORTNAME= xloadimage
PORTVERSION= ${VERSION}.${REVISION}
diff --git a/x11/xloadimage/files/patch-lp64 b/x11/xloadimage/files/patch-lp64
index 0344dc9a98ab..1391c5fab823 100644
--- a/x11/xloadimage/files/patch-lp64
+++ b/x11/xloadimage/files/patch-lp64
@@ -74,3 +74,26 @@
(*((byte *)(PTR) + 3) << 24))))))
+--- root.c.orig 2006-10-20 16:05:45.000000000 -0400
++++ root.c 2006-10-20 16:18:09.000000000 -0400
+@@ -68,16 +68,16 @@
+ Pixmap *pm;
+ Atom actual_type; /* NOTUSED */
+ int format;
+- int nitems;
+- int bytes_after;
++ unsigned long nitems;
++ unsigned long bytes_after;
+
+ /* intern the property name */
+ Atom atom = XInternAtom(dpy, RETAIN_PROP_NAME, 0);
+
+ /* look for existing resource allocation */
+ if ((XGetWindowProperty(dpy, w, atom, 0, 1, 1/*delete*/,
+- AnyPropertyType, &actual_type, &format, (unsigned long *)&nitems,
+- (unsigned long *)&bytes_after, (unsigned char **)&pm) == Success) &&
++ AnyPropertyType, &actual_type, &format, &nitems,
++ &bytes_after, (unsigned char **)&pm) == Success) &&
+ nitems == 1) {
+ if ((actual_type == XA_PIXMAP) && (format == 32) &&
+ (nitems == 1) && (bytes_after == 0)) {