aboutsummaryrefslogtreecommitdiff
path: root/x11/xmx
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>1999-06-28 23:03:58 +0000
committerChris Piazza <cpiazza@FreeBSD.org>1999-06-28 23:03:58 +0000
commitbc8d6179b1da729c51f0ed78c88ec83df37fe89d (patch)
tree11c0ff770b65dd3403f4ca9659330ccfae31c612 /x11/xmx
parent86689473b2794da89a97c9907d5653ace4c16d2d (diff)
downloadports-bc8d6179b1da729c51f0ed78c88ec83df37fe89d.tar.gz
ports-bc8d6179b1da729c51f0ed78c88ec83df37fe89d.zip
Xmx: an X protocol multiplexor. It is a standalone utility for
displaying an X windows session on multiple displays. It was developed at Brown University and has been in use there since 1988. PR: 12294 Submitted by: Oliver Breuninger <ob@seicom.NET>
Notes
Notes: svn path=/head/; revision=19887
Diffstat (limited to 'x11/xmx')
-rw-r--r--x11/xmx/Makefile22
-rw-r--r--x11/xmx/distinfo1
-rw-r--r--x11/xmx/files/patch-aa121
-rw-r--r--x11/xmx/pkg-comment1
-rw-r--r--x11/xmx/pkg-descr20
-rw-r--r--x11/xmx/pkg-plist1
6 files changed, 166 insertions, 0 deletions
diff --git a/x11/xmx/Makefile b/x11/xmx/Makefile
new file mode 100644
index 000000000000..e92e93188d00
--- /dev/null
+++ b/x11/xmx/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: xmx 1.1
+# Version required: 1.1
+# Date created: February 23, 1999
+# Whom: Oliver Breuninger <ob@seicom.NET>
+#
+# $Id: $
+
+DISTNAME= xmx-1.1
+CATEGORIES= x11
+MASTER_SITES= ftp://ftp.cs.brown.edu/pub/xmx/
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= ob@seicom.NET
+
+USE_X_PREFIX= yes
+
+MAN1= xmx.1
+
+post-install:
+ @strip ${PREFIX}/bin/xmx
+
+.include <bsd.port.mk>
diff --git a/x11/xmx/distinfo b/x11/xmx/distinfo
new file mode 100644
index 000000000000..711ee3e24332
--- /dev/null
+++ b/x11/xmx/distinfo
@@ -0,0 +1 @@
+MD5 (xmx-1.1.tar.Z) = 8ea77b5f3472ea549c4eed0f7a789978
diff --git a/x11/xmx/files/patch-aa b/x11/xmx/files/patch-aa
new file mode 100644
index 000000000000..e9bee16fd789
--- /dev/null
+++ b/x11/xmx/files/patch-aa
@@ -0,0 +1,121 @@
+--- Makefile.orig Wed Apr 13 09:22:21 1994
++++ Makefile Mon Jun 28 15:57:11 1999
+@@ -1,70 +1,52 @@
+-#
+-# Makefile for xmx
+-#
+-OPTFG= -O
+-DBGFG= -g -DDEBUG -DMALLOC_DEBUG
+-CFLAGS= -g
+-
+-LIB=
+-
+-XMX= xmx
+-OFILES=\
+- bufio.o\
+- connect.o\
+- error.o\
+- genreq.o\
+- main.o\
+- map.o\
+- pointer.o\
+- reply.o\
+- request.o\
+- resource.o\
+- socket.o
+-
+-CFILES= `echo $(OFILES) | sed 's/\.o/.c/g'`
+-DEBUGLIB= /usr/lib/debug/malloc.o /usr/lib/debug/mallocmap.o $(LIB)
+-
+-$(XMX): $(OFILES)
+- cc $(CFLAGS) -o $(XMX) $(OFILES) $(LIB)
++LIBPATH = -L${X11BASE}/lib
++INCPATH = -I${X11BASE}/include
+
+-debug:
+- make xmxd CFLAGS="$(DBGFG)" LIB="$(DEBUGLIB)"
+-
+-opt:
+- make xmx CFLAGS="$(OPTFG)"
+-
+-lint:
+- lint -hz $(CFILES)
++BIN = ${PREFIX}/bin
++MANPATH = ${PREFIX}/man
++LIB = -lX11 -lm
++OBJ = bufio.o connect.o error.o genreq.o main.o map.o \
++ pointer.o reply.o request.o resource.o socket.o
++
++TARGET_FILE = xmx
++
++# -02 = enable all optimazions
++# -s = make output smaller (without debug/link-informations)
++OPTION = ${CFLAGS}
++
++# if yu dont have "gcc" use instead of "gcc" "cc"
++CC ?= gcc
++
++all: $(TARGET_FILE)
++
++$(TARGET_FILE): $(OBJ)
++ $(CC) $(OPTION) -o $(TARGET_FILE) $(OBJ) $(LIBPATH) $(INCPATH) $(LIB)
++bufio.o: bufio.c
++ $(CC) $(OPTION) -c bufio.c $(LIBPATH) $(INCPATH)
++connect.o: connect.c
++ $(CC) $(OPTION) -c connect.c $(LIBPATH) $(INCPATH)
++error.o: error.c
++ $(CC) $(OPTION) -c error.c $(LIBPATH) $(INCPATH)
++genreq.o: genreq.c
++ $(CC) $(OPTION) -c genreq.c $(LIBPATH) $(INCPATH)
++main.o: main.c
++ $(CC) $(OPTION) -c main.c $(LIBPATH) $(INCPATH)
++map.o: map.c
++ $(CC) $(OPTION) -c map.c $(LIBPATH) $(INCPATH)
++pointer.o: pointer.c
++ $(CC) $(OPTION) -c pointer.c $(LIBPATH) $(INCPATH)
++reply.o: reply.c
++ $(CC) $(OPTION) -c reply.c $(LIBPATH) $(INCPATH)
++request.o: request.c
++ $(CC) $(OPTION) -c request.c $(LIBPATH) $(INCPATH)
++resource.o: resource.c
++ $(CC) $(OPTION) -c resource.c $(LIBPATH) $(INCPATH)
++socket.o: socket.c
++ $(CC) $(OPTION) -c socket.c $(LIBPATH) $(INCPATH)
+
+ clean:
+- rm -f *.o xmx xmxd core
+-
+-cs:
+- cp $(CFILES) xmx.h resource.h Makefile xmx.1 README doc/lab.me /cs/src/xmx
+-
+-howbig:
+- wc $(CFILES)
+-
+-src:
+- @echo $(CFILES) xmx.h resource.h
+-
+-listhost: listhost.c
+- cc -g -o listhost listhost.c -lX
+-
+-testhash: testhash.o hash.o error.o
+- cc -g -o testhash testhash.o hash.o error.o
+-
+-testsocket: testsocket.o socket.o error.o
+- cc -g -o testsocket testsocket.o socket.o error.o
+-
+-xcoltest: xcoltest.o
+- cc -g -o xcoltest xcoltest.o -lX11
+-
+-xcmaptest: xcmaptest.o
+- cc -g -o xcmaptest xcmaptest.o -lX11
+-
+-onecol: onecol.o
+- cc -g -o onecol onecol.o -lX11
++ rm -f *.o xmx xmxd *.core
+
+-genreq.o resource.o: resource.h
+-$(OFILES): xmx.h
++install: all
++ cp xmx $(BIN)
++ cp xmx.1 $(MANPATH)/man1
++ chmod 755 $(BIN)/xmx
diff --git a/x11/xmx/pkg-comment b/x11/xmx/pkg-comment
new file mode 100644
index 000000000000..c017bed355f1
--- /dev/null
+++ b/x11/xmx/pkg-comment
@@ -0,0 +1 @@
+An X protocol multiplexor
diff --git a/x11/xmx/pkg-descr b/x11/xmx/pkg-descr
new file mode 100644
index 000000000000..1b5a07b91853
--- /dev/null
+++ b/x11/xmx/pkg-descr
@@ -0,0 +1,20 @@
+
+XMX is an X protocol multiplexor. It is a standalone utility for displaying
+an X Windows session on multiple displays. XMX takes advantage of the
+networked nature of the X Window System by tapping the communication link
+between an X client and an X server. In this way, XMX works with any
+X clients and any X servers, without the need to modify either.
+
+It's tempting to call this "broadcast software," and that is certainly the
+effect. In reality, though, XMX is "multicast" software. It must know
+all the slave machines ahead of time and it connects to each one directly.
+XMX is more like mail than news.
+
+XMX connects to N servers like an X client, then accepts connections from
+M clients like an X server. One of those servers is designated the "master"
+from which input is directed to the clients. The other servers are "slaves."
+Slave servers receive only those protocol requests that are necessary for
+them to maintain a visual look-alike of the master server's display.
+
+This software was developed at Brown University for use in our electronic
+classroom. Some version of it has been in use here since 1988.
diff --git a/x11/xmx/pkg-plist b/x11/xmx/pkg-plist
new file mode 100644
index 000000000000..b603772a3aa4
--- /dev/null
+++ b/x11/xmx/pkg-plist
@@ -0,0 +1 @@
+bin/xmx