aboutsummaryrefslogtreecommitdiff
path: root/x11/xprompt
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-06-02 19:11:07 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2013-06-02 19:11:07 +0000
commit46139ef306b4c3d10f07e9d41d16d02f845155eb (patch)
tree00648c12c3f2cea85218f17df4a0dd777d8bd29a /x11/xprompt
parent95867b9df7f9d032d3187872afeede348cd4caa5 (diff)
downloadports-46139ef306b4c3d10f07e9d41d16d02f845155eb.tar.gz
ports-46139ef306b4c3d10f07e9d41d16d02f845155eb.zip
- Trim Makefile header
- Unbreak with clang
Notes
Notes: svn path=/head/; revision=319719
Diffstat (limited to 'x11/xprompt')
-rw-r--r--x11/xprompt/Makefile8
-rw-r--r--x11/xprompt/files/patch-xprompt.c11
2 files changed, 13 insertions, 6 deletions
diff --git a/x11/xprompt/Makefile b/x11/xprompt/Makefile
index 3eaefe217bce..ded1c4239601 100644
--- a/x11/xprompt/Makefile
+++ b/x11/xprompt/Makefile
@@ -1,15 +1,11 @@
-# New ports collection makefile for: xprompt
-# Date created: 23 March 1997
-# Whom: Matthew Hunt <mph@pobox.com>
-#
+# Created by: Matthew Hunt <mph@pobox.com>
# $FreeBSD$
-#
PORTNAME= xprompt
PORTVERSION= 1.4
PORTREVISION= 2
CATEGORIES= x11
-MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITES= LOCAL
MASTER_SITE_SUBDIR= mph
MAINTAINER= ports@FreeBSD.org
diff --git a/x11/xprompt/files/patch-xprompt.c b/x11/xprompt/files/patch-xprompt.c
new file mode 100644
index 000000000000..46494194d053
--- /dev/null
+++ b/x11/xprompt/files/patch-xprompt.c
@@ -0,0 +1,11 @@
+--- ./xprompt.c.orig 1995-08-07 18:25:13.000000000 +0000
++++ ./xprompt.c 2013-06-02 08:18:31.000000000 +0000
+@@ -387,7 +387,7 @@
+ void unparsegeometry();
+
+ main(argc, argv)
+-unsigned int argc;
++int argc;
+ char **argv;
+ {
+ register int i, j;