aboutsummaryrefslogtreecommitdiff
path: root/x11/xscreensaver
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-08-02 17:50:54 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-08-02 17:50:54 +0000
commit859f7ce80cb5c4e4dff115cb55d0414058e030ac (patch)
tree71ee4cc570ff557ed82f320415fe558c94e2d36b /x11/xscreensaver
parent8a8b2b184d40cbfcfc5cfe83ec70ea9e547c4f92 (diff)
downloadports-859f7ce80cb5c4e4dff115cb55d0414058e030ac.tar.gz
ports-859f7ce80cb5c4e4dff115cb55d0414058e030ac.zip
Put flameproof asbestos on and commit diversification of xscreensaver
and xscreensaver-gnome, so that GNOME components now is fully independent from the main xscreensaver port. Unfortunately all numerous attempts of GNOME team to put xscreensaver's maintainer into a co-operative mode failed, so that this commit goes in unreviewed. In addition, prevent xscreensaver from detecting gtk/glib/libxml-2.0 when it is not asked for, remove stale warning, use USE_GNOMENG and detect/use libintl properly. This expected to significantly decrease number of "xscreensaver doesn't work with GNOME" complains in freebsd-gnome mailing list. Approved by: maintainer's timeout
Notes
Notes: svn path=/head/; revision=63873
Diffstat (limited to 'x11/xscreensaver')
-rw-r--r--x11/xscreensaver/Makefile39
-rw-r--r--x11/xscreensaver/files/patch-ab27
-rw-r--r--x11/xscreensaver/files/patch-po::Makefile.in.in14
-rw-r--r--x11/xscreensaver/pkg-libwarning11
-rw-r--r--x11/xscreensaver/pkg-plist29
5 files changed, 65 insertions, 55 deletions
diff --git a/x11/xscreensaver/Makefile b/x11/xscreensaver/Makefile
index 3314abd9dae6..82e82dcab45c 100644
--- a/x11/xscreensaver/Makefile
+++ b/x11/xscreensaver/Makefile
@@ -18,37 +18,28 @@ MASTER_SITES= http://www.jwz.org/xscreensaver/
MAINTAINER?= DougB@FreeBSD.org
-LIB_DEPENDS= gle.3:${PORTSDIR}/graphics/gle \
- xml.5:${PORTSDIR}/textproc/libxml
+LIB_DEPENDS= gle.3:${PORTSDIR}/graphics/gle
USE_X_PREFIX= yes
USE_XPM= yes
USE_MESA= yes
USE_GMAKE= yes
-USE_GTK= yes
-WANT_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= libxml gtk12
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-pam --with-gl --with-gle --with-xpm --with-xml \
--with-hackdir=${PREFIX}/bin/xscreensaver-hacks/ \
--with-configdir=${PREFIX}/share/xscreensaver/config/ \
- --with-jpeg=${LOCALBASE}
-
-.include <bsd.port.pre.mk>
+ --with-jpeg=${LOCALBASE} \
+ --without-gnome --without-motif --without-pixbuf
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ X_CFLAGS="-I${LOCALBASE}/include/gnome-xml"
.if defined(XS_WITH_ALL_FORTUNES)
CONFIGURE_ARGS+= --with-fortune="/usr/games/fortune -sa"
.endif
-.if defined(HAVE_GNOME) && defined(WITH_GNOME)
-USE_GNOME= yes
-CONFIGURE_ARGS+= --with-gnome
-.else
-CONFIGURE_ARGS+= --without-gnome
-.undef HAVE_GNOME
-.endif
-
-CONFIGURE_ENV= X_CFLAGS=-I${LOCALBASE}/include/gnome-xml
-
MAN1= anemone.1 ant.1 apollonian.1 atlantis.1 attraction.1 blaster.1 \
blitspin.1 bouboule.1 boxed.1 braid.1 bsod.1 bubble3d.1 bubbles.1 \
bumps.1 cage.1 ccurve.1 circuit.1 compass.1 coral.1 critical.1 \
@@ -76,12 +67,6 @@ MAN1= anemone.1 ant.1 apollonian.1 atlantis.1 attraction.1 blaster.1 \
xscreensaver-getimage-file.1 xscreensaver-getimage-video.1 \
xscreensaver-getimage.1 xscreensaver-gl-helper.1 xscreensaver.1
-pre-fetch:
-.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
- @(/usr/bin/dialog --textbox ${MASTERDIR}/pkg-libwarning 15 70 || \
- /usr/bin/true)
-.endif
-
post-patch:
@ ${CP} ${WRKSRC}/configure ${WRKSRC}/configure.Patched
@ ${SED} -e 's#-lpthread#${PTHREAD_LIBS}#g' \
@@ -92,10 +77,4 @@ post-patch:
${WRKSRC}/hacks/glx/${file}
.endfor
-post-install:
- @(if test -x ${X11BASE}/bin/xscreensaver-hacks/webcollage-helper; then \
- ${ECHO} "bin/xscreensaver-hacks/webcollage-helper" | \
- ${CAT} - ${TMPPLIST} > ${TMPPLIST}.cat && \
- ${MV} ${TMPPLIST}.cat ${TMPPLIST}; fi)
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11/xscreensaver/files/patch-ab b/x11/xscreensaver/files/patch-ab
index d75477c6e95c..6c67406a6e40 100644
--- a/x11/xscreensaver/files/patch-ab
+++ b/x11/xscreensaver/files/patch-ab
@@ -1,6 +1,27 @@
---- configure.orig Fri May 31 20:43:47 2002
-+++ configure Wed Jun 5 00:58:27 2002
-@@ -17452,13 +17452,13 @@
+
+$FreeBSD$
+
+--- configure.orig Tue Jun 11 12:09:04 2002
++++ configure Thu Jul 18 15:09:54 2002
+@@ -12483,7 +12483,7 @@
+ pkg_check_version gmodule-2.0 2.0.0
+ pkg_check_version libxml-2.0 2.4.6
+ pkg_check_version libglade-2.0 1.99.0
+- have_gtk="$ok"
++ have_gtk="no"
+
+ if test "$have_gtk" = yes; then
+ have_gtk2=yes
+@@ -13116,7 +13116,7 @@
+
+ # First check for XML 2.x.
+ #
+- pkg_check_version libxml-2.0 2.4.6
++ pkg_check_version libxml 1.0
+
+ # If that didn't work (we don't have XML 2.x) and we *don't* have
+ # Gtk 2.x, then check to see if we have XML 1.x
+@@ -17491,13 +17491,13 @@
# Now that we know whether we have Gnome, we can decide where the XML
# config files get installed.
#
diff --git a/x11/xscreensaver/files/patch-po::Makefile.in.in b/x11/xscreensaver/files/patch-po::Makefile.in.in
new file mode 100644
index 000000000000..4a63ea151a0c
--- /dev/null
+++ b/x11/xscreensaver/files/patch-po::Makefile.in.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- po/Makefile.in.in 2002/06/06 19:53:47 1.1
++++ po/Makefile.in.in 2002/06/06 19:54:28
+@@ -101,7 +101,7 @@
+ exec_prefix = @exec_prefix@
+ #datadir = $(prefix)/@DATADIRNAME@ -- not for xscreensaver
+ datadir = @GNOME_DATADIR@
+-localedir = $(datadir)/locale
++localedir = $(prefix)/share/locale
+ #gnulocaledir = $(prefix)/share/locale -- not for xscreensaver
+ gnulocaledir = $(localedir)
+ #gettextsrcdir = $(prefix)/share/glib-2.0/gettext/po
diff --git a/x11/xscreensaver/pkg-libwarning b/x11/xscreensaver/pkg-libwarning
deleted file mode 100644
index 8cb4793662b4..000000000000
--- a/x11/xscreensaver/pkg-libwarning
+++ /dev/null
@@ -1,11 +0,0 @@
-There is currently a conflict between configure for this port,
-and pkgconfig. If your build fails, do the following:
-
-make clean
-pkg_delete -f pkgconfig*
-make install
-
-You may also want to upgrade your complete ports tree and
-then re-install glib12 and gtk12 which will also fix the
-pkg-config files for those two ports, and should offer a
-more permanent solution.
diff --git a/x11/xscreensaver/pkg-plist b/x11/xscreensaver/pkg-plist
index 7bc95872be1c..52fe126d20cc 100644
--- a/x11/xscreensaver/pkg-plist
+++ b/x11/xscreensaver/pkg-plist
@@ -1,4 +1,3 @@
-%%GNOME:%%bin/screensaver-properties-capplet
bin/xscreensaver
bin/xscreensaver-command
bin/xscreensaver-demo
@@ -153,16 +152,24 @@ bin/xscreensaver-hacks/xsublim
bin/xscreensaver-hacks/xteevee
bin/xscreensaver-hacks/zoom
lib/X11/app-defaults/XScreenSaver
-%%GNOME:%%share/gnome/apps/Settings/Desktop/screensaver-properties.desktop
-%%GNOME:%%share/gnome/control-center/Desktop/screensaver-properties.desktop
-%%GNOME:%%share/gnome/control-center/capplets/screensaver.desktop
-%%GNOME:%%share/gnome/pixmaps/screensaver-cmndln.xpm
-%%GNOME:%%share/gnome/pixmaps/screensaver-colorselector.xpm
-%%GNOME:%%share/gnome/pixmaps/screensaver-diagnostic.xpm
-%%GNOME:%%share/gnome/pixmaps/screensaver-locking.xpm
-%%GNOME:%%share/gnome/pixmaps/screensaver-power.xpm
-%%GNOME:%%share/gnome/pixmaps/screensaver-snap.xpm
-%%GNOME:%%share/gnome/pixmaps/xscreensaver.xpm
+share/locale/ca/LC_MESSAGES/xscreensaver.mo
+share/locale/da/LC_MESSAGES/xscreensaver.mo
+share/locale/de/LC_MESSAGES/xscreensaver.mo
+share/locale/es/LC_MESSAGES/xscreensaver.mo
+share/locale/et/LC_MESSAGES/xscreensaver.mo
+share/locale/fi/LC_MESSAGES/xscreensaver.mo
+share/locale/fr/LC_MESSAGES/xscreensaver.mo
+share/locale/hu/LC_MESSAGES/xscreensaver.mo
+share/locale/it/LC_MESSAGES/xscreensaver.mo
+share/locale/ja/LC_MESSAGES/xscreensaver.mo
+share/locale/ko/LC_MESSAGES/xscreensaver.mo
+share/locale/no/LC_MESSAGES/xscreensaver.mo
+share/locale/pl/LC_MESSAGES/xscreensaver.mo
+share/locale/pt/LC_MESSAGES/xscreensaver.mo
+share/locale/pt_BR/LC_MESSAGES/xscreensaver.mo
+share/locale/ru/LC_MESSAGES/xscreensaver.mo
+share/locale/sv/LC_MESSAGES/xscreensaver.mo
+share/locale/wa/LC_MESSAGES/xscreensaver.mo
share/xscreensaver/xscreensaver.xpm
share/xscreensaver/screensaver-cmndln.xpm
share/xscreensaver/screensaver-colorselector.xpm