aboutsummaryrefslogtreecommitdiff
path: root/x11/xvkbd
diff options
context:
space:
mode:
authorArmin Pirkovitsch <sperber@FreeBSD.org>2012-04-25 07:14:27 +0000
committerArmin Pirkovitsch <sperber@FreeBSD.org>2012-04-25 07:14:27 +0000
commit3ae359c1297532ba24c54be0d2a4ceaff38c1e58 (patch)
tree2b2212d96e60cc0b508a9b9fe962f714eda708a5 /x11/xvkbd
parent472c4568e6000763f3a90ba90e2fb3b0dbfdc056 (diff)
downloadports-3ae359c1297532ba24c54be0d2a4ceaff38c1e58.tar.gz
ports-3ae359c1297532ba24c54be0d2a4ceaff38c1e58.zip
- Update to 3.3
Approved by: beat (mentor)
Notes
Notes: svn path=/head/; revision=295455
Diffstat (limited to 'x11/xvkbd')
-rw-r--r--x11/xvkbd/Makefile2
-rw-r--r--x11/xvkbd/distinfo4
-rw-r--r--x11/xvkbd/files/patch-xvkbd.c109
-rw-r--r--x11/xvkbd/files/patch-xvkbd.man94
4 files changed, 100 insertions, 109 deletions
diff --git a/x11/xvkbd/Makefile b/x11/xvkbd/Makefile
index bb57a9633b58..a90608f1c23b 100644
--- a/x11/xvkbd/Makefile
+++ b/x11/xvkbd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xvkbd
-PORTVERSION= 3.2
+PORTVERSION= 3.3
CATEGORIES= x11
MASTER_SITES= http://homepage3.nifty.com/tsato/xvkbd/
diff --git a/x11/xvkbd/distinfo b/x11/xvkbd/distinfo
index 7f71cb8a53e3..985d098cfbfd 100644
--- a/x11/xvkbd/distinfo
+++ b/x11/xvkbd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xvkbd-3.2.tar.gz) = 93c4bdced9f13f22c367d990e98ffbc53f8210fa28a816fa9c610d86e78bf807
-SIZE (xvkbd-3.2.tar.gz) = 78617
+SHA256 (xvkbd-3.3.tar.gz) = 414ba22cbbcddbb67abebe2a8919dae62c0bbbcb110aa691389500ac68e1679e
+SIZE (xvkbd-3.3.tar.gz) = 79576
diff --git a/x11/xvkbd/files/patch-xvkbd.c b/x11/xvkbd/files/patch-xvkbd.c
index 89b0f13b91af..1e2a503e14f3 100644
--- a/x11/xvkbd/files/patch-xvkbd.c
+++ b/x11/xvkbd/files/patch-xvkbd.c
@@ -1,15 +1,6 @@
-Description: Assorted compilation and usage fixes.
- - fix a lot of compiler warnings
- - unbreak the build if XTEST is not selected
- - use snprintf() instead of sprintf() and strcpy(), just in case
- - fix the text of an error message
-Forwarded: no
-Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2010-06-11
-
---- xvkbd.c.orig
-+++ xvkbd.c
-@@ -460,8 +460,8 @@
+--- xvkbd.c.orig 2012-03-03 01:31:46.000000000 +0100
++++ xvkbd.c 2012-04-01 10:24:40.225558910 +0200
+@@ -463,8 +463,8 @@
static int altgr_mask = 0;
static KeySym altgr_keysym = NoSymbol;
@@ -20,7 +11,7 @@ Last-Update: 2010-06-11
static Display *target_dpy = NULL;
-@@ -472,7 +472,7 @@
+@@ -475,7 +475,7 @@
static Pixmap xvkbd_pixmap = None;
static int AddKeysym(KeySym keysym, Boolean top); /* forward */
@@ -29,7 +20,7 @@ Last-Update: 2010-06-11
static void MakeKeyboard(Boolean remake);
static void MakeKeypad(Widget form, Widget from_vert, Widget from_horiz);
static void MakeSunFunctionKey(Widget form, Widget from_vert, Widget from_horiz);
-@@ -481,6 +481,8 @@
+@@ -484,6 +484,8 @@
static void PopupFunctionKeyEditor(void);
static void DeleteWindowProc(Widget w, XEvent *event, String *pars, Cardinal *n_pars);
@@ -38,7 +29,7 @@ Last-Update: 2010-06-11
/*
* Search for window which has specified instance name (WM_NAME)
* or class name (WM_CLASS).
-@@ -489,8 +491,7 @@
+@@ -492,8 +494,7 @@
{
Window w;
Window *children, dummy;
@@ -48,7 +39,7 @@ Last-Update: 2010-06-11
XClassHint hint;
char *win_name;
-@@ -774,7 +775,9 @@
+@@ -777,7 +778,9 @@
*/
static void SendEvent(XKeyEvent *event)
{
@@ -58,10 +49,10 @@ Last-Update: 2010-06-11
if (!appres.no_sync) {
XSync(event->display, FALSE);
-@@ -1055,11 +1058,11 @@
+@@ -1061,11 +1064,11 @@
#ifdef USE_XTEST
- if (appres.xtest) {
+ if (appres.xtest && press_release == 0) {
- Window root, child;
+ Window troot, child;
int root_x, root_y, x, y;
@@ -72,7 +63,7 @@ Last-Update: 2010-06-11
event.type = KeyRelease;
event.state = 0;
-@@ -1209,7 +1212,7 @@
+@@ -1221,7 +1224,7 @@
static void SetDefaultDictionary(void)
{
@@ -81,7 +72,7 @@ Last-Update: 2010-06-11
XtVaSetValues(props_dict_entry, XtNstring, dict_filename, NULL);
}
-@@ -1224,7 +1227,7 @@
+@@ -1236,7 +1239,7 @@
struct WORDLIST *p;
if (strcmp(cur_dict_filename, dict_filename) == 0) return;
@@ -90,7 +81,7 @@ Last-Update: 2010-06-11
if (!first) {
int cnt = 0;
-@@ -1274,7 +1277,7 @@
+@@ -1286,7 +1289,7 @@
static void AddToCompletionText(KeySym keysym)
{
@@ -99,7 +90,7 @@ Last-Update: 2010-06-11
struct WORDLIST *node_ptr;
if (completion_entry != None) {
-@@ -1364,7 +1367,7 @@
+@@ -1376,7 +1379,7 @@
ReadCompletionDictionary();
@@ -108,7 +99,7 @@ Last-Update: 2010-06-11
XtVaSetValues(completion_entry, XtNlabel, msg, NULL);
completion_text[0] = '\0';
-@@ -1379,11 +1382,11 @@
+@@ -1391,11 +1394,11 @@
*/
static void KeyPressed(Widget w, char *key, char *data);
@@ -123,7 +114,7 @@ Last-Update: 2010-06-11
int val;
Window target_root, child, junk_w;
int junk_i;
-@@ -1408,8 +1411,7 @@
+@@ -1420,8 +1423,7 @@
} else {
len = cp2 - cp - 1;
if (sizeof(key) <= len) len = sizeof(key) - 1;
@@ -133,7 +124,7 @@ Last-Update: 2010-06-11
KeyPressed(None, key, NULL);
cp = cp2;
}
-@@ -1429,11 +1431,12 @@
+@@ -1468,11 +1470,12 @@
if ('1' <= *cp && *cp <= '9') {
usleep((*cp - '0') * 100000);
} else {
@@ -147,7 +138,7 @@ Last-Update: 2010-06-11
cp++;
if ('1' <= *cp && *cp <= '9') {
if (appres.debug) fprintf(stderr, "XTestFakeButtonEvent(%d)\n", *cp - '0');
-@@ -1444,10 +1447,18 @@
+@@ -1483,10 +1486,18 @@
fprintf(stderr, "%s: no digit after \"\\m\"\n",
PROGRAM_NAME);
}
@@ -167,7 +158,7 @@ Last-Update: 2010-06-11
target_root = RootWindow(target_dpy, DefaultScreen(target_dpy));
XQueryPointer(target_dpy, target_root, &junk_w, &child,
&cur_x, &cur_y, &junk_i, &junk_i, &junk_u);
-@@ -1515,7 +1526,7 @@
+@@ -1554,7 +1565,7 @@
char name1[50];
Widget w;
@@ -176,7 +167,7 @@ Last-Update: 2010-06-11
w = XtNameToWidget(toplevel, name1);
if (w != None) {
if (strstr(name, "Focus") != NULL) {
-@@ -1544,13 +1555,13 @@
+@@ -1583,13 +1594,13 @@
static void RefreshShiftState(Boolean force)
{
static Boolean first = TRUE;
@@ -195,7 +186,7 @@ Last-Update: 2010-06-11
int first_row, row, col;
Boolean shifted;
char *label;
-@@ -1641,7 +1652,7 @@
+@@ -1680,7 +1691,7 @@
Window root, child;
int root_x, root_y, x, y;
@@ -204,7 +195,7 @@ Last-Update: 2010-06-11
XKeyEvent event;
-@@ -1657,28 +1668,28 @@
+@@ -1696,28 +1707,28 @@
event.same_screen = TRUE;
event.state = 0;
@@ -238,7 +229,7 @@ Last-Update: 2010-06-11
event.keycode = XKeysymToKeycode(target_dpy, XK_Meta_L);
event.type = (shift_state & meta_mask) ? KeyPress : KeyRelease;
SendEvent(&event);
-@@ -1739,7 +1750,7 @@
+@@ -1778,7 +1789,7 @@
XtVaGetValues(w, XtNx, &x0, XtNy, &y0, NULL);
XGetGeometry(dpy, XtWindow(w), &root, &x1, &y1, &wd, &ht, &bd, &dp);
@@ -247,7 +238,7 @@ Last-Update: 2010-06-11
return geom;
}
-@@ -1801,7 +1812,7 @@
+@@ -1840,7 +1851,7 @@
if (key != NULL) {
if (strcmp(key, "default") != 0) {
sscanf(key, "%29[^/]/%29s", customization, lang);
@@ -256,7 +247,7 @@ Last-Update: 2010-06-11
xenv = XtResolvePathname(dpy, "app-defaults", name, NULL, NULL, NULL, 0, NULL);
if (xenv == NULL) {
fprintf(stderr, "%s: app-default file \"%s\" not installed\n",
-@@ -1809,12 +1820,10 @@
+@@ -1848,12 +1859,10 @@
}
}
@@ -271,7 +262,7 @@ Last-Update: 2010-06-11
putenv(env_xenv);
} else if (getenv("XENVIRONMENT") != NULL) {
putenv("XENVIRONMENT=");
-@@ -1923,6 +1932,7 @@
+@@ -1962,6 +1971,7 @@
XtVaGetValues(XtNameToWidget(props_panel, "*jump_pointer"),
XtNstate, &appres.jump_pointer, NULL);
@@ -279,7 +270,7 @@ Last-Update: 2010-06-11
appres.key_click_duration = (int)XawToggleGetCurrent(click_buttons);
appres.autoclick_delay = (int)XawToggleGetCurrent(autoclick_buttons);
-@@ -1989,7 +1999,7 @@
+@@ -2028,7 +2038,7 @@
if (props_panel == None) {
Widget label, button;
Widget form, w;
@@ -288,7 +279,7 @@ Last-Update: 2010-06-11
int val;
props_panel = XtVaCreatePopupShell("props_panel", transientShellWidgetClass,
-@@ -2015,7 +2025,7 @@
+@@ -2054,7 +2064,7 @@
click_buttons = button;
for (val = 1; val <= 50; val *= 2) {
char s1[10];
@@ -297,7 +288,7 @@ Last-Update: 2010-06-11
button = XtVaCreateManagedWidget(s1, toggleWidgetClass,
form, XtNfromVert, w, XtNfromHoriz, button,
XtNradioData, (XtPointer)val,
-@@ -2037,7 +2047,7 @@
+@@ -2076,7 +2086,7 @@
autoclick_buttons = button;
for (val = 500; val <= 1000; val += 100) {
char s1[10];
@@ -306,7 +297,7 @@ Last-Update: 2010-06-11
button = XtVaCreateManagedWidget(s1, toggleWidgetClass,
form, XtNfromVert, w, XtNfromHoriz, button,
XtNradioData, (XtPointer)val,
-@@ -2099,7 +2109,7 @@
+@@ -2138,7 +2148,7 @@
focused_subwindow = None;
if (target_dpy != NULL && target_dpy != dpy) XCloseDisplay(target_dpy);
@@ -315,7 +306,7 @@ Last-Update: 2010-06-11
for (cp = name; isascii(*cp) && isprint(*cp); cp++) ;
*cp = '\0';
-@@ -2292,7 +2302,7 @@
+@@ -2342,7 +2352,7 @@
}
}
@@ -324,7 +315,7 @@ Last-Update: 2010-06-11
{
XWindowAttributes attr;
XGetWindowAttributes(dpy, XtWindow(toplevel), &attr);
-@@ -2594,7 +2604,7 @@
+@@ -2647,7 +2657,7 @@
XtAddCallback(w, XtNcallback, (XtCallbackProc)KeyPressed, (XtPointer)name);
if (label != NULL) {
@@ -333,7 +324,7 @@ Last-Update: 2010-06-11
if (strcmp(str, "space") == 0) strcpy(str, "");
len = strlen(str);
if (3 <= len) {
-@@ -2666,9 +2676,9 @@
+@@ -2719,9 +2729,9 @@
|| (strncmp(keypad_shift[row][col], "KP_", 3) == 0
&& isdigit(keypad_shift[row][col][3])))
color = appres.general_background;
@@ -345,7 +336,7 @@ Last-Update: 2010-06-11
key = MakeKey(keypad_box, XtNewString(name),
keypad_label[row][col], color);
XtVaSetValues(key, XtNfont, font, NULL);
-@@ -2770,12 +2780,12 @@
+@@ -2823,12 +2833,12 @@
Widget form, key, left;
Pixel color;
XFontStruct *font;
@@ -360,7 +351,7 @@ Last-Update: 2010-06-11
#include "xvkbd.xbm"
#include "iconify.xbm"
-@@ -2795,7 +2805,7 @@
+@@ -2848,7 +2858,7 @@
for (row = first_row; row < NUM_KEY_ROWS; row++) {
if (keys_normal[row][0] == NULL) continue;
@@ -369,7 +360,7 @@ Last-Update: 2010-06-11
key_box[row] = XtVaCreateManagedWidget(name, formWidgetClass, form, NULL);
key_box[row + 1] = None;
if (row != first_row)
-@@ -2805,7 +2815,7 @@
+@@ -2858,7 +2868,7 @@
left = None;
for (col = 0; keys_normal[row][col] != NULL; col++) {
@@ -378,7 +369,7 @@ Last-Update: 2010-06-11
if (strcmp(name, "MainMenu") == 0) {
Widget iconify_button = None;
-@@ -2847,11 +2857,11 @@
+@@ -2900,11 +2910,11 @@
color = appres.general_background;
font = appres.general_font;
if (isalpha(name[0])) font = appres.letter_font;
@@ -393,7 +384,7 @@ Last-Update: 2010-06-11
/* keys can be removed by setting its width to 1 */
XtDestroyWidget(key);
key = None;
-@@ -2888,7 +2898,7 @@
+@@ -2941,7 +2951,7 @@
Window root;
int x1, y1;
unsigned int wd, ht, bd, dp;
@@ -402,7 +393,7 @@ Last-Update: 2010-06-11
XGetGeometry(dpy, XtWindow(toplevel), &root, &x1, &y1, &wd, &ht, &bd, &dp);
max_wd = XtScreen(toplevel)->width * appres.max_width_ratio;
-@@ -2906,16 +2916,16 @@
+@@ -2959,16 +2969,16 @@
if (!appres.debug && key_box[first_row] != None) {
if (appres.keypad) {
@@ -424,7 +415,7 @@ Last-Update: 2010-06-11
}
}
if (0 < strlen(appres.geometry)) {
-@@ -3015,19 +3025,20 @@
+@@ -3068,19 +3078,20 @@
home = getenv("HOME");
if (appres.key_file[0] != '/' && home != NULL
&& strlen(home) + strlen(appres.key_file) + 1 < sizeof(fkey_filename))
@@ -450,7 +441,7 @@ Last-Update: 2010-06-11
appres.quick_modifiers = val;
else if (strcmp(key, "shift_lock") == 0)
appres.shift_lock = val;
-@@ -3047,7 +3058,7 @@
+@@ -3100,7 +3111,7 @@
appres.jump_pointer = val;
else if (strcmp(key, "dict_file") == 0) {
sscanf(&str[1], "%*s %s", &key);
@@ -459,7 +450,7 @@ Last-Update: 2010-06-11
}
} else if (isalpha(str[0])) {
len = strlen(str);
-@@ -3102,9 +3113,9 @@
+@@ -3155,9 +3166,9 @@
if (key == NULL)
strcpy(key2, "");
else if (strncmp(key, "Shift-", strlen("Shift-")) == 0)
@@ -471,16 +462,16 @@ Last-Update: 2010-06-11
if (strcmp(cur_fkey, key2) != 0) {
if (strlen(cur_fkey) != 0) {
-@@ -3127,7 +3138,7 @@
+@@ -3180,7 +3191,7 @@
prefix = "";
if (cur_fkey_value_mode[0] == 'c') prefix = "!";
- else if (fkey_value[0] == '!') prefix = "\\";
+ else if (fkey_value[0] == '!' || fkey_value[0] == '\\') prefix = "\\";
- sprintf(sp->value, "%s %s%s", cur_fkey, prefix, fkey_value);
+ snprintf(sp->value, len + strlen(fkey_value) + 5, "%s %s%s", cur_fkey, prefix, fkey_value);
} else { /* empty string - remove the entry for the function key */
if (sp != NULL) {
if (sp2 != NULL) sp2->next = sp->next;
-@@ -3147,10 +3158,10 @@
+@@ -3200,10 +3211,10 @@
FKeyValueMenuSelected(None, (value[0] == '!') ? "command" : "string");
if (value[0] == '!' || value[0] == '\\') value = value + 1;
@@ -493,7 +484,7 @@ Last-Update: 2010-06-11
}
}
}
-@@ -3213,9 +3224,9 @@
+@@ -3266,9 +3277,9 @@
for (j = 0; j <= 1; j++) {
for (i = 1; i <= appres.editable_function_keys; i++) {
if (j == 0)
@@ -505,7 +496,7 @@ Last-Update: 2010-06-11
key = XtNewString(label);
menu_entry = XtVaCreateManagedWidget(key, smeBSBObjectClass, menu, NULL);
XtAddCallback(menu_entry, XtNcallback, (XtCallbackProc)FKeyMenuSelected,
-@@ -3277,8 +3288,8 @@
+@@ -3330,8 +3341,8 @@
else if (shift_state & ControlMask) prefix = 'c';
else if (shift_state & ShiftMask) prefix = 's';
}
@@ -516,7 +507,7 @@ Last-Update: 2010-06-11
len = strlen(label);
for (sp = fkey_list; sp != NULL; sp = sp->next) {
-@@ -3336,8 +3347,10 @@
+@@ -3389,8 +3400,10 @@
{
StopAutoclick();
@@ -527,7 +518,7 @@ Last-Update: 2010-06-11
}
static void ShowBalloon(Widget w, XEvent *event, String *pars, Cardinal *n_pars)
-@@ -3418,7 +3431,7 @@
+@@ -3471,7 +3484,7 @@
static void VisibilityChanged(Widget w, XEvent *event,
String *pars, Cardinal *n_pars)
{
@@ -536,7 +527,7 @@ Last-Update: 2010-06-11
static time_t t1 = 0;
time_t t2;
-@@ -3466,7 +3479,9 @@
+@@ -3519,7 +3532,9 @@
Boolean open_keypad_panel = FALSE;
char ch;
Window child;
@@ -546,7 +537,7 @@ Last-Update: 2010-06-11
argc1 = argc;
argv1 = malloc(sizeof(char *) * (argc1 + 5));
-@@ -3664,14 +3679,14 @@
+@@ -3719,14 +3734,14 @@
if (locale == NULL) {
return cur_locale;
} else if (category == LC_ALL) {
diff --git a/x11/xvkbd/files/patch-xvkbd.man b/x11/xvkbd/files/patch-xvkbd.man
index 91bba16885af..f3124272b1d3 100644
--- a/x11/xvkbd/files/patch-xvkbd.man
+++ b/x11/xvkbd/files/patch-xvkbd.man
@@ -1,10 +1,5 @@
-Description: Escape a lot of minus signs.
-Forwarded: no
-Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2010-06-11
-
---- xvkbd.man.orig
-+++ xvkbd.man
+--- xvkbd.man.orig 2012-03-03 01:55:00.000000000 +0100
++++ xvkbd.man 2012-04-01 10:31:11.073558446 +0200
@@ -29,7 +29,7 @@
.PP
\fIIMPORTANT NOTE:\fP
@@ -14,7 +9,7 @@ Last-Update: 2010-06-11
or you will have serious security risk.
.SH "Environment"
-@@ -245,13 +245,13 @@
+@@ -246,13 +246,13 @@
.SH " Options"
\fIxvkbd\fP accept following command line options, in addition to
@@ -31,7 +26,7 @@ Last-Update: 2010-06-11
Make \fIxvkbd\fP to use \fIXSendEvent()\fP to simulate keyboard events,
as it was in \fIxvkbd\fP version 1.0.
\fIxvkbd\fP version 1.1 and later will try to use XTEST extension instead
-@@ -262,14 +262,14 @@
+@@ -263,14 +263,14 @@
.sp 0.5
Resource `\fBxvkbd.xtest: false\fP' has the same function.
.TP 4
@@ -49,7 +44,7 @@ Last-Update: 2010-06-11
Make \fIxvkbd\fP not to jump the pointer when sending events.
In the default, \fIxvkbd\fP will temporary jump the pointer to the focused window,
if input focus is set explicitly via \fIFocus\fP button,
-@@ -277,14 +277,14 @@
+@@ -278,14 +278,14 @@
.sp 0.5
Resource `\fBxvkbd.jumpPointer: false\fP' has the same function.
.TP 4
@@ -66,7 +61,7 @@ Last-Update: 2010-06-11
Make labels on keys in the \fIxvkbd\fP window
to be set independently for each of four shift states,
not shifted, \fIShift\fP, \fIAltGr\fP and \fIShift\fP-\fIAltGr\fP.
-@@ -295,22 +295,22 @@
+@@ -296,22 +296,22 @@
.sp 0.5
Resource `\fBxvkbd.modalKeytop: true\fP' has the same function.
.TP 4
@@ -96,7 +91,7 @@ Last-Update: 2010-06-11
Do not auto-repeat even if key is depressed long time.
.sp 0.5
If auto-repeat is enabled (this is the default),
-@@ -322,31 +322,31 @@
+@@ -323,31 +323,31 @@
.sp 0.5
Resource `\fBxvkbd.autoRepeat: false\fP' has the same function.
.TP 4
@@ -135,7 +130,7 @@ Last-Update: 2010-06-11
.sp 0.5
If this option is specified,
\fIxvkbd\fP will not open its window
-@@ -386,22 +386,22 @@
+@@ -394,22 +394,22 @@
.IP " - " 6
\fB\\m\fP\fIdigit\fP - simulate click of the specified mouse button
.TP 4
@@ -165,7 +160,7 @@ Last-Update: 2010-06-11
Specify the ID
(hexadecimal value leaded with `\fB0x\fP', or decimal value),
the name (instance name or class name) of the window,
-@@ -419,10 +419,10 @@
+@@ -427,10 +427,10 @@
If there are two or more windows which have the name specified with this option,
the window which was found first will be selected.
.TP 4
@@ -178,7 +173,7 @@ Last-Update: 2010-06-11
.sp 0.5
If you want to set input focus to the widget \fBfoo.bar.zot\fP,
you can write \fBzot\fP, \fBbar.zot\fP or \fBfoo.bar.zot\fP
-@@ -433,20 +433,20 @@
+@@ -441,24 +441,24 @@
For example,
.sp
.in +4
@@ -189,8 +184,13 @@ Last-Update: 2010-06-11
will enter the string ``\fBabc\fP'' to the ``Search Term'' field
of a \fBxarchie\fP window.
.TP 4
+-.BI "-remote-display " display
++.BI "\-remote-display " display
+ Specify the display (in the meaning of the X Window System) to connect;
+ see also \fIConnect to Remote Display...\fP.
+ .TP 4
-.B "-true-keypad"
-+.B "\-true\-keypad"
++.B "\-true-keypad"
If this option is specified,
\fIxvkbd\fP will attempt to use \fIkeysym\fPs such as
\fIXK_KP_1\fP instead of \fIXK_1\fP.
@@ -202,7 +202,7 @@ Last-Update: 2010-06-11
Specify the default dictionary (list of words) file to be used for
word completion.
The `\fICompletion Dictionary\fP' filename
-@@ -456,7 +456,7 @@
+@@ -468,7 +468,7 @@
.sp 0.5
See also ``Making your own completion dictionary''.
.TP 4
@@ -211,7 +211,7 @@ Last-Update: 2010-06-11
Make \fIxvkbd\fP window can be minimized (iconified)
even if no window manager is in use.
When this feature is enabled,
-@@ -465,7 +465,7 @@
+@@ -477,7 +477,7 @@
.sp 0.5
Resource `\fBxvkbd.minimizable: true\fP' has the same function.
.TP 4
@@ -220,7 +220,7 @@ Last-Update: 2010-06-11
Disable invocation of external commands,
including user assigned command and the online manual reader.
Connection to another displays would also be disabled.
-@@ -473,25 +473,25 @@
+@@ -485,25 +485,25 @@
.sp 0.5
Resource `\fBxvkbd.secure: true\fP' has the same function.
.TP 4
@@ -251,7 +251,7 @@ Last-Update: 2010-06-11
to apply this for those four modifiers.
Maybe this can be useful when attempting to decorate
the mouse operations with the modifiers.
-@@ -515,89 +515,89 @@
+@@ -527,89 +527,89 @@
.SH "Screen Shot"
.TP 4
Default (US)
@@ -352,23 +352,23 @@ Last-Update: 2010-06-11
.SH "Download"
.TP 4
\fILatest Official Release\fP
--\fIhttp://homepage3.nifty.com/tsato/xvkbd/xvkbd-3.2.tar.gz\fP
-+\fIhttp://homepage3.nifty.com/tsato/xvkbd/xvkbd\-3.2.tar.gz\fP
+-\fIhttp://homepage3.nifty.com/tsato/xvkbd/xvkbd-3.3.tar.gz\fP
++\fIhttp://homepage3.nifty.com/tsato/xvkbd/xvkbd\-3.3.tar.gz\fP
.br
- - source of version 3.2 (2010-03-14)
+ - source of version 3.3 (2012-03-03)
.TP 4
previous release
+-http://homepage3.nifty.com/tsato/xvkbd/xvkbd-3.2.tar.gz
++http://homepage3.nifty.com/tsato/xvkbd/xvkbd\-3.2.tar.gz
+ .br
+ - source of version 3.2 (2010-03-14)
+ .sp 0.5
-http://homepage3.nifty.com/tsato/xvkbd/xvkbd-3.1.tar.gz
+http://homepage3.nifty.com/tsato/xvkbd/xvkbd\-3.1.tar.gz
.br
- source of version 3.1 (2010-01-17)
- .sp 0.5
--http://homepage3.nifty.com/tsato/xvkbd/xvkbd-3.0.tar.gz
-+http://homepage3.nifty.com/tsato/xvkbd/xvkbd\-3.0.tar.gz
- .br
- - source of version 3.0 (2008-05-05)
.PP
-@@ -634,8 +634,8 @@
+@@ -646,8 +646,8 @@
.IP " o " 4
set the filename to the \fB$XENVIRONMENT\fP environment variable, or
.IP " o " 4
@@ -379,7 +379,7 @@ Last-Update: 2010-06-11
.IP " o " 4
put them in application default directory as \fBXVkbd\fP.
.PP
-@@ -647,11 +647,11 @@
+@@ -659,11 +659,11 @@
system's application default directory specified with
\fB$XFILESEACHPATH\fP environment variable,
or else the directory specified when compiling the X
@@ -393,7 +393,7 @@ Last-Update: 2010-06-11
near top of the file.
.PP
\fIxvkbd\fP is distributed with some application default files,
-@@ -682,7 +682,7 @@
+@@ -694,7 +694,7 @@
to display only the labels for the current shift state,
instead of trying to always display all of them in the small keytop.
.PP
@@ -402,7 +402,7 @@ Last-Update: 2010-06-11
.SH " Removing Unwanted Keys"
Keys on \fIxvkbd\fP window can be removed by setting its width to 1.
-@@ -753,12 +753,12 @@
+@@ -765,12 +765,12 @@
In all of those resources, each keys are separated by spaces,
and rows of keys are terminated with `\fB \\n\\\fP'
(note that `\fB\\n\fP' must have space before it).
@@ -418,7 +418,7 @@ Last-Update: 2010-06-11
will make \fIxvkbd\fP to use the German layout.
For another method to activate those settings, please refer
"How to Customize \fIxvkbd\fP" above.
-@@ -820,7 +820,7 @@
+@@ -832,7 +832,7 @@
.IP " o " 4
If \fIAlt\fP or \fIMeta\fP is not defined as modifier,
the key can't be used as modifier.
@@ -427,7 +427,7 @@ Last-Update: 2010-06-11
.IP " o " 4
\fINum Lock\fP (and maybe other modifiers) on the physical keyboard
may not work correctly when \fIxvkbd\fP is in use.
-@@ -831,10 +831,10 @@
+@@ -843,10 +843,10 @@
http://homepage3.nifty.com/tsato/xvkbd/faq.html
.TP 4
Making your own completion dictionary
@@ -441,7 +441,7 @@ Last-Update: 2010-06-11
.TP 4
Note about how to send key events
http://homepage3.nifty.com/tsato/xvkbd/events.html
-@@ -855,26 +855,26 @@
+@@ -867,26 +867,26 @@
can be entered using dedicated key combinations.
.IP " - " 6
Make keyboard layout not to be disturbed when
@@ -473,7 +473,7 @@ Last-Update: 2010-06-11
.IP " - " 6
\fIxvkbd\fP can now send keys
with \fIMode_switch\fP (\fIAltGr\fP) modifier,
-@@ -882,9 +882,9 @@
+@@ -894,9 +894,9 @@
.IP " - " 6
\fIxvkbd\fP now support \fIAltGr\fP key
so that German (and some other) keyboard layout can be used.
@@ -485,7 +485,7 @@ Last-Update: 2010-06-11
in the distribution, which modifies keyboard layout
and put some non-ASCII keys on the \fIxvkbd\fP window.
.IP " - " 6
-@@ -900,7 +900,7 @@
+@@ -912,7 +912,7 @@
not shifted, \fIShift\fP, \fIAltGr\fP and \fIShift\fP-\fIAltGr\fP.
(thanks, Jim)
.IP " - " 6
@@ -494,7 +494,7 @@ Last-Update: 2010-06-11
.TP 4
Version 1.2 (2001-02-18)
.IP " - " 6
-@@ -928,7 +928,7 @@
+@@ -940,7 +940,7 @@
.TP 4
Version 1.3 (2001-03-19)
.IP " - " 6
@@ -503,7 +503,7 @@ Last-Update: 2010-06-11
(contributed from Marcel Portner)
.IP " - " 6
\fIxvkbd\fP now catches MappingNotify event and reload the new mapping.
-@@ -978,7 +978,7 @@
+@@ -990,7 +990,7 @@
.TP 4
Version 1.6 (2001-11-10)
.IP " - " 6
@@ -512,7 +512,7 @@ Last-Update: 2010-06-11
(thanks, Gregory)
.IP " - " 6
New entry `\fIUse XTEST Extension?\fP' is added
-@@ -997,7 +997,7 @@
+@@ -1009,7 +1009,7 @@
Show/hide of the keypad and funcion keys on the main window
can now be toggled from the main menu.
.IP " - " 6
@@ -521,7 +521,7 @@ Last-Update: 2010-06-11
(contributed from Jean-Pierre Demailly)
.TP 4
Version 2.1 (2002-01-27)
-@@ -1005,9 +1005,9 @@
+@@ -1017,9 +1017,9 @@
When height of the \fIxvkbd\fP window is smaller than
\fBXVkbd.modalThreshold\fP,
\fIxvkbd\fP will now automatically switch the keytop
@@ -533,7 +533,7 @@ Last-Update: 2010-06-11
would send wrong keys - this problem is now fixed.
.IP " - " 6
Target \fBdistclean\fP in the \fBImakefile\fP is renamed
-@@ -1020,8 +1020,8 @@
+@@ -1032,8 +1032,8 @@
String assigned to function keys can now be edited on a panel popped up via
"\fIEdit Function Keys...\fP" in the main menu.
.IP " - " 6
@@ -544,7 +544,7 @@ Last-Update: 2010-06-11
its standard input (stdin) to get the string to be sent.
.IP " - " 6
In the previous release,
-@@ -1050,7 +1050,7 @@
+@@ -1062,7 +1062,7 @@
United Kingdom
and Latin-1.
.IP " - " 6
@@ -553,7 +553,7 @@ Last-Update: 2010-06-11
- this problem is now fixed.
.TP 4
Version 2.4 (2002-10-02)
-@@ -1111,24 +1111,24 @@
+@@ -1123,24 +1123,24 @@
.IP " - " 6
It is now possible to minimize (iconify) the main window
even if no window manager is in use.
@@ -585,7 +585,7 @@ Last-Update: 2010-06-11
and maybe useful when run \fIxvkbd\fP from a display manager.
.TP 4
Version 2.7a (2005-05-07)
-@@ -1144,17 +1144,17 @@
+@@ -1156,17 +1156,17 @@
Reference to the target bitmap is changed from
\fB/usr/X11R6/include/X11/bitmaps/target\fP to \fB/usr/include/X11/bitmaps/target\fP.
.IP " - " 6
@@ -607,7 +607,7 @@ Last-Update: 2010-06-11
via \fB\\x\fP, \fB\\y\fP and \fB\\m\fP special sequences.
.TP 4
Version 3.0 (2008-05-05)
-@@ -1169,7 +1169,7 @@
+@@ -1181,7 +1181,7 @@
.IP " - " 6
Changed the default setting for automatic click to OFF, which was set ON in the previous release in error and caused confusion.
.IP " - " 6
@@ -616,7 +616,7 @@ Last-Update: 2010-06-11
.IP " - " 6
Up to 25x25 keys can now be supported both for the main keyboard and the keypad.
.IP " - " 6
-@@ -1177,7 +1177,7 @@
+@@ -1189,7 +1189,7 @@
.IP " - " 6
Fixed errors in some keyboard layout files (Korean, Slovene, UK).
.IP " - " 6