aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2016-05-04 03:12:35 +0000
committerCy Schubert <cy@FreeBSD.org>2016-05-04 03:12:35 +0000
commitf6d424b24071402fa15a21300d267f58e858976e (patch)
tree8aa95aab24fb2207dc4381a6e304f1904304683f /x11
parent0a503d4c6b875e8a48d3706796607dc64ee27b2a (diff)
downloadports-f6d424b24071402fa15a21300d267f58e858976e.tar.gz
ports-f6d424b24071402fa15a21300d267f58e858976e.zip
Add static option which also builds xforward-static which can be copied
to a firewall/gateway/proxy machine without a full-blown X insstalled.
Notes
Notes: svn path=/head/; revision=414578
Diffstat (limited to 'x11')
-rw-r--r--x11/xforward/Makefile11
-rw-r--r--x11/xforward/files/patch-Makefile38
2 files changed, 46 insertions, 3 deletions
diff --git a/x11/xforward/Makefile b/x11/xforward/Makefile
index 5b7819d93a75..2f18cb243c70 100644
--- a/x11/xforward/Makefile
+++ b/x11/xforward/Makefile
@@ -16,8 +16,17 @@ COMMENT= Provide user-level X forwarding service
LICENSE_FILE= ${WRKSRC}/NOTICE
MAKE_ARGS+= PREFIX=${PREFIX} LOCALBASE=${LOCALBASE}
-USE_XORG= x11 xt xaw
+USE_XORG= x11 xt xaw xmu xt xext sm ice xp xft xau xcb xdmcp xrender
USES= motif
+LIB_DEPENDS= libpng.so:graphics/png \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libexpat.so:textproc/expat2 \
+ libfreetype.so:print/freetype2
PLIST_FILES= bin/xforward man/man1/xforward.1.gz
+OPTIONS_DEFINE= STATIC
+STATIC_ALL_TARGET= all-static
+STATIC_INSTALL_TARGET= install-static
+STATIC_PLIST_FILES= bin/xforward-static
+
.include <bsd.port.mk>
diff --git a/x11/xforward/files/patch-Makefile b/x11/xforward/files/patch-Makefile
index 2c05be07154a..1e35b4c243b9 100644
--- a/x11/xforward/files/patch-Makefile
+++ b/x11/xforward/files/patch-Makefile
@@ -1,6 +1,6 @@
--- Makefile.orig 1993-06-04 19:32:01.000000000 -0700
-+++ Makefile 2012-04-27 13:01:33.079482669 -0700
-@@ -18,17 +18,17 @@
++++ Makefile 2016-04-29 22:53:07.305978000 -0700
+@@ -18,17 +18,19 @@
# MANDIR is where the manual page will be installed.
DESTDIR=
@@ -20,6 +20,40 @@
+INCFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+LIBS= -lXm -lXt -lX11 -lXext
++LIBS_STATIC= -lXm -lXmu -lXt -lXext -lSM -lICE -lpng16 -lz -lm -ljpeg -lXp -lXft -lfontconfig -lexpat -lfreetype -lbz2 -lX11 -lXau -lxcb -lXdmcp -lXau -lXft -lXrender
++
CFLAGS= ${INCFLAGS} -O
+@@ -39,20 +41,30 @@
+ AUXFILES= README NOTICE Makefile xforward.1
+
+ PROGS = xforward
++PROGS_STATIC = xforward-static
+
++all-static: all ${PROGS_STATIC}
++
+ all: ${PROGS}
+
+ xforward: xforward.o
+ cc ${LDFLAGS} xforward.o -o xforward ${LIBS}
+
++xforward-static: xforward.o
++ cc ${LDFLAGS} -static xforward.o -o xforward-static ${LIBS_STATIC}
++
+ xforward.o: xforward.c
+ cc -c ${CFLAGS} xforward.c
+
+ install: ${PROGS}
+ install -c xforward ${DESTDIR}${BINDIR}/xforward
+ install -c xforward.1 ${DESTDIR}${MANDIR}/xforward.1
++
++install-static: install ${PROGS_STATIC}
++ install -c xforward-static ${DESTDIR}${BINDIR}/xforward-static
++
+ clean: ;
+- rm -f *~ *.o core ${PROGS}
++ rm -f *~ *.o core ${PROGS} ${PROGS_STATIC}
+
+ center:
+ #load ${LDFLAGS} ${LIBS}