aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-09 19:42:46 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-09 19:42:46 +0000
commit30a00f2227a3e53b607331247c81c2911c1e98ef (patch)
treeb3bdcd25b598432ef78aefb0f72e9412f429eee4 /x11
parentfc3bdd2b5bc1f418653dc07e3f7734890f957654 (diff)
downloadports-30a00f2227a3e53b607331247c81c2911c1e98ef.tar.gz
ports-30a00f2227a3e53b607331247c81c2911c1e98ef.zip
Most commonly used build systems support silent builds, when they
hide actual commands executed and only show short summary line (like "CC foo.c"). CMake and ninja enable this by default, some autotools using ports do as well. This is unacceptable because we need complete build logs at any time, so we now switch to verbose build logs unconditionally. Note that this change deliberately affects ALL builds and not only package builds on cluster, because we need to be sure that user experiencing failure can always provide informative build log regardless of settings and without rerunning the build. Change summary: - Always do verbose builds for cmake, ninja and GNU configure (the latter includes check if --disable-silent-rules is actually supported by the configure script; there are isolated cases when it's not true) - Remove CMAKE_VERBOSE, NINJA_VERBOSE and CONFIGURE_ARGS=--disable-silent-rules from all ports which set them for this is no longer needed - Revert hacks for --disable-silent-rules support priorly committed to biology/ncbi-blast+ and net-p2p/mldonkey - no longer needed as well Submitted by: amdmi3 Reviewed by: mat Exp-run by: antoine Approved by: portmgr (mat, antoine) Differential Revision: D7534
Notes
Notes: svn path=/head/; revision=421635
Diffstat (limited to 'x11')
-rw-r--r--x11/keybinder-gtk3/Makefile2
-rw-r--r--x11/keybinder/Makefile2
-rw-r--r--x11/lxpanel/Makefile2
-rw-r--r--x11/sbxkb/Makefile1
-rw-r--r--x11/workrave/Makefile5
-rw-r--r--x11/xtermcontrol/Makefile1
6 files changed, 5 insertions, 8 deletions
diff --git a/x11/keybinder-gtk3/Makefile b/x11/keybinder-gtk3/Makefile
index 88e0b8e41756..f7f2f1916cac 100644
--- a/x11/keybinder-gtk3/Makefile
+++ b/x11/keybinder-gtk3/Makefile
@@ -22,7 +22,7 @@ PATHFIX_MAKEFILEIN= Makefile.am
USE_GNOME= gtk30 introspection:build
USE_XORG= x11 xext xrender
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-silent-rules --disable-gtk-doc
+CONFIGURE_ARGS= --disable-gtk-doc
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
diff --git a/x11/keybinder/Makefile b/x11/keybinder/Makefile
index ef4c2cb79ff2..94957d611282 100644
--- a/x11/keybinder/Makefile
+++ b/x11/keybinder/Makefile
@@ -21,7 +21,7 @@ PATHFIX_MAKEFILEIN= Makefile.am
USE_GNOME= gtk20 introspection:build
USE_XORG= x11 xext xrender
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-silent-rules --disable-gtk-doc
+CONFIGURE_ARGS= --disable-gtk-doc
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
diff --git a/x11/lxpanel/Makefile b/x11/lxpanel/Makefile
index 6118e639dbf6..4794d4a254aa 100644
--- a/x11/lxpanel/Makefile
+++ b/x11/lxpanel/Makefile
@@ -26,7 +26,7 @@ USES= gmake pathfix pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix="${PREFIX}" \
--with-plugins=netstatus,volume,volumealsa,deskno,batt,kbled,xkb,thermal,cpu,cpufreq,monitors,wnckpager \
- --with-x --disable-silent-rules \
+ --with-x \
CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CFLAGS+= -I${WRKSRC}
diff --git a/x11/sbxkb/Makefile b/x11/sbxkb/Makefile
index c49c75c92322..ddb77d661bd6 100644
--- a/x11/sbxkb/Makefile
+++ b/x11/sbxkb/Makefile
@@ -12,7 +12,6 @@ COMMENT= XKB keyboard layout indicator and switcher
LICENSE= GPLv3
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-silent-rules
LIBS+= -L${LOCALBASE}/lib -lX11
USES= pkgconfig
USE_GNOME= gtk20
diff --git a/x11/workrave/Makefile b/x11/workrave/Makefile
index ca177e2fb5d1..21b5ca781a27 100644
--- a/x11/workrave/Makefile
+++ b/x11/workrave/Makefile
@@ -12,12 +12,11 @@ LICENSE= GPLv3+
LIB_DEPENDS= libgdome.so:textproc/gdome2
-USES= autoreconf:build gettext gmake libtool pathfix pkgconfig
+USES= autoreconf:build gettext gmake libtool pathfix pkgconfig
USE_XORG= ice recordproto sm x11 xext xmu xscrnsaver xtst
USE_GNOME= intltool intlhack introspection gtkmm30
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-silent-rules \
- --disable-gsettings \
+CONFIGURE_ARGS= --disable-gsettings \
--disable-pulse \
--disable-gconf \
--disable-mate \
diff --git a/x11/xtermcontrol/Makefile b/x11/xtermcontrol/Makefile
index 692284ddd6f7..ea28601df227 100644
--- a/x11/xtermcontrol/Makefile
+++ b/x11/xtermcontrol/Makefile
@@ -14,7 +14,6 @@ LICENSE= GPLv2+
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_header_libintl_h=no
-CONFIGURE_ARGS= --disable-silent-rules
PLIST_FILES= bin/xtermcontrol man/man1/xtermcontrol.1.gz