aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2012-06-01 18:52:46 +0000
committerLars Engels <lme@FreeBSD.org>2012-06-01 18:52:46 +0000
commit3e5930dbb9c313b2cd5a18a4ec38c5342bd716ad (patch)
tree2a98ccdc9c5773a995e230bfa09afb68acfde485 /x11
parent1d14744cb6988531a48fb2b287c484d0972aba7b (diff)
downloadports-3e5930dbb9c313b2cd5a18a4ec38c5342bd716ad.tar.gz
ports-3e5930dbb9c313b2cd5a18a4ec38c5342bd716ad.zip
- Fix build with clang
- While here, fix a segfault [1] - Bump PORTREVISION Fixed by: ed [1]
Notes
Notes: svn path=/head/; revision=297971
Diffstat (limited to 'x11')
-rw-r--r--x11/bbrun/Makefile3
-rw-r--r--x11/bbrun/files/patch-Makefile6
-rw-r--r--x11/bbrun/files/patch-bbrun.c37
3 files changed, 38 insertions, 8 deletions
diff --git a/x11/bbrun/Makefile b/x11/bbrun/Makefile
index 915a35dcecc9..09cf7dfa11e7 100644
--- a/x11/bbrun/Makefile
+++ b/x11/bbrun/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bbrun
PORTVERSION= 1.6
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= x11
MASTER_SITES= http://www.bsd-geek.de/FreeBSD/distfiles/
@@ -19,6 +19,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/bbrun
USE_XORG= xpm
USE_GNOME= gtk20
USE_GMAKE= yes
+USE_CSTD= gnu89
PORTDOCS= README
PLIST_FILES= bin/bbrun
diff --git a/x11/bbrun/files/patch-Makefile b/x11/bbrun/files/patch-Makefile
index 7040172a6f27..7144020704a9 100644
--- a/x11/bbrun/files/patch-Makefile
+++ b/x11/bbrun/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Wed Feb 11 13:57:17 2004
-+++ Makefile Wed Aug 11 03:14:43 2004
+--- Makefile.orig 2004-02-11 05:57:17.000000000 +0100
++++ Makefile 2012-05-30 22:23:41.000000000 +0200
@@ -1,7 +1,6 @@
-CC = gcc
-LIBDIR = -L/usr/lib -L/usr/X11R6/lib
@@ -11,7 +11,7 @@
OBJS = bbrun.o \
../wmgeneral/wmgeneral.o \
-@@ -11,7 +10,7 @@
+@@ -11,7 +10,7 @@ OBJS = bbrun.o \
all: bbrun
.c.o:
diff --git a/x11/bbrun/files/patch-bbrun.c b/x11/bbrun/files/patch-bbrun.c
index 376c2989112b..87760e8469ae 100644
--- a/x11/bbrun/files/patch-bbrun.c
+++ b/x11/bbrun/files/patch-bbrun.c
@@ -1,5 +1,5 @@
---- bbrun.c.orig Sat Jul 20 13:24:53 2002
-+++ bbrun.c Sat Jul 20 20:31:49 2002
+--- bbrun.c.orig 2004-02-13 01:24:59.000000000 +0100
++++ bbrun.c 2012-06-01 20:42:51.000000000 +0200
@@ -3,7 +3,11 @@
#include <string.h>
#include <getopt.h>
@@ -17,7 +17,36 @@
#define ADVANCED_WINDOW_COLS 10
-#define u32 __u32
-+#define u32 u_int32_t
++#define u32 uintptr_t
#define __DEBUG__ 0
- #define VERSION "1.4"
+ #define VERSION "1.6"
+@@ -38,8 +42,8 @@ char historyFilename[MAXPATHLEN + 1];
+
+ // TOC = Table Of Contents, it is a dynamically allocated array of pointers to dynamically
+ // allocated history items.
+-u32 *histTOC; // Always keep track of the beginning, this one is NEVER incremented.
+-u32 *histTOC2; // We increment this one for each item
++u32 *histTOC = NULL; // Always keep track of the beginning, this one is NEVER incremented.
++u32 *histTOC2 = NULL; // We increment this one for each item
+
+ void parseArguments(int, char **);
+ void execDialogInformation();
+@@ -197,7 +201,7 @@ void readHistory(void) {
+
+ item = malloc(strlen(buf));
+ strncpy(item, buf, strlen(buf));
+- item[strlen(buf)- 1] = 0x0; // Remove the newline char
++ item[strlen(buf)- 1] = '\0'; // Remove the newline char
+
+ *histTOC2 = (u32) item;
+ } else {
+@@ -322,7 +326,7 @@ void writeHistory()
+ // Event handler for Ok and Cancel buttons
+ void callback (GtkWidget * widget, gpointer data)
+ {
+- if ((char *) data == "ok")
++ if ((strcmp(data, "ok")) == 0)
+ execDialogInformation();
+
+ gtk_main_quit();