aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2016-09-13 07:19:33 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2016-09-13 07:19:33 +0000
commit9f15136599b59cbeec787a89ce18676237bbfbf1 (patch)
tree8850bbf7ea3bbf6a101a9ea91d7a121325809472 /x11
parent3649201941e6e18b5d0501605dc57e11fc50a58b (diff)
downloadports-9f15136599b59cbeec787a89ce18676237bbfbf1.tar.gz
ports-9f15136599b59cbeec787a89ce18676237bbfbf1.zip
- Update to 0.6.0
- Sort USES - Remove unneeded patches - Mark BROKEN on 9 (probably also on 10, lack of feedback [0]), because it requires recent GPU drivers Tested successfully on FreeBSD >= 11.0-RC2 with fallback drivers, scfb [1], and vesa (by me). [0] https://lists.freebsd.org/pipermail/freebsd-xfce/2016-May/001353.html Tested by: Ben Woods (woodsb02@) [1]
Notes
Notes: svn path=/head/; revision=421981
Diffstat (limited to 'x11')
-rw-r--r--x11/xfce4-dashboard/Makefile21
-rw-r--r--x11/xfce4-dashboard/distinfo5
-rw-r--r--x11/xfce4-dashboard/files/patch-configure11
-rw-r--r--x11/xfce4-dashboard/files/patch-libxfdashboard_quicklaunch.c11
-rw-r--r--x11/xfce4-dashboard/files/patch-xfdashboard_applications-search-provider.c11
-rw-r--r--x11/xfce4-dashboard/files/patch-xfdashboard_applications-view.c11
-rw-r--r--x11/xfce4-dashboard/files/patch-xfdashboard_search-view.c11
-rw-r--r--x11/xfce4-dashboard/files/patch-xfdashboard_windows-view.c11
-rw-r--r--x11/xfce4-dashboard/pkg-plist99
9 files changed, 127 insertions, 64 deletions
diff --git a/x11/xfce4-dashboard/Makefile b/x11/xfce4-dashboard/Makefile
index 091c966f28f0..8f998d0fc158 100644
--- a/x11/xfce4-dashboard/Makefile
+++ b/x11/xfce4-dashboard/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= dashboard
-PORTVERSION= 0.4.2
+PORTVERSION= 0.6.0
CATEGORIES= x11 xfce
MASTER_SITES= XFCE/src/apps/xfdashboard/${PORTVERSION:R}/
PKGNAMEPREFIX= xfce4-
@@ -15,17 +15,28 @@ COMMENT= GNOME shell like dashboard for the Xfce desktop
LICENSE= GPLv2
LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
+ libdbus-1.so:devel/dbus \
+ libjson-glib-1.0.so:devel/json-glib \
+ libcogl.so:graphics/cogl \
libclutter-1.0.so:graphics/clutter
+BROKEN_FreeBSD_9= requires recent GPU drivers
+
GNU_CONFIGURE= yes
-USES= pkgconfig libtool gmake perl5 gettext xfce tar:bzip2
-USE_GNOME= glib20 gtk30 libwnck3 intltool intlhack
+USES= gettext-tools gmake localbase libtool pathfix perl5 pkgconfig \
+ tar:bzip2 xfce:gtk3
+USE_GNOME= glib20 gtk30 libwnck3 cairo intltool intlhack
USE_XFCE= garcon
-USE_XORG= x11 xcomposite xdamage xinerama
-USE_GL= gl
+USE_XORG= x11 xcomposite xdamage xext xfixes xi xinerama xrandr
+USE_GL= egl gl
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
+OPTIONS_DEFINE= NLS
+NLS_USES= gettext-runtime
+NLS_CONFIGURE_ENABLE= nls
+OPTIONS_SUB= yes
+
post-patch:
# Decrease default value of desaturation factor (0.0 -> no desaturation)
# With some graphics cards, quick launch icons are totally black with
diff --git a/x11/xfce4-dashboard/distinfo b/x11/xfce4-dashboard/distinfo
index 4ee0e8b678a1..b5070aa05059 100644
--- a/x11/xfce4-dashboard/distinfo
+++ b/x11/xfce4-dashboard/distinfo
@@ -1,2 +1,3 @@
-SHA256 (xfce4/xfdashboard-0.4.2.tar.bz2) = d00f8378b5813f307a54d97150cad1ba9f5fc2c4e175e127b787610d603cec3a
-SIZE (xfce4/xfdashboard-0.4.2.tar.bz2) = 2276535
+TIMESTAMP = 1463852460
+SHA256 (xfce4/xfdashboard-0.6.0.tar.bz2) = 86feda138001a3bbb686a36c14ad6923e3c7ab2c1b921217f9c075cd43c2b1bc
+SIZE (xfce4/xfdashboard-0.6.0.tar.bz2) = 2401630
diff --git a/x11/xfce4-dashboard/files/patch-configure b/x11/xfce4-dashboard/files/patch-configure
new file mode 100644
index 000000000000..c060a55a7bcf
--- /dev/null
+++ b/x11/xfce4-dashboard/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2016-05-20 19:36:31 UTC
++++ configure
+@@ -14443,7 +14443,7 @@ $as_echo "#define HAVE_LC_MESSAGES 1" >>
+
+ fi
+ fi
+- USE_NLS=yes
++ #USE_NLS=yes
+
+
+ gt_cv_have_gettext=no
diff --git a/x11/xfce4-dashboard/files/patch-libxfdashboard_quicklaunch.c b/x11/xfce4-dashboard/files/patch-libxfdashboard_quicklaunch.c
new file mode 100644
index 000000000000..5f7aa91c0952
--- /dev/null
+++ b/x11/xfce4-dashboard/files/patch-libxfdashboard_quicklaunch.c
@@ -0,0 +1,11 @@
+--- libxfdashboard/quicklaunch.c.orig 2016-03-29 05:48:01 UTC
++++ libxfdashboard/quicklaunch.c
+@@ -1295,7 +1295,7 @@ static void _xfdashboard_quicklaunch_set
+ XfdashboardQuicklaunchPrivate *priv;
+ guint i;
+ const gchar *defaultApplications[]= {
+- "exo-web-browser.desktop"
++ "exo-web-browser.desktop",
+ "exo-mail-reader.desktop",
+ "exo-file-manager.desktop",
+ "exo-terminal-emulator.desktop",
diff --git a/x11/xfce4-dashboard/files/patch-xfdashboard_applications-search-provider.c b/x11/xfce4-dashboard/files/patch-xfdashboard_applications-search-provider.c
deleted file mode 100644
index 74dc386e4721..000000000000
--- a/x11/xfce4-dashboard/files/patch-xfdashboard_applications-search-provider.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- xfdashboard/applications-search-provider.c.orig 2015-03-04 05:46:06 UTC
-+++ xfdashboard/applications-search-provider.c
-@@ -318,7 +318,7 @@ static const gchar* _xfdashboard_applica
- /* Overriden virtual function: get_icon */
- static const gchar* _xfdashboard_applications_search_provider_get_icon(XfdashboardSearchProvider *inProvider)
- {
-- return("gtk-missing-image");
-+ return("applications-other");
- }
-
- /* Overriden virtual function: get_result_set */
diff --git a/x11/xfce4-dashboard/files/patch-xfdashboard_applications-view.c b/x11/xfce4-dashboard/files/patch-xfdashboard_applications-view.c
deleted file mode 100644
index 34f495f33caa..000000000000
--- a/x11/xfce4-dashboard/files/patch-xfdashboard_applications-view.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- xfdashboard/applications-view.c.orig 2015-03-04 05:45:24 UTC
-+++ xfdashboard/applications-view.c
-@@ -1374,7 +1374,7 @@ static void xfdashboard_applications_vie
- /* Set up view */
- xfdashboard_view_set_internal_name(XFDASHBOARD_VIEW(self), "applications");
- xfdashboard_view_set_name(XFDASHBOARD_VIEW(self), _("Applications"));
-- xfdashboard_view_set_icon(XFDASHBOARD_VIEW(self), "gtk-home");
-+ xfdashboard_view_set_icon(XFDASHBOARD_VIEW(self), "go-home");
-
- /* Set up actor */
- xfdashboard_actor_set_can_focus(XFDASHBOARD_ACTOR(self), TRUE);
diff --git a/x11/xfce4-dashboard/files/patch-xfdashboard_search-view.c b/x11/xfce4-dashboard/files/patch-xfdashboard_search-view.c
deleted file mode 100644
index 53a44a1f2265..000000000000
--- a/x11/xfce4-dashboard/files/patch-xfdashboard_search-view.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- xfdashboard/search-view.c.orig 2015-03-04 05:44:14 UTC
-+++ xfdashboard/search-view.c
-@@ -1540,7 +1540,7 @@ static void xfdashboard_search_view_init
- /* Set up view (Note: Search view is disabled by default!) */
- xfdashboard_view_set_internal_name(XFDASHBOARD_VIEW(self), "search");
- xfdashboard_view_set_name(XFDASHBOARD_VIEW(self), _("Search"));
-- xfdashboard_view_set_icon(XFDASHBOARD_VIEW(self), "gtk-find");
-+ xfdashboard_view_set_icon(XFDASHBOARD_VIEW(self), "system-search");
- xfdashboard_view_set_enabled(XFDASHBOARD_VIEW(self), FALSE);
-
- /* Set up actor */
diff --git a/x11/xfce4-dashboard/files/patch-xfdashboard_windows-view.c b/x11/xfce4-dashboard/files/patch-xfdashboard_windows-view.c
deleted file mode 100644
index cc5c7fa96682..000000000000
--- a/x11/xfce4-dashboard/files/patch-xfdashboard_windows-view.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- xfdashboard/windows-view.c.orig 2015-03-17 21:31:03 UTC
-+++ xfdashboard/windows-view.c
-@@ -128,7 +128,7 @@ static void _xfdashboard_windows_view_se
- /* IMPLEMENTATION: Private variables and methods */
- #define SCROLL_EVENT_CHANGES_WORKSPACE_XFCONF_PROP "/components/windows-view/scroll-event-changes-workspace"
-
--#define DEFAULT_VIEW_ICON "gtk-fullscreen"
-+#define DEFAULT_VIEW_ICON "view-fullscreen"
- #define DEFAULT_DRAG_HANDLE_SIZE 32.0f
-
- /* Stage interface has changed monitor */
diff --git a/x11/xfce4-dashboard/pkg-plist b/x11/xfce4-dashboard/pkg-plist
index bb7564a7b1f4..e3b32b018bf4 100644
--- a/x11/xfce4-dashboard/pkg-plist
+++ b/x11/xfce4-dashboard/pkg-plist
@@ -1,9 +1,81 @@
bin/xfdashboard
bin/xfdashboard-settings
etc/xdg/autostart/xfdashboard-autostart.desktop
+include/xfdashboard/libxfdashboard/action-button.h
+include/xfdashboard/libxfdashboard/actor.h
+include/xfdashboard/libxfdashboard/application-button.h
+include/xfdashboard/libxfdashboard/application-database.h
+include/xfdashboard/libxfdashboard/application-tracker.h
+include/xfdashboard/libxfdashboard/application.h
+include/xfdashboard/libxfdashboard/applications-menu-model.h
+include/xfdashboard/libxfdashboard/applications-search-provider.h
+include/xfdashboard/libxfdashboard/applications-view.h
+include/xfdashboard/libxfdashboard/background.h
+include/xfdashboard/libxfdashboard/binding.h
+include/xfdashboard/libxfdashboard/bindings-pool.h
+include/xfdashboard/libxfdashboard/box-layout.h
+include/xfdashboard/libxfdashboard/button.h
+include/xfdashboard/libxfdashboard/click-action.h
+include/xfdashboard/libxfdashboard/collapse-box.h
+include/xfdashboard/libxfdashboard/compat.h
+include/xfdashboard/libxfdashboard/css-selector.h
+include/xfdashboard/libxfdashboard/desktop-app-info.h
+include/xfdashboard/libxfdashboard/drag-action.h
+include/xfdashboard/libxfdashboard/drop-action.h
+include/xfdashboard/libxfdashboard/dynamic-table-layout.h
+include/xfdashboard/libxfdashboard/emblem-effect.h
+include/xfdashboard/libxfdashboard/fill-box-layout.h
+include/xfdashboard/libxfdashboard/focus-manager.h
+include/xfdashboard/libxfdashboard/focusable.h
+include/xfdashboard/libxfdashboard/image-content.h
+include/xfdashboard/libxfdashboard/libxfdashboard.h
+include/xfdashboard/libxfdashboard/live-window.h
+include/xfdashboard/libxfdashboard/live-workspace.h
+include/xfdashboard/libxfdashboard/model.h
+include/xfdashboard/libxfdashboard/outline-effect.h
+include/xfdashboard/libxfdashboard/plugin.h
+include/xfdashboard/libxfdashboard/plugins-manager.h
+include/xfdashboard/libxfdashboard/quicklaunch.h
+include/xfdashboard/libxfdashboard/scaled-table-layout.h
+include/xfdashboard/libxfdashboard/scrollbar.h
+include/xfdashboard/libxfdashboard/search-manager.h
+include/xfdashboard/libxfdashboard/search-provider.h
+include/xfdashboard/libxfdashboard/search-result-container.h
+include/xfdashboard/libxfdashboard/search-result-set.h
+include/xfdashboard/libxfdashboard/search-view.h
+include/xfdashboard/libxfdashboard/stage-interface.h
+include/xfdashboard/libxfdashboard/stage.h
+include/xfdashboard/libxfdashboard/stylable.h
+include/xfdashboard/libxfdashboard/text-box.h
+include/xfdashboard/libxfdashboard/theme-css.h
+include/xfdashboard/libxfdashboard/theme-effects.h
+include/xfdashboard/libxfdashboard/theme-layout.h
+include/xfdashboard/libxfdashboard/theme.h
+include/xfdashboard/libxfdashboard/toggle-button.h
+include/xfdashboard/libxfdashboard/tooltip-action.h
+include/xfdashboard/libxfdashboard/types.h
+include/xfdashboard/libxfdashboard/utils.h
+include/xfdashboard/libxfdashboard/view-manager.h
+include/xfdashboard/libxfdashboard/view-selector.h
+include/xfdashboard/libxfdashboard/view.h
+include/xfdashboard/libxfdashboard/viewpad.h
+include/xfdashboard/libxfdashboard/window-content.h
+include/xfdashboard/libxfdashboard/window-tracker-monitor.h
+include/xfdashboard/libxfdashboard/window-tracker-window.h
+include/xfdashboard/libxfdashboard/window-tracker-workspace.h
+include/xfdashboard/libxfdashboard/window-tracker.h
+include/xfdashboard/libxfdashboard/windows-view.h
+include/xfdashboard/libxfdashboard/workspace-selector.h
+lib/libxfdashboard.so
+lib/libxfdashboard.so.0
+lib/libxfdashboard.so.0.600.0
+lib/xfdashboard/plugins/clock-view.so
+lib/xfdashboard/plugins/gnome-shell-search-provider.so
+lib/xfdashboard/plugins/hot-corner.so
+libdata/pkgconfig/libxfdashboard.pc
share/appdata/xfdashboard.appdata.xml
-share/applications/xfdashboard.desktop
share/applications/xfdashboard-settings.desktop
+share/applications/xfdashboard.desktop
share/icons/hicolor/128x128/apps/xfdashboard.png
share/icons/hicolor/16x16/apps/xfdashboard.png
share/icons/hicolor/22x22/apps/xfdashboard.png
@@ -13,58 +85,59 @@ share/icons/hicolor/32x32/apps/xfdashboard.png
share/icons/hicolor/48x48/apps/xfdashboard.png
share/icons/hicolor/64x64/apps/xfdashboard.png
share/icons/hicolor/96x96/apps/xfdashboard.png
-share/locale/es/LC_MESSAGES/xfdashboard.mo
-share/locale/fr/LC_MESSAGES/xfdashboard.mo
-share/locale/he/LC_MESSAGES/xfdashboard.mo
-share/locale/it_IT/LC_MESSAGES/xfdashboard.mo
-share/locale/sr/LC_MESSAGES/xfdashboard.mo
+%%NLS%%share/locale/es/LC_MESSAGES/xfdashboard.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/xfdashboard.mo
+%%NLS%%share/locale/he/LC_MESSAGES/xfdashboard.mo
+%%NLS%%share/locale/it_IT/LC_MESSAGES/xfdashboard.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/xfdashboard.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/xfdashboard.mo
share/themes/xfdashboard-auber/xfdashboard-1.0/effects.xml
share/themes/xfdashboard-auber/xfdashboard-1.0/screenshot-xfdashboard-auber.png
share/themes/xfdashboard-auber/xfdashboard-1.0/xfdashboard-auber.css
+share/themes/xfdashboard-auber/xfdashboard-1.0/xfdashboard-secondary.xml
share/themes/xfdashboard-auber/xfdashboard-1.0/xfdashboard.css
share/themes/xfdashboard-auber/xfdashboard-1.0/xfdashboard.theme
share/themes/xfdashboard-auber/xfdashboard-1.0/xfdashboard.xml
-share/themes/xfdashboard-auber/xfdashboard-1.0/xfdashboard-secondary.xml
share/themes/xfdashboard-blue/xfdashboard-1.0/effects.xml
share/themes/xfdashboard-blue/xfdashboard-1.0/xfdashboard-blue.css
+share/themes/xfdashboard-blue/xfdashboard-1.0/xfdashboard-secondary.xml
share/themes/xfdashboard-blue/xfdashboard-1.0/xfdashboard.css
share/themes/xfdashboard-blue/xfdashboard-1.0/xfdashboard.theme
share/themes/xfdashboard-blue/xfdashboard-1.0/xfdashboard.xml
-share/themes/xfdashboard-blue/xfdashboard-1.0/xfdashboard-secondary.xml
share/themes/xfdashboard-dark/xfdashboard-1.0/effects.xml
share/themes/xfdashboard-dark/xfdashboard-1.0/screenshot-xfdashboard-dark.png
share/themes/xfdashboard-dark/xfdashboard-1.0/xfdashboard-dark.css
+share/themes/xfdashboard-dark/xfdashboard-1.0/xfdashboard-secondary.xml
share/themes/xfdashboard-dark/xfdashboard-1.0/xfdashboard.css
share/themes/xfdashboard-dark/xfdashboard-1.0/xfdashboard.theme
share/themes/xfdashboard-dark/xfdashboard-1.0/xfdashboard.xml
-share/themes/xfdashboard-dark/xfdashboard-1.0/xfdashboard-secondary.xml
share/themes/xfdashboard-mint/xfdashboard-1.0/effects.xml
share/themes/xfdashboard-mint/xfdashboard-1.0/screenshot-xfdashboard-mint.png
share/themes/xfdashboard-mint/xfdashboard-1.0/xfdashboard-mint.css
+share/themes/xfdashboard-mint/xfdashboard-1.0/xfdashboard-secondary.xml
share/themes/xfdashboard-mint/xfdashboard-1.0/xfdashboard.css
share/themes/xfdashboard-mint/xfdashboard-1.0/xfdashboard.theme
share/themes/xfdashboard-mint/xfdashboard-1.0/xfdashboard.xml
-share/themes/xfdashboard-mint/xfdashboard-1.0/xfdashboard-secondary.xml
share/themes/xfdashboard-moranga/xfdashboard-1.0/effects.xml
share/themes/xfdashboard-moranga/xfdashboard-1.0/screenshot-xfdashboard-moranga.png
share/themes/xfdashboard-moranga/xfdashboard-1.0/xfdashboard-moranga.css
+share/themes/xfdashboard-moranga/xfdashboard-1.0/xfdashboard-secondary.xml
share/themes/xfdashboard-moranga/xfdashboard-1.0/xfdashboard.css
share/themes/xfdashboard-moranga/xfdashboard-1.0/xfdashboard.theme
share/themes/xfdashboard-moranga/xfdashboard-1.0/xfdashboard.xml
-share/themes/xfdashboard-moranga/xfdashboard-1.0/xfdashboard-secondary.xml
share/themes/xfdashboard-wine/xfdashboard-1.0/effects.xml
share/themes/xfdashboard-wine/xfdashboard-1.0/screenshot-xfdashboard-wine.png
+share/themes/xfdashboard-wine/xfdashboard-1.0/xfdashboard-secondary.xml
share/themes/xfdashboard-wine/xfdashboard-1.0/xfdashboard-wine.css
share/themes/xfdashboard-wine/xfdashboard-1.0/xfdashboard.css
share/themes/xfdashboard-wine/xfdashboard-1.0/xfdashboard.theme
share/themes/xfdashboard-wine/xfdashboard-1.0/xfdashboard.xml
-share/themes/xfdashboard-wine/xfdashboard-1.0/xfdashboard-secondary.xml
share/themes/xfdashboard/xfdashboard-1.0/effects.xml
share/themes/xfdashboard/xfdashboard-1.0/screenshot-xfdashboard.png
share/themes/xfdashboard/xfdashboard-1.0/windows-view.png
+share/themes/xfdashboard/xfdashboard-1.0/xfdashboard-secondary.xml
share/themes/xfdashboard/xfdashboard-1.0/xfdashboard.css
share/themes/xfdashboard/xfdashboard-1.0/xfdashboard.theme
share/themes/xfdashboard/xfdashboard-1.0/xfdashboard.xml
-share/themes/xfdashboard/xfdashboard-1.0/xfdashboard-secondary.xml
share/xfdashboard/bindings.xml
share/xfdashboard/preferences.ui