aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2012-01-21 17:40:15 +0000
committerEitan Adler <eadler@FreeBSD.org>2012-01-21 17:40:15 +0000
commitc59a3834c4bd220def36c5006080d4e0f57b83e0 (patch)
treed65d5bf921ef2499700b90c4dc6855a0137ddaf2 /x11
parent556296fe6692c3141d20c3bf87b479397ff4f4b0 (diff)
downloadports-c59a3834c4bd220def36c5006080d4e0f57b83e0.tar.gz
ports-c59a3834c4bd220def36c5006080d4e0f57b83e0.zip
At the moment 1385 ports use BUILD_DEPENDS= ${RUN_DEPENDS} and 450
ports use BUILD_DEPENDS:= ${RUN_DEPENDS}. This patch fixes ports that are currently broken. This is a temporary measure until we organically stop using := or someone(s) spend a lot of time changing all the ports over. Explicit duplication > := > = and this just moves ports one step to the left Approved by: portmgr
Notes
Notes: svn path=/head/; revision=289563
Diffstat (limited to 'x11')
-rw-r--r--x11/hotwire-shell/Makefile2
-rw-r--r--x11/p5-Clipboard/Makefile2
-rw-r--r--x11/p5-X11-IdleTime/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/x11/hotwire-shell/Makefile b/x11/hotwire-shell/Makefile
index c5b9b1d79081..bfabce8a8813 100644
--- a/x11/hotwire-shell/Makefile
+++ b/x11/hotwire-shell/Makefile
@@ -22,7 +22,7 @@ BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/dbus-python.pc:${PORTSDIR}/devel/p
${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3 \
${PYTHON_SITELIBDIR}/gtk-2.0/vtemodule.so:${PORTSDIR}/x11-toolkits/py-vte \
${PYXML}
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PYTHON= 2.5+
USE_PYDISTUTILS= yes
diff --git a/x11/p5-Clipboard/Makefile b/x11/p5-Clipboard/Makefile
index 00886acaf5f4..f41a181e5226 100644
--- a/x11/p5-Clipboard/Makefile
+++ b/x11/p5-Clipboard/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= tobez@FreeBSD.org
COMMENT= Access to X11 clipboard from Perl
BUILD_DEPENDS= ${SITE_PERL}/Spiffy.pm:${PORTSDIR}/devel/p5-Spiffy
-RUN_DEPENDS= ${BUILD_DEPENDS} \
+RUN_DEPENDS:= ${BUILD_DEPENDS} \
xclip:${PORTSDIR}/x11/xclip
PERL_CONFIGURE= yes
diff --git a/x11/p5-X11-IdleTime/Makefile b/x11/p5-X11-IdleTime/Makefile
index b8edf198faac..97af62f30f19 100644
--- a/x11/p5-X11-IdleTime/Makefile
+++ b/x11/p5-X11-IdleTime/Makefile
@@ -16,7 +16,7 @@ COMMENT= Perl module that reports number of seconds that X11 has been idle
BUILD_DEPENDS= ${SITE_PERL}/Inline.pm:${PORTSDIR}/devel/p5-Inline \
${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAKE_JOBS_UNSAFE= yes