aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorKris Moore <kmoore@FreeBSD.org>2011-07-27 13:48:51 +0000
committerKris Moore <kmoore@FreeBSD.org>2011-07-27 13:48:51 +0000
commitdffd53d2ac97537b07c65d072a94175b9ac500c9 (patch)
tree0c8c7bedbc71165368379a43947c081be3985e5c /x11
parent03f0bf5f2f17f66aa9d8514af9caa1afa76b1f36 (diff)
downloadports-dffd53d2ac97537b07c65d072a94175b9ac500c9.tar.gz
ports-dffd53d2ac97537b07c65d072a94175b9ac500c9.zip
Florence is an extensible scalable virtual keyboard for GNOME and other WMs.
Notes
Notes: svn path=/head/; revision=278407
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/florence/Makefile35
-rw-r--r--x11/florence/distinfo2
-rw-r--r--x11/florence/pkg-descr3
-rw-r--r--x11/florence/pkg-plist146
5 files changed, 187 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 3085aa9461f3..c71ab1dc0396 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -65,6 +65,7 @@
SUBDIR += fbsd-icons
SUBDIR += fireflies
SUBDIR += fixesproto
+ SUBDIR += florence
SUBDIR += fluxbg
SUBDIR += fpc-x11
SUBDIR += fstobdf
diff --git a/x11/florence/Makefile b/x11/florence/Makefile
new file mode 100644
index 000000000000..c45afb5b7e70
--- /dev/null
+++ b/x11/florence/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Florence
+# Date created: 2011/07/26
+# Whom: Kris Moore <kmoore@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= florence
+PORTVERSION= 0.5.0
+CATEGORIES= x11
+MASTER_SITES= SF/florence/florence/${PORTVERSION}
+
+MAINTAINER= kmoore@FreeBSD.org
+COMMENT= Florence OnScreen Keyboard
+
+LIB_DEPENDS= notify.1:${PORTSDIR}/devel/libnotify \
+ cspi.10:${PORTSDIR}/accessibility/at-spi
+
+USE_XORG= xtst
+USE_GNOME= gtk20 intlhack gnomedocutils gconf2 librsvg2 gnomepanel
+
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_ICONV= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+INSTALLS_OMF= yes
+GCONF_SCHEMAS= florence.schemas
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+.include <bsd.port.mk>
diff --git a/x11/florence/distinfo b/x11/florence/distinfo
new file mode 100644
index 000000000000..f9808b424a7a
--- /dev/null
+++ b/x11/florence/distinfo
@@ -0,0 +1,2 @@
+SHA256 (florence-0.5.0.tar.bz2) = 485416250e83104f44c917d63508fcf2ef2c45023777897fa637c7470fa6645c
+SIZE (florence-0.5.0.tar.bz2) = 479264
diff --git a/x11/florence/pkg-descr b/x11/florence/pkg-descr
new file mode 100644
index 000000000000..d5dfb801390b
--- /dev/null
+++ b/x11/florence/pkg-descr
@@ -0,0 +1,3 @@
+Florence is an extensible scalable virtual keyboard for GNOME.
+
+WWW: http://florence.sourceforge.net
diff --git a/x11/florence/pkg-plist b/x11/florence/pkg-plist
new file mode 100644
index 000000000000..5fc93d795e6b
--- /dev/null
+++ b/x11/florence/pkg-plist
@@ -0,0 +1,146 @@
+bin/florence
+bin/florence_applet
+lib/bonobo/servers/florence.server
+share/applications/florence.desktop
+%%DATADIR%%/florence.conf
+%%DATADIR%%/florence.css
+%%DATADIR%%/florence.glade
+%%DATADIR%%/florence.rnc
+%%DATADIR%%/layouts/compact-alt.xml
+%%DATADIR%%/layouts/compact.xml
+%%DATADIR%%/layouts/florence-alt.xml
+%%DATADIR%%/layouts/florence.xml
+%%DATADIR%%/relaxng/README
+%%DATADIR%%/relaxng/florence.rng
+%%DATADIR%%/relaxng/style.rng
+%%DATADIR%%/relaxng/svg-animation.rng
+%%DATADIR%%/relaxng/svg-animevents-attrib.rng
+%%DATADIR%%/relaxng/svg-basic-clip.rng
+%%DATADIR%%/relaxng/svg-basic-filter.rng
+%%DATADIR%%/relaxng/svg-basic-font.rng
+%%DATADIR%%/relaxng/svg-basic-graphics-attrib.rng
+%%DATADIR%%/relaxng/svg-basic-structure.rng
+%%DATADIR%%/relaxng/svg-basic-text.rng
+%%DATADIR%%/relaxng/svg-clip.rng
+%%DATADIR%%/relaxng/svg-conditional.rng
+%%DATADIR%%/relaxng/svg-container-attrib.rng
+%%DATADIR%%/relaxng/svg-core-attrib.rng
+%%DATADIR%%/relaxng/svg-cursor.rng
+%%DATADIR%%/relaxng/svg-datatypes.rng
+%%DATADIR%%/relaxng/svg-docevents-attrib.rng
+%%DATADIR%%/relaxng/svg-extensibility.rng
+%%DATADIR%%/relaxng/svg-extresources-attrib.rng
+%%DATADIR%%/relaxng/svg-filter.rng
+%%DATADIR%%/relaxng/svg-font.rng
+%%DATADIR%%/relaxng/svg-gradient.rng
+%%DATADIR%%/relaxng/svg-graphevents-attrib.rng
+%%DATADIR%%/relaxng/svg-graphics-attrib.rng
+%%DATADIR%%/relaxng/svg-hyperlink.rng
+%%DATADIR%%/relaxng/svg-image.rng
+%%DATADIR%%/relaxng/svg-marker.rng
+%%DATADIR%%/relaxng/svg-mask.rng
+%%DATADIR%%/relaxng/svg-opacity-attrib.rng
+%%DATADIR%%/relaxng/svg-paint-attrib.rng
+%%DATADIR%%/relaxng/svg-pattern.rng
+%%DATADIR%%/relaxng/svg-profile.rng
+%%DATADIR%%/relaxng/svg-script.rng
+%%DATADIR%%/relaxng/svg-shape.rng
+%%DATADIR%%/relaxng/svg-structure.rng
+%%DATADIR%%/relaxng/svg-style.rng
+%%DATADIR%%/relaxng/svg-text.rng
+%%DATADIR%%/relaxng/svg-view.rng
+%%DATADIR%%/relaxng/svg-viewport-attrib.rng
+%%DATADIR%%/relaxng/svg-xlink-attrib.rng
+%%DATADIR%%/relaxng/svg11.rng
+%%DATADIR%%/styles/bright/default.svg
+%%DATADIR%%/styles/bright/florence.defs
+%%DATADIR%%/styles/bright/florence.style
+%%DATADIR%%/styles/default/florence.defs
+%%DATADIR%%/styles/default/florence.style
+%%DATADIR%%/styles/default/symbols.xml
+%%DATADIR%%/styles/hard/default.svg
+%%DATADIR%%/styles/hard/florence.defs
+%%DATADIR%%/styles/hard/florence.style
+%%DATADIR%%/styles/hard/high.svg
+%%DATADIR%%/styles/hard/mini.svg
+%%DATADIR%%/styles/hard/return.svg
+%%DATADIR%%/styles/hard/small.svg
+%%DATADIR%%/styles/hard/space.svg
+%%DATADIR%%/styles/hard/tiny.svg
+%%DATADIR%%/styles/hard/wide.svg
+%%DATADIR%%/styles/hard/xl.svg
+%%DATADIR%%/styles/hard/xxl.svg
+%%DATADIR%%/svg11/README
+%%DATADIR%%/svg11/svg-animation.rnc
+%%DATADIR%%/svg11/svg-animevents-attrib.rnc
+%%DATADIR%%/svg11/svg-basic-clip.rnc
+%%DATADIR%%/svg11/svg-basic-filter.rnc
+%%DATADIR%%/svg11/svg-basic-font.rnc
+%%DATADIR%%/svg11/svg-basic-graphics-attrib.rnc
+%%DATADIR%%/svg11/svg-basic-structure.rnc
+%%DATADIR%%/svg11/svg-basic-text.rnc
+%%DATADIR%%/svg11/svg-clip.rnc
+%%DATADIR%%/svg11/svg-conditional.rnc
+%%DATADIR%%/svg11/svg-container-attrib.rnc
+%%DATADIR%%/svg11/svg-core-attrib.rnc
+%%DATADIR%%/svg11/svg-cursor.rnc
+%%DATADIR%%/svg11/svg-datatypes.rnc
+%%DATADIR%%/svg11/svg-docevents-attrib.rnc
+%%DATADIR%%/svg11/svg-extensibility.rnc
+%%DATADIR%%/svg11/svg-extresources-attrib.rnc
+%%DATADIR%%/svg11/svg-filter.rnc
+%%DATADIR%%/svg11/svg-font.rnc
+%%DATADIR%%/svg11/svg-gradient.rnc
+%%DATADIR%%/svg11/svg-graphevents-attrib.rnc
+%%DATADIR%%/svg11/svg-graphics-attrib.rnc
+%%DATADIR%%/svg11/svg-hyperlink.rnc
+%%DATADIR%%/svg11/svg-image.rnc
+%%DATADIR%%/svg11/svg-marker.rnc
+%%DATADIR%%/svg11/svg-mask.rnc
+%%DATADIR%%/svg11/svg-opacity-attrib.rnc
+%%DATADIR%%/svg11/svg-paint-attrib.rnc
+%%DATADIR%%/svg11/svg-pattern.rnc
+%%DATADIR%%/svg11/svg-profile.rnc
+%%DATADIR%%/svg11/svg-script.rnc
+%%DATADIR%%/svg11/svg-shape.rnc
+%%DATADIR%%/svg11/svg-structure.rnc
+%%DATADIR%%/svg11/svg-style.rnc
+%%DATADIR%%/svg11/svg-text.rnc
+%%DATADIR%%/svg11/svg-view.rnc
+%%DATADIR%%/svg11/svg-viewport-attrib.rnc
+%%DATADIR%%/svg11/svg-xlink-attrib.rnc
+%%DATADIR%%/svg11/svg11.rnc
+share/gnome/help/florence/C/figures/behaviour.png
+share/gnome/help/florence/C/figures/florence.png
+share/gnome/help/florence/C/figures/layout.png
+share/gnome/help/florence/C/figures/style.png
+share/gnome/help/florence/C/figures/window.png
+share/gnome/help/florence/C/florence.xml
+share/gnome/help/florence/C/gfdl.dbk
+share/gnome/help/florence/fr/figures/behaviour.png
+share/gnome/help/florence/fr/figures/florence.png
+share/gnome/help/florence/fr/figures/layout.png
+share/gnome/help/florence/fr/figures/style.png
+share/gnome/help/florence/fr/figures/window.png
+share/gnome/help/florence/fr/florence.xml
+share/locale/fr/LC_MESSAGES/florence.mo
+share/omf/florence/florence-C.omf
+share/omf/florence/florence-fr.omf
+share/pixmaps/florence.svg
+@dirrm lib/bonobo/servers
+@dirrm lib/bonobo
+@dirrm share/gnome/help/florence/fr/figures
+@dirrm share/gnome/help/florence/fr
+@dirrm share/gnome/help/florence/C/figures
+@dirrm share/gnome/help/florence/C
+@dirrm share/gnome/help/florence
+@dirrm share/omf/florence
+@dirrm share/omf
+@dirrm %%DATADIR%%/svg11
+@dirrm %%DATADIR%%/styles/hard
+@dirrm %%DATADIR%%/styles/default
+@dirrm %%DATADIR%%/styles/bright
+@dirrm %%DATADIR%%/styles
+@dirrm %%DATADIR%%/relaxng
+@dirrm %%DATADIR%%/layouts
+@dirrm %%DATADIR%%