aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-06 08:35:37 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-06 08:35:37 +0000
commitf74bf9fdcdbb8089fbb917a2bc666726ebac6dd1 (patch)
tree1cc8ad6ab4e4df2b15ff34dd7e5875d94b4c62a0 /x11
parent8d313a8be1e45876426bfcab0746fe1219dc789e (diff)
downloadports-f74bf9fdcdbb8089fbb917a2bc666726ebac6dd1.tar.gz
ports-f74bf9fdcdbb8089fbb917a2bc666726ebac6dd1.zip
Support stage
Use options helpers Use modern lib_depends
Notes
Notes: svn path=/head/; revision=338842
Diffstat (limited to 'x11')
-rw-r--r--x11/aterm/Makefile64
1 files changed, 18 insertions, 46 deletions
diff --git a/x11/aterm/Makefile b/x11/aterm/Makefile
index 4e2725b2acc3..07c6205e9bf1 100644
--- a/x11/aterm/Makefile
+++ b/x11/aterm/Makefile
@@ -33,57 +33,29 @@ KANJI_DESC= Kanji (EUC-JP or SJIS) support
BIG5S_DESC= Chinese character (BIG5) support
GREEK_DESC= Greek keyboard support
-MAN1= aterm.1
+PLIST_FILES= bin/aterm \
+ man/man1/aterm.1.gz
+
+TRANS_CONFIGURE_ENABLE= transparency
+BSDEL_CONFIGURE_OFF= --disable-backspace-key --disable-delete-key
+BSDEL_CONFIGURE_ON= --enable-backspace-key --enable-delete-key
+MOUSE_CONFIGURE_ENABLE= mousewheel
+BGIMG_LIB_DEPENDS= libAfterImage.so:${PORTSDIR}/graphics/libafterimage \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg
+BGIMG_CONFIGURE_ON= --with-afterimage-config --with-png --with-jpeg
+BGIMG_CONFIGURE_OFF= --without-afterimage-config --with-png=no --with-jpeg=no
+KANJI_CONFIGURE_ENABLE= kanji
+BIG5S_CONFIGURE_ENABLE= big5
+GREEK_CONFIGURE_ENABLE= greek
-PLIST_FILES= bin/aterm
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
+
.if ${OSVERSION} > 900007
CONFIGURE_ARGS+= --disable-utmp
.else
CONFIGURE_ARGS+= --enable-utmp
.endif
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MTRANS}
-CONFIGURE_ARGS+= --enable-transparency
-.else
-CONFIGURE_ARGS+= --disable-transparency
-.endif
-
-.if ${PORT_OPTIONS:MBSDEL}
-CONFIGURE_ARGS+= --disable-backspace-key --disable-delete-key
-.else
-CONFIGURE_ARGS+= --enable-backspace-key --enable-delete-key
-.endif
-
-.if ${PORT_OPTIONS:MMOUSE}
-CONFIGURE_ARGS+= --enable-mousewheel
-.else
-CONFIGURE_ARGS+= --disable-mousewheel
-.endif
-
-.if ${PORT_OPTIONS:MBGIMG}
-LIB_DEPENDS+= AfterImage:${PORTSDIR}/graphics/libafterimage \
- png15:${PORTSDIR}/graphics/png \
- jpeg:${PORTSDIR}/graphics/jpeg
-CONFIGURE_ARGS+= --with-afterimage-config --with-png --with-jpeg
-.else
-CONFIGURE_ARGS+= --without-afterimage-config --with-png=no --with-jpeg=no
-.endif
-
-.if ${PORT_OPTIONS:MKANJI}
-CONFIGURE_ARGS+= --enable-kanji
-.endif
-
-.if ${PORT_OPTIONS:MBIG5S}
-CONFIGURE_ARGS+= --enable-big5
-.endif
-
-.if ${PORT_OPTIONS:MGREEK}
-CONFIGURE_ARGS+= --enable-greek
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>