aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2013-04-26 10:44:28 +0000
committerAlex Kozlov <ak@FreeBSD.org>2013-04-26 10:44:28 +0000
commit83f02b963c2b22c85235bf19b4f10a20bea921b5 (patch)
treee5e83d3ba0442c1c2f0b99c843428b36a8eb003d /x11
parent152f30ef73f9cf1c87d1eb78186693682bed0c43 (diff)
downloadports-83f02b963c2b22c85235bf19b4f10a20bea921b5.tar.gz
ports-83f02b963c2b22c85235bf19b4f10a20bea921b5.zip
- Convert USE_GETTEXT to USES (part 4)
Approved by: portmgr (bapt)
Notes
Notes: svn path=/head/; revision=316596
Diffstat (limited to 'x11')
-rw-r--r--x11/avant-window-navigator/Makefile3
-rw-r--r--x11/gdm/Makefile3
-rw-r--r--x11/gnome-applets/Makefile3
-rw-r--r--x11/gnome-panel/Makefile3
-rw-r--r--x11/gnome-pie/Makefile2
-rw-r--r--x11/gnome-screensaver/Makefile3
-rw-r--r--x11/kde4-baseapps/Makefile3
-rw-r--r--x11/kde4-runtime/Makefile3
-rw-r--r--x11/kde4-workspace/Makefile3
-rw-r--r--x11/kdelibs4/Makefile3
-rw-r--r--x11/libexo/Makefile2
-rw-r--r--x11/libfm/Makefile2
-rw-r--r--x11/libxfce4menu/Makefile2
-rw-r--r--x11/libxfce4util/Makefile2
-rw-r--r--x11/metisse/Makefile3
-rw-r--r--x11/roxterm/Makefile3
-rw-r--r--x11/workrave/Makefile2
-rw-r--r--x11/xfce4-clipman-plugin/Makefile3
-rw-r--r--x11/xfce4-conf/Makefile2
-rw-r--r--x11/xfce4-screenshooter-plugin/Makefile2
-rw-r--r--x11/xfce4-terminal/Makefile2
-rw-r--r--x11/xkeyboard-config/Makefile2
-rw-r--r--x11/xscreensaver/Makefile3
-rw-r--r--x11/zenity/Makefile3
24 files changed, 24 insertions, 38 deletions
diff --git a/x11/avant-window-navigator/Makefile b/x11/avant-window-navigator/Makefile
index 665892b79e81..4928a08ad91e 100644
--- a/x11/avant-window-navigator/Makefile
+++ b/x11/avant-window-navigator/Makefile
@@ -18,10 +18,9 @@ LIB_DEPENDS= wnck-1:${PORTSDIR}/x11-toolkits/libwnck \
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USES= pathfix pkgconfig
+USES= pathfix pkgconfig gettext
USE_GNOME= glib20 gtk20 pygtk2
USE_PYTHON= yes
-USE_GETTEXT= yes
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
USE_XORG= x11 xproto xcomposite xrender
diff --git a/x11/gdm/Makefile b/x11/gdm/Makefile
index 06c3b8a7fe1b..56f743b97fd1 100644
--- a/x11/gdm/Makefile
+++ b/x11/gdm/Makefile
@@ -31,14 +31,13 @@ USERS= gdm
GROUPS= gdm
USE_XZ= yes
-USE_GETTEXT= yes
USE_LDCONFIG= yes
USE_XORG= dmx dmxproto
INSTALLS_ICONS= yes
USE_RC_SUBR= gdm
USE_GNOME_SUBR= yes
USE_GMAKE= yes
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= intlhack gnomehier gconf2 librsvg2 \
gnomedocutils gnomeprefix gnomepanel
GCONF_SCHEMAS= gdm-simple-greeter.schemas
diff --git a/x11/gnome-applets/Makefile b/x11/gnome-applets/Makefile
index 3f2e7a9f3fc3..48290d59ecb5 100644
--- a/x11/gnome-applets/Makefile
+++ b/x11/gnome-applets/Makefile
@@ -22,13 +22,12 @@ LIB_DEPENDS= gtop-2.0:${PORTSDIR}/devel/libgtop \
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/system-tools-backends-2.0.pc:${PORTSDIR}/sysutils/system-tools-backends \
${LOCALBASE}/libexec/gnome-settings-daemon:${PORTSDIR}/sysutils/gnome-settings-daemon
-USE_GETTEXT= yes
USE_BZIP2= yes
USE_GMAKE= yes
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= gnomeprefix intlhack gnomepanel gnomedocutils libgnomekbd
WANT_GNOME= yes
USE_GSTREAMER= yes
diff --git a/x11/gnome-panel/Makefile b/x11/gnome-panel/Makefile
index a3c4714b0f45..37756a95d5ed 100644
--- a/x11/gnome-panel/Makefile
+++ b/x11/gnome-panel/Makefile
@@ -26,13 +26,12 @@ LIB_DEPENDS= gweather:${PORTSDIR}/net/libgweather \
CONFLICTS= gnome-panel-3.[0-9]*
-USE_GETTEXT= yes
USE_XORG= ice sm x11 xau xrandr
USE_PYTHON= yes
INSTALLS_OMF= yes
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= gnomeprefix intlhack gnomedesktop libwnck gnomemenus \
gnomedocutils ltverhack referencehack librsvg2
USE_GMAKE= yes
diff --git a/x11/gnome-pie/Makefile b/x11/gnome-pie/Makefile
index 95149c54da86..f88a713aa075 100644
--- a/x11/gnome-pie/Makefile
+++ b/x11/gnome-pie/Makefile
@@ -43,7 +43,7 @@ CMAKE_ARGS+= -DNO_INSTALL_MANPAGES:BOOL=ON
.if ${PORT_OPTIONS:MNLS}
CMAKE_ARGS+= -DINSTALL_NLS:BOOL=ON
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB= NLS=""
.else
CMAKE_ARGS+= -DINSTALL_NLS:BOOL=OFF
diff --git a/x11/gnome-screensaver/Makefile b/x11/gnome-screensaver/Makefile
index d7d155cc4ce4..7d24aac610c8 100644
--- a/x11/gnome-screensaver/Makefile
+++ b/x11/gnome-screensaver/Makefile
@@ -19,10 +19,9 @@ CONFLICTS= gnome-screensaver-3.[0-9]*
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GETTEXT= yes
GNU_CONFIGURE= yes
USE_XORG= xtst xxf86vm
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= gnomeprefix intlhack gnomemenus libgnomekbd gnomedesktop
CONFIGURE_ARGS= --with-gdm-config=${LOCALBASE}/etc/gdm/custom.conf \
--with-xscreensaverdir=${XSCREENSAVER_DIR} \
diff --git a/x11/kde4-baseapps/Makefile b/x11/kde4-baseapps/Makefile
index a77cc2defc7d..d6b183eb0df8 100644
--- a/x11/kde4-baseapps/Makefile
+++ b/x11/kde4-baseapps/Makefile
@@ -15,12 +15,11 @@ LIB_DEPENDS= tidy-0.99.0:${PORTSDIR}/www/tidy-lib
CONFLICTS= kdebase-4.[0-6].* konq-plugins-4.[0-6].*
USE_XZ= yes
-USE_GETTEXT= yes
USE_GNOME= glib20
USE_KDE4= kdehier kdelibs kdeprefix libkonq \
automoc4 soprano strigi nepomuk-core \
nepomuk-widgets kactivities
-USES= cmake:outsource
+USES= cmake:outsource gettext
USE_QT4= corelib dbus gui script xml \
moc_build qmake_build rcc_build uic_build
USE_XORG= x11 xt
diff --git a/x11/kde4-runtime/Makefile b/x11/kde4-runtime/Makefile
index 0c648d4e63d8..cc9bd873b253 100644
--- a/x11/kde4-runtime/Makefile
+++ b/x11/kde4-runtime/Makefile
@@ -25,10 +25,9 @@ RUN_DEPENDS= cagibid:${PORTSDIR}/net/cagibi
CONFLICTS= kdebase-runtime-4.[0-6].* kdebase-workspace-4.5.[0-5] nepomukcontroller-0.2
USE_XZ= yes
-USE_GETTEXT= yes
USE_KDE4= kactivities kdehier kdelibs kdeprefix oxygen \
attica automoc4 pimlibs sharedmime strigi nepomuk-core
-USES= cmake:outsource
+USES= cmake:outsource gettext
USE_QT4= corelib dbus declarative designer_build gui phonon \
network qtestlib script svg webkit xml \
moc_build qmake_build rcc_build uic_build
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index 54f191c1d0ae..3d787908ebc2 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -42,13 +42,12 @@ RUN_DEPENDS= ${KDE4_PREFIX}/env/xdg-env.sh:${PORTSDIR}/misc/kde4-xdg-env \
CONFLICTS= kdeaccessibility-4.[0-6].* kdebase-workspace-4.[0-6].*
-USE_GETTEXT= yes
USE_GL= glu
USE_GNOME= glib20
USE_ICONV= yes
USE_KDE4= kactivities kdehier kdelibs kdeprefix oxygen pimlibs \
akonadi automoc4 ontologies qimageblitz soprano strigi
-USES= cmake:outsource pkgconfig
+USES= cmake:outsource pkgconfig gettext
USE_QT4= corelib dbus declarative designer_build gui network \
opengl phonon qtestlib script sql webkit xml \
moc_build qmake_build rcc_build uic_build
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index a760bde3428e..0b11fe18df34 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -40,11 +40,10 @@ LATEST_LINK= ${PORTNAME}4
USE_XZ= yes
USE_FAM= yes
-USE_GETTEXT= yes
USE_GNOME= libxml2 libxslt
USE_KDE4= kdehier kdeprefix oxygen \
attica automoc4 ontologies sharedmime soprano strigi
-USES= cmake:outsource
+USES= cmake:outsource gettext
USE_OPENSSL= yes
USE_PERL5= yes
USE_QT4= corelib dbus declarative designer_build gui \
diff --git a/x11/libexo/Makefile b/x11/libexo/Makefile
index bf32fcdb4e63..482a8ed117fa 100644
--- a/x11/libexo/Makefile
+++ b/x11/libexo/Makefile
@@ -48,7 +48,7 @@ PLIST_SUB+= APIDOCS="@comment "
.endif
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
.else
diff --git a/x11/libfm/Makefile b/x11/libfm/Makefile
index 57926a7f50ed..7e76dba82625 100644
--- a/x11/libfm/Makefile
+++ b/x11/libfm/Makefile
@@ -31,7 +31,7 @@ OPTIONS_DEFINE= NLS
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
diff --git a/x11/libxfce4menu/Makefile b/x11/libxfce4menu/Makefile
index 30e674df812e..8ac2246679ce 100644
--- a/x11/libxfce4menu/Makefile
+++ b/x11/libxfce4menu/Makefile
@@ -38,7 +38,7 @@ PLIST_SUB+= APIDOCS="@comment "
.endif
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
.else
diff --git a/x11/libxfce4util/Makefile b/x11/libxfce4util/Makefile
index 932ce83e7920..08039c3c172c 100644
--- a/x11/libxfce4util/Makefile
+++ b/x11/libxfce4util/Makefile
@@ -27,7 +27,7 @@ OPTIONS_DEFINE= NLS DOCS
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
.else
diff --git a/x11/metisse/Makefile b/x11/metisse/Makefile
index f25adc3b72af..8c390419c343 100644
--- a/x11/metisse/Makefile
+++ b/x11/metisse/Makefile
@@ -24,8 +24,7 @@ CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-fontdir=${LOCALBASE}/lib/X11/fonts
MAKE_ARGS= METISSE_DOC_DIR="${DOCSDIR}"
-USE_GETTEXT= yes
-USES= pathfix
+USES= pathfix gettext
WANT_GNOME= yes
USE_LDCONFIG= yes
USE_PYTHON= yes
diff --git a/x11/roxterm/Makefile b/x11/roxterm/Makefile
index a95138c8f05d..2af83129f84f 100644
--- a/x11/roxterm/Makefile
+++ b/x11/roxterm/Makefile
@@ -21,8 +21,7 @@ OPTIONS_DEFINE= DOCS
USE_BZIP2= yes
USE_GNOME= libglade2 vte
USE_PYTHON_BUILD= yes
-USE_GETTEXT= yes
-USES= pkgconfig
+USES= pkgconfig gettext
USE_AUTOTOOLS= libtool:env
INSTALLS_ICONS= yes
MAKE_JOBS_SAFE= yes
diff --git a/x11/workrave/Makefile b/x11/workrave/Makefile
index 9a9ca2c7f0a6..cb67a419e5f9 100644
--- a/x11/workrave/Makefile
+++ b/x11/workrave/Makefile
@@ -53,7 +53,7 @@ CONFIGURE_ARGS+=--disable-distribution
.endif
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
diff --git a/x11/xfce4-clipman-plugin/Makefile b/x11/xfce4-clipman-plugin/Makefile
index e57cc34d6c5b..850a4ad22ec1 100644
--- a/x11/xfce4-clipman-plugin/Makefile
+++ b/x11/xfce4-clipman-plugin/Makefile
@@ -20,12 +20,11 @@ UNIQUE_DESC= Enable Unique (single instance) support
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gtk20 intltool intlhack glib20 desktopfileutils
USE_XFCE= configenv libexo libmenu libutil panel xfconf
USE_XORG= xtst
-USES= pkgconfig
+USES= pkgconfig gettext
INSTALLS_ICONS= yes
diff --git a/x11/xfce4-conf/Makefile b/x11/xfce4-conf/Makefile
index 89e98a1a17dc..ed190a5c8663 100644
--- a/x11/xfce4-conf/Makefile
+++ b/x11/xfce4-conf/Makefile
@@ -55,7 +55,7 @@ PLIST_SUB+= PERLBIND="@comment "
.endif
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
.else
diff --git a/x11/xfce4-screenshooter-plugin/Makefile b/x11/xfce4-screenshooter-plugin/Makefile
index 0faf8e938f68..85f2c8d570b0 100644
--- a/x11/xfce4-screenshooter-plugin/Makefile
+++ b/x11/xfce4-screenshooter-plugin/Makefile
@@ -28,7 +28,7 @@ MAN1= xfce4-screenshooter.1
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --disable-nls
diff --git a/x11/xfce4-terminal/Makefile b/x11/xfce4-terminal/Makefile
index 9fdeb9e0c27e..fe0c8074c73c 100644
--- a/x11/xfce4-terminal/Makefile
+++ b/x11/xfce4-terminal/Makefile
@@ -32,7 +32,7 @@ MANLANG= "" ar ca da de el es fr gl id it ja ko lt \
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
.else
diff --git a/x11/xkeyboard-config/Makefile b/x11/xkeyboard-config/Makefile
index 615968b03e01..16e08cc52dea 100644
--- a/x11/xkeyboard-config/Makefile
+++ b/x11/xkeyboard-config/Makefile
@@ -31,7 +31,7 @@ MAN7= xkeyboard-config.7
.if ${PORT_OPTIONS:MNLS}
USE_ICONV= yes
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --disable-nls
diff --git a/x11/xscreensaver/Makefile b/x11/xscreensaver/Makefile
index f5ddfe14799a..25cf786994bb 100644
--- a/x11/xscreensaver/Makefile
+++ b/x11/xscreensaver/Makefile
@@ -22,11 +22,10 @@ MAKE_JOBS_SAFE= yes
CONFLICTS= xscreensaver-gnome-[0-9]* xscreensaver-gnome-hacks-[0-9]*
-USES= pkgconfig
+USES= pkgconfig gettext
USE_XORG= xpm
USE_GL= yes
USE_GMAKE= yes
-USE_GETTEXT= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gtk --with-gl --with-gle --with-pixbuf --with-xpm \
--with-jpeg=${LOCALBASE} --with-xshm-ext --with-xdbe-ext \
diff --git a/x11/zenity/Makefile b/x11/zenity/Makefile
index 5bfbd2bc19c8..277135a2864f 100644
--- a/x11/zenity/Makefile
+++ b/x11/zenity/Makefile
@@ -16,10 +16,9 @@ BUILD_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
RUN_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
USE_GMAKE= yes
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= gnomeprefix gtk20 gnomedocutils intlhack
USE_BZIP2= yes
-USE_GETTEXT= yes
GNU_CONFIGURE= yes
INSTALLS_OMF= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"