aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2005-11-15 06:52:12 +0000
committerAde Lovett <ade@FreeBSD.org>2005-11-15 06:52:12 +0000
commit54a0b86543e9ffa811825f0afecea56e89aac2a5 (patch)
treef56fb969c6a70f5e63287a4f791d035ab1ef0ddc /x11
parent1fccb46f1497a538f24ec00f14b7826570bc0a3a (diff)
downloadports-54a0b86543e9ffa811825f0afecea56e89aac2a5.tar.gz
ports-54a0b86543e9ffa811825f0afecea56e89aac2a5.zip
Mass-conversion to the USE_AUTOTOOLS New World Order. The code present
in bsd.autotools.mk essentially makes this a no-op given that all the old variables set a USE_AUTOTOOLS_COMPAT variable, which is parsed in exactly the same way as USE_AUTOTOOLS itself. Moreover, USE_AUTOTOOLS has already been extensively tested by the GNOME team -- all GNOME 2.12.x ports use it. Preliminary documentation can be found at: http://people.FreeBSD.org/~ade/autotools.txt which is in the process of being SGMLized before introduction into the Porters Handbook. Light blue touch-paper. Run.
Notes
Notes: svn path=/head/; revision=148323
Diffstat (limited to 'x11')
-rw-r--r--x11/alltray/Makefile2
-rw-r--r--x11/brightside/Makefile2
-rw-r--r--x11/ecore/Makefile2
-rw-r--r--x11/electricsheep/Makefile2
-rw-r--r--x11/eterm/Makefile2
-rw-r--r--x11/gcursor/Makefile2
-rw-r--r--x11/gdkxft/Makefile2
-rw-r--r--x11/gdm/Makefile2
-rw-r--r--x11/gnome-libs/Makefile2
-rw-r--r--x11/gnomelibs/Makefile2
-rw-r--r--x11/gtk-themepreview/Makefile2
-rw-r--r--x11/gtkterm2/Makefile2
-rw-r--r--x11/idesk/Makefile2
-rw-r--r--x11/libICE/Makefile2
-rw-r--r--x11/libSM/Makefile2
-rw-r--r--x11/libXau/Makefile2
-rw-r--r--x11/libXcomposite/Makefile2
-rw-r--r--x11/libXcursor/Makefile2
-rw-r--r--x11/libXdamage/Makefile2
-rw-r--r--x11/libXext/Makefile2
-rw-r--r--x11/libXfixes/Makefile2
-rw-r--r--x11/libXi/Makefile2
-rw-r--r--x11/libXpm/Makefile2
-rw-r--r--x11/libXrender/Makefile2
-rw-r--r--x11/libXres/Makefile2
-rw-r--r--x11/libXv/Makefile2
-rw-r--r--x11/libexo/Makefile2
-rw-r--r--x11/libgnomemm/Makefile2
-rw-r--r--x11/libgnomemm26/Makefile2
-rw-r--r--x11/libxfce4mcs/Makefile2
-rw-r--r--x11/libxfce4util/Makefile2
-rw-r--r--x11/libxklavier/Makefile2
-rw-r--r--x11/mgapdesk/Makefile2
-rw-r--r--x11/mlterm/Makefile2
-rw-r--r--x11/multi-aterm/Makefile2
-rw-r--r--x11/portoseguro/Makefile2
-rw-r--r--x11/powershell/Makefile2
-rw-r--r--x11/rxvt-devel/Makefile2
-rw-r--r--x11/startup-notification/Makefile2
-rw-r--r--x11/tkXwin/Makefile2
-rw-r--r--x11/vdesk/Makefile2
-rw-r--r--x11/xfce4-clipman-plugin/Makefile2
-rw-r--r--x11/xfce4-taskmanager/Makefile3
-rw-r--r--x11/xfce4-trigger-launcher/Makefile2
44 files changed, 44 insertions, 45 deletions
diff --git a/x11/alltray/Makefile b/x11/alltray/Makefile
index 29e40eb069f2..7ff438680256 100644
--- a/x11/alltray/Makefile
+++ b/x11/alltray/Makefile
@@ -17,7 +17,7 @@ COMMENT= Dock any application with no native tray icon
USE_X_PREFIX= yes
USE_GNOME= gtk20
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" LDFLAGS="-L${X11BASE}/lib"
diff --git a/x11/brightside/Makefile b/x11/brightside/Makefile
index 4e369119be0f..ce88024b2aeb 100644
--- a/x11/brightside/Makefile
+++ b/x11/brightside/Makefile
@@ -17,7 +17,7 @@ COMMENT= A tool to add reactivity to the edges and corners of the GNOME desktop
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_GNOME= gnomeprefix gnomehack libwnck libgnomeui
CONFIGURE_ARGS= --enable-tray-icon
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/x11/ecore/Makefile b/x11/ecore/Makefile
index 8245fb89c4f2..a201bc73a541 100644
--- a/x11/ecore/Makefile
+++ b/x11/ecore/Makefile
@@ -17,7 +17,7 @@ COMMENT= A core event abstraction library
LIB_DEPENDS= evas.1:${PORTSDIR}/graphics/evas
USE_X_PREFIX= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
USE_ICONV= yes
USE_GNOME= gnomehack pkgconfig gnometarget
INSTALLS_SHLIB= yes
diff --git a/x11/electricsheep/Makefile b/x11/electricsheep/Makefile
index 53d2eb8592ba..75105dc54394 100644
--- a/x11/electricsheep/Makefile
+++ b/x11/electricsheep/Makefile
@@ -31,7 +31,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-2.6.2
USE_X_PREFIX= yes
USE_SDL= sdl
USE_REINPLACE= yes
-USE_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13
.if !defined(NOPORTDOCS)
MAN1= electricsheep.1
diff --git a/x11/eterm/Makefile b/x11/eterm/Makefile
index 3cb25cc120b1..c32ac15afa6d 100644
--- a/x11/eterm/Makefile
+++ b/x11/eterm/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= Imlib2.3:${PORTSDIR}/graphics/imlib2 \
ast.2:${PORTSDIR}/devel/libast
USE_X_PREFIX= yes
-USE_INC_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13:inc
INSTALLS_SHLIB= yes
CONFIGURE_ARGS?=--enable-trans --enable-utmp \
--enable-xim --with-theme-update \
diff --git a/x11/gcursor/Makefile b/x11/gcursor/Makefile
index 8eda4c04fe1a..e4faf56eed08 100644
--- a/x11/gcursor/Makefile
+++ b/x11/gcursor/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= file-roller:${PORTSDIR}/archivers/fileroller
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomeprefix gnometarget intlhack libgnomeui
-USE_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/x11/gdkxft/Makefile b/x11/gdkxft/Makefile
index 143ea846f371..2da57a189d4a 100644
--- a/x11/gdkxft/Makefile
+++ b/x11/gdkxft/Makefile
@@ -22,7 +22,7 @@ USE_GNOME= gtk12
WANT_GNOME= yes
USE_ICONV= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lgnuregex -liconv" \
diff --git a/x11/gdm/Makefile b/x11/gdm/Makefile
index 0ca73c46c897..6f7a5dc64c87 100644
--- a/x11/gdm/Makefile
+++ b/x11/gdm/Makefile
@@ -22,7 +22,7 @@ INSTALLS_OMF= yes
USE_RC_SUBR= gdm.sh
USE_GMAKE= yes
USE_GNOME= gnomehack intlhack gnomehier libgnomeui librsvg2
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
CONFIGURE_ARGS= --localstatedir=/var --datadir=${PREFIX}/share/gnome \
--with-html-dir=${GNOME_HTML_DIR} \
diff --git a/x11/gnome-libs/Makefile b/x11/gnome-libs/Makefile
index 0eb5a292cf58..1e8a8e640442 100644
--- a/x11/gnome-libs/Makefile
+++ b/x11/gnome-libs/Makefile
@@ -27,7 +27,7 @@ USE_PERL5= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix esound gtk12 imlib libxml orbit
INSTALLS_SHLIB= yes
-USE_INC_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13:inc
USE_REINPLACE= yes
LIBTOOLFILES= configure libart_lgpl/configure
CONFIGURE_ARGS= --disable-test-gnome
diff --git a/x11/gnomelibs/Makefile b/x11/gnomelibs/Makefile
index 0eb5a292cf58..1e8a8e640442 100644
--- a/x11/gnomelibs/Makefile
+++ b/x11/gnomelibs/Makefile
@@ -27,7 +27,7 @@ USE_PERL5= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix esound gtk12 imlib libxml orbit
INSTALLS_SHLIB= yes
-USE_INC_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13:inc
USE_REINPLACE= yes
LIBTOOLFILES= configure libart_lgpl/configure
CONFIGURE_ARGS= --disable-test-gnome
diff --git a/x11/gtk-themepreview/Makefile b/x11/gtk-themepreview/Makefile
index b275128856c2..fe51f110631d 100644
--- a/x11/gtk-themepreview/Makefile
+++ b/x11/gtk-themepreview/Makefile
@@ -18,7 +18,7 @@ COMMENT= A small application for preview your theme widgets in one small window
GNU_CONFIGURE= yes
USE_X_PREFIX= yes
USE_GNOME= gtk20
-WANT_AUTOMAKE_VER= 19
+USE_AUTOTOOLS= automake:19:env
PLIST_FILES= bin/${PORTNAME}
WRKSRC= ${WRKDIR}/ThemePreview-2
diff --git a/x11/gtkterm2/Makefile b/x11/gtkterm2/Makefile
index c49477d3f323..d1c361bb41c2 100644
--- a/x11/gtkterm2/Makefile
+++ b/x11/gtkterm2/Makefile
@@ -20,7 +20,7 @@ USE_GNOME= gnometarget vte
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
PORTDOCS= README
diff --git a/x11/idesk/Makefile b/x11/idesk/Makefile
index 3f7cc10ea5a5..809b8f50fd4c 100644
--- a/x11/idesk/Makefile
+++ b/x11/idesk/Makefile
@@ -22,7 +22,7 @@ USE_X_PREFIX= yes
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_AUTOCONF_VER= 259
+USE_AUTOTOOLS= autoconf:259
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
CXXFLAGS+= `imlib2-config --cflags` `freetype-config --cflags`
diff --git a/x11/libICE/Makefile b/x11/libICE/Makefile
index 37c8671d24cb..dd5e832c2d57 100644
--- a/x11/libICE/Makefile
+++ b/x11/libICE/Makefile
@@ -25,7 +25,7 @@ USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13:inc
INSTALLS_SHLIB= yes
USE_GNOME= gnomehack pkgconfig
diff --git a/x11/libSM/Makefile b/x11/libSM/Makefile
index f092977a6c65..85123076a1f0 100644
--- a/x11/libSM/Makefile
+++ b/x11/libSM/Makefile
@@ -25,7 +25,7 @@ PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13
INSTALLS_SHLIB= yes
USE_GNOME= gnomehack pkgconfig
diff --git a/x11/libXau/Makefile b/x11/libXau/Makefile
index 7960cd3bfcfa..d80ee69519ea 100644
--- a/x11/libXau/Makefile
+++ b/x11/libXau/Makefile
@@ -23,7 +23,7 @@ PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13
USE_GNOME= gnomehack pkgconfig
INSTALLS_SHLIB= yes
diff --git a/x11/libXcomposite/Makefile b/x11/libXcomposite/Makefile
index 1ed37398c2d0..44b3bd33a346 100644
--- a/x11/libXcomposite/Makefile
+++ b/x11/libXcomposite/Makefile
@@ -25,7 +25,7 @@ PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13
CFLAGS+= -DMALLOC_0_RETURNS_NULL
INSTALLS_SHLIB= yes
USE_GNOME= gnomehack pkgconfig
diff --git a/x11/libXcursor/Makefile b/x11/libXcursor/Makefile
index f2a8d694c871..b20731d017c7 100644
--- a/x11/libXcursor/Makefile
+++ b/x11/libXcursor/Makefile
@@ -29,7 +29,7 @@ PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13
CFLAGS+= -DMALLOC_0_RETURNS_NULL
MAN3= Xcursor.3
INSTALLS_SHLIB= yes
diff --git a/x11/libXdamage/Makefile b/x11/libXdamage/Makefile
index 58a80cf88efd..14e716b49a4f 100644
--- a/x11/libXdamage/Makefile
+++ b/x11/libXdamage/Makefile
@@ -25,7 +25,7 @@ PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13
CFLAGS+= -DMALLOC_0_RETURNS_NULL
INSTALLS_SHLIB= yes
USE_GNOME= gnomehack pkgconfig
diff --git a/x11/libXext/Makefile b/x11/libXext/Makefile
index ca4a84836707..8eb9867781e1 100644
--- a/x11/libXext/Makefile
+++ b/x11/libXext/Makefile
@@ -25,7 +25,7 @@ PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13:inc
CFLAGS+= -DMALLOC_0_RETURNS_NULL
INSTALLS_SHLIB= yes
USE_GNOME= gnomehack pkgconfig
diff --git a/x11/libXfixes/Makefile b/x11/libXfixes/Makefile
index caf85cf2638d..9ec158fdaffb 100644
--- a/x11/libXfixes/Makefile
+++ b/x11/libXfixes/Makefile
@@ -25,7 +25,7 @@ PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13
CFLAGS+= -DMALLOC_0_RETURNS_NULL
INSTALLS_SHLIB= yes
USE_GNOME= gnomehack pkgconfig
diff --git a/x11/libXi/Makefile b/x11/libXi/Makefile
index 643c11ec21ab..bab6a804bf45 100644
--- a/x11/libXi/Makefile
+++ b/x11/libXi/Makefile
@@ -27,7 +27,7 @@ PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13
CFLAGS+= -DMALLOC_0_RETURNS_NULL
INSTALLS_SHLIB= yes
USE_GNOME= gnomehack pkgconfig
diff --git a/x11/libXpm/Makefile b/x11/libXpm/Makefile
index 258d25dcd4a4..19f4157b2ce0 100644
--- a/x11/libXpm/Makefile
+++ b/x11/libXpm/Makefile
@@ -26,7 +26,7 @@ PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-USE_INC_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13:inc
CFLAGS+= -DMALLOC_0_RETURNS_NULL
INSTALLS_SHLIB= yes
USE_GNOME= gnomehack pkgconfig
diff --git a/x11/libXrender/Makefile b/x11/libXrender/Makefile
index 3e7e282ad082..d43c9bebfa02 100644
--- a/x11/libXrender/Makefile
+++ b/x11/libXrender/Makefile
@@ -28,7 +28,7 @@ PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13:inc
CFLAGS+= -DMALLOC_0_RETURNS_NULL
INSTALLS_SHLIB= yes
USE_GNOME= gnomehack pkgconfig
diff --git a/x11/libXres/Makefile b/x11/libXres/Makefile
index 469d86022389..4bf3ced4d94f 100644
--- a/x11/libXres/Makefile
+++ b/x11/libXres/Makefile
@@ -29,7 +29,7 @@ PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-USE_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13
CFLAGS+= -DMALLOC_0_RETURNS_NULL
INSTALLS_SHLIB= yes
USE_GNOME= gnomehack pkgconfig
diff --git a/x11/libXv/Makefile b/x11/libXv/Makefile
index 8faacf984e29..463464ef837c 100644
--- a/x11/libXv/Makefile
+++ b/x11/libXv/Makefile
@@ -24,7 +24,7 @@ PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13
CFLAGS+= -DMALLOC_0_RETURNS_NULL
INSTALLS_SHLIB= yes
USE_GNOME= gnomehack pkgconfig
diff --git a/x11/libexo/Makefile b/x11/libexo/Makefile
index 62588ca3e353..5844a294909f 100644
--- a/x11/libexo/Makefile
+++ b/x11/libexo/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= xfcegui4.3:${PORTSDIR}/x11-toolkits/libxfce4gui
WRKSRC= ${WRKDIR}/${DISTNAME}
GNU_CONFIGURE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
USE_GNOME= glib20
USE_X_PREFIX= yes
diff --git a/x11/libgnomemm/Makefile b/x11/libgnomemm/Makefile
index d8b697bba0bd..ba62c2a0f746 100644
--- a/x11/libgnomemm/Makefile
+++ b/x11/libgnomemm/Makefile
@@ -22,7 +22,7 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomehack libgnome
-USE_INC_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13:inc
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-static
diff --git a/x11/libgnomemm26/Makefile b/x11/libgnomemm26/Makefile
index d6fdf0c34f9d..ef4ba0b4676a 100644
--- a/x11/libgnomemm26/Makefile
+++ b/x11/libgnomemm26/Makefile
@@ -26,7 +26,7 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GCC= 3.4
USE_GNOME= gnomehack libgnome
-USE_INC_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15:inc
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-static
diff --git a/x11/libxfce4mcs/Makefile b/x11/libxfce4mcs/Makefile
index 9df55b57e066..fdb6f781801d 100644
--- a/x11/libxfce4mcs/Makefile
+++ b/x11/libxfce4mcs/Makefile
@@ -27,7 +27,7 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
NO_FILTER_SHLIBS= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
.if defined(WITH_GTKDOC)
BUILD_DEPENDS+= gtkdocize:${PORTSDIR}/textproc/gtk-doc
diff --git a/x11/libxfce4util/Makefile b/x11/libxfce4util/Makefile
index 2dbe2ca7ef7d..6bda003832e7 100644
--- a/x11/libxfce4util/Makefile
+++ b/x11/libxfce4util/Makefile
@@ -25,7 +25,7 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
NO_FILTER_SHLIBS= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
.if defined(WITH_GTKDOC)
BUILD_DEPENDS+= gtkdocize:${PORTSDIR}/textproc/gtk-doc
diff --git a/x11/libxklavier/Makefile b/x11/libxklavier/Makefile
index 3ec757055fd6..ac259d070eeb 100644
--- a/x11/libxklavier/Makefile
+++ b/x11/libxklavier/Makefile
@@ -21,7 +21,7 @@ USE_GMAKE= yes
USE_GNOME= gnometarget gnomehack libxml2
INSTALLS_SHLIB= yes
USE_GETOPT_LONG=yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include
CONFIGURE_ARGS= --disable-doxygen \
--with-xkb-base=${X11BASE}/lib/X11/xkb
diff --git a/x11/mgapdesk/Makefile b/x11/mgapdesk/Makefile
index 23276ce4865c..fef25e3c6ffb 100644
--- a/x11/mgapdesk/Makefile
+++ b/x11/mgapdesk/Makefile
@@ -19,7 +19,7 @@ COMMENT= Matrox Powerdesk for *nix
USE_X_PREFIX= YES
USE_GNOME= gtk12
USE_GMAKE= YES
-USE_AUTOCONF_VER= 213
+USE_AUTOTOOLS= autoconf:213
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/x11/mlterm/Makefile b/x11/mlterm/Makefile
index 5ac498404ab3..237a7af2d322 100644
--- a/x11/mlterm/Makefile
+++ b/x11/mlterm/Makefile
@@ -17,7 +17,7 @@ COMMENT= Multilingual X11 terminal emulator
USE_X_PREFIX= yes
USE_GNOME= gtk20 lthack
-USE_INC_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13:inc
USE_REINPLACE= yes
USE_PERL5_BUILD=yes
CONFIGURE_ARGS= --with-imagelib=gdk-pixbuf --enable-utmp \
diff --git a/x11/multi-aterm/Makefile b/x11/multi-aterm/Makefile
index cac30db984d9..3715741c7bba 100644
--- a/x11/multi-aterm/Makefile
+++ b/x11/multi-aterm/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= esn@x123.info
COMMENT= A multi terminal based on aterm
USE_X_PREFIX= yes
-USE_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/x11/portoseguro/Makefile b/x11/portoseguro/Makefile
index 91b96069cda9..f3e8c398a109 100644
--- a/x11/portoseguro/Makefile
+++ b/x11/portoseguro/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= trevor@FreeBSD.org
COMMENT= Launch applications by clicking on an icon bar
CONFIGURE_ENV= GTKCONFIG=${GTK_CONFIG}
-USE_AUTOCONF_VER= 213
+USE_AUTOTOOLS= autoconf:213
GNU_CONFIGURE= yes
USE_GNOME= gtk12
USE_X_PREFIX= yes
diff --git a/x11/powershell/Makefile b/x11/powershell/Makefile
index 19c74b1f83b9..29ec49c1a416 100644
--- a/x11/powershell/Makefile
+++ b/x11/powershell/Makefile
@@ -17,7 +17,7 @@ COMMENT= A terminal emulator for the X11
USE_X_PREFIX= yes
USE_GNOME= gnomelibs
-USE_AUTOCONF_VER= 213
+USE_AUTOTOOLS= autoconf:213
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include `${IMLIB_CONFIG} --cflags`" \
LDFLAGS="-L${LOCALBASE}/lib `${IMLIB_CONFIG} --libs`"
ALL_TARGET= ${PORTNAME}
diff --git a/x11/rxvt-devel/Makefile b/x11/rxvt-devel/Makefile
index 7a0f22e7aecf..c852e14911a0 100644
--- a/x11/rxvt-devel/Makefile
+++ b/x11/rxvt-devel/Makefile
@@ -22,7 +22,7 @@ DISTNAME= rxvt-${PORTVERSION}
MAINTAINER= lioux@FreeBSD.org
COMMENT= A low memory usage xterm replacement that supports color
-USE_INC_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13:inc
USE_PERL5_BUILD=yes
USE_X_PREFIX= yes
diff --git a/x11/startup-notification/Makefile b/x11/startup-notification/Makefile
index 7bb884219b96..96596bfae7f8 100644
--- a/x11/startup-notification/Makefile
+++ b/x11/startup-notification/Makefile
@@ -20,7 +20,7 @@ COMMENT= Library that supports startup notification spec from freedesktop.org
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnometarget pkgconfig
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/x11/tkXwin/Makefile b/x11/tkXwin/Makefile
index 211c272187ac..adf4e7cf48e4 100644
--- a/x11/tkXwin/Makefile
+++ b/x11/tkXwin/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= tcl${SHORT_TK_VER}:${PORTSDIR}/lang/tcl${SHORT_TK_VER} \
GNU_CONFIGURE= yes
USE_X_PREFIX= yes
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl${TK_VER} \
--with-tclinclude=${LOCALBASE}/include/tcl${TK_VER} \
diff --git a/x11/vdesk/Makefile b/x11/vdesk/Makefile
index 85d9fd128ee0..2e67c7733038 100644
--- a/x11/vdesk/Makefile
+++ b/x11/vdesk/Makefile
@@ -22,7 +22,7 @@ PLIST_FILES+= share/doc/vdesk/${ii}
.endfor
.endif
USE_X_PREFIX= yes
-USE_AUTOCONF_VER= 259
+USE_AUTOTOOLS= autoconf:259
post-extract:
# Avoid having to read this lengthy file.
diff --git a/x11/xfce4-clipman-plugin/Makefile b/x11/xfce4-clipman-plugin/Makefile
index 2c4b8831c3ad..c6d95df9ae50 100644
--- a/x11/xfce4-clipman-plugin/Makefile
+++ b/x11/xfce4-clipman-plugin/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
USE_GNOME= gtk20
USE_X_PREFIX= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
diff --git a/x11/xfce4-taskmanager/Makefile b/x11/xfce4-taskmanager/Makefile
index 0aaaa924224f..518bb3f51bad 100644
--- a/x11/xfce4-taskmanager/Makefile
+++ b/x11/xfce4-taskmanager/Makefile
@@ -15,7 +15,6 @@ COMMENT= A task manager for XFCE
BUILD_DEPENDS= xfwm4:${PORTSDIR}/x11-wm/xfce4-wm
-USE_AUTOMAKE_VER= 19
-USE_AUTOCONF_VER= 259
+USE_AUTOTOOLS= automake:19 autoconf:259
.include <bsd.port.mk>
diff --git a/x11/xfce4-trigger-launcher/Makefile b/x11/xfce4-trigger-launcher/Makefile
index 2b2c7ba5efce..f5eb453bd132 100644
--- a/x11/xfce4-trigger-launcher/Makefile
+++ b/x11/xfce4-trigger-launcher/Makefile
@@ -27,7 +27,7 @@ RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
USE_GNOME= gtk20 libxml2
USE_X_PREFIX= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
.include <bsd.port.mk>