aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2013-01-24 22:43:07 +0000
committerNicola Vitale <nivit@FreeBSD.org>2013-01-24 22:43:07 +0000
commit65ace5171da29eb4552718f9b23f94c0ea8e871a (patch)
tree0594ee492c13a6adebe93ba7c1afbc1af89a7ed0 /x11
parentf391c85c5c744e76528c82b83538b8e6c2ec10b9 (diff)
downloadports-65ace5171da29eb4552718f9b23f94c0ea8e871a.tar.gz
ports-65ace5171da29eb4552718f9b23f94c0ea8e871a.zip
Gnome-Pie is a circular application launcher. It is made of several pies,
each consisting of multiple slices. The user presses a key stroke which opens the desired pie. By activating one of its slices, applications may be launched, key presses may be simulated or files can be opened. WWW: http://gnome-pie.simonschneegans.de/
Notes
Notes: svn path=/head/; revision=310953
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/gnome-pie/Makefile74
-rw-r--r--x11/gnome-pie/distinfo2
-rw-r--r--x11/gnome-pie/files/patch-CMakeLists.txt30
-rw-r--r--x11/gnome-pie/files/patch-resources__gnome-pie.desktop8
-rw-r--r--x11/gnome-pie/files/patch-src__CMakeLists.txt43
-rw-r--r--x11/gnome-pie/files/patch-src__actionGroups__windowListGroup.vala28
-rw-r--r--x11/gnome-pie/files/patch-src__actions__actionRegistry.vala11
-rw-r--r--x11/gnome-pie/files/patch-src__utilities__paths.vala27
-rw-r--r--x11/gnome-pie/files/pkg-message.in13
-rw-r--r--x11/gnome-pie/pkg-descr6
-rw-r--r--x11/gnome-pie/pkg-plist98
12 files changed, 341 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index b3ecca7d1ad8..2f256e6a37c2 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -83,6 +83,7 @@
SUBDIR += gnome-menus
SUBDIR += gnome-panel
SUBDIR += gnome-panel-reference
+ SUBDIR += gnome-pie
SUBDIR += gnome-screensaver
SUBDIR += gnome-session
SUBDIR += gnome-shell
diff --git a/x11/gnome-pie/Makefile b/x11/gnome-pie/Makefile
new file mode 100644
index 000000000000..9af6dee7e1c4
--- /dev/null
+++ b/x11/gnome-pie/Makefile
@@ -0,0 +1,74 @@
+# Created by: Nicola Vitale <nivit@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= gnome-pie
+PORTVERSION= 0.5.2
+#PORTREVISION= 0
+CATEGORIES= x11
+# Waiting for a tag on the GitHub repository https://github.com/Simmesimme/Gnome-Pie...
+MASTER_SITES= LOCAL/nivit/${PORTNAME}/
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Circular application launcher
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= valac:${PORTSDIR}/lang/vala
+RUN_DEPENDS= gnome-icons-elementary>=2.5:${PORTSDIR}/x11-themes/gnome-icons-elementary \
+ gnome-settings-daemon>=2.32.1_4:${PORTSDIR}/sysutils/gnome-settings-daemon
+LIB_DEPENDS= Xtst:${PORTSDIR}/x11/libXtst \
+ cairo:${PORTSDIR}/graphics/cairo \
+ gee:${PORTSDIR}/devel/libgee \
+ unique:${PORTSDIR}/x11-toolkits/unique
+
+INSTALLS_ICONS= yes
+OPTIONS_DEFINE= DOCS MANPAGES NLS
+OPTIONS_DEFAULT= DOCS MANPAGES NLS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+CMAKE_ARGS= -DINSTALL_DOCS:BOOL=ON
+.endif
+
+.if ${PORT_OPTIONS:MMANPAGES}
+MAN1= gnome-pie.1
+.else
+CMAKE_ARGS+= -DNO_INSTALL_MANPAGES:BOOL=ON
+.endif
+
+.if ${PORT_OPTIONS:MNLS}
+CMAKE_ARGS+= -DINSTALL_NLS:BOOL=ON
+USE_GETTEXT= yes
+PLIST_SUB= NLS=""
+.else
+CMAKE_ARGS+= -DINSTALL_NLS:BOOL=OFF
+PLIST_SUB= NLS="@comment "
+.endif
+
+PLIST_SUB+= DESKTOPDIR=${DESKTOPDIR:S,${PREFIX}/,,}
+
+REINPLACE_ARGS= -e 's,%%DATADIR%%,${DATADIR},1' \
+ -e 's,%%DESKTOPDIR%%,${DESKTOPDIR},1' \
+ -e 's,%%PREFIX%%,${PREFIX},1' \
+ -i.bak
+
+SUB_FILES= pkg-message
+SUB_LIST= PORTSDIR=${PORTSDIR}
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+USE_GNOME= gconf2 gnomemenus gtk20 libwnck
+USE_PKGCONFIG= build
+
+post-patch:
+ ${REINPLACE_CMD} ${WRKSRC}/src/actions/actionRegistry.vala ${WRKSRC}/src/utilities/paths.vala
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+gnome-pie-user:
+ gconftool-2 --type string --set /desktop/gnome/interface/icon_theme "elementary"
+ gconftool-2 --type bool --set /desktop/gnome/interface/menus_have_icons true
+
+.include <bsd.port.mk>
diff --git a/x11/gnome-pie/distinfo b/x11/gnome-pie/distinfo
new file mode 100644
index 000000000000..819bd91b4e3d
--- /dev/null
+++ b/x11/gnome-pie/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gnome-pie-0.5.2.tar.bz2) = 12fd55ea199f4a22bcfe76989e6e44650dd1f169b7b3592b1cfff3fe01e95d8d
+SIZE (gnome-pie-0.5.2.tar.bz2) = 185397
diff --git a/x11/gnome-pie/files/patch-CMakeLists.txt b/x11/gnome-pie/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..107842398159
--- /dev/null
+++ b/x11/gnome-pie/files/patch-CMakeLists.txt
@@ -0,0 +1,30 @@
+--- ./CMakeLists.txt.orig 2013-01-23 23:33:16.000000000 +0100
++++ ./CMakeLists.txt 2013-01-24 21:41:21.000000000 +0100
+@@ -32,13 +32,11 @@
+ pkg_check_modules(INDICATOR3 appindicator3-0.1)
+ pkg_check_modules(UNIQUE REQUIRED unique-3.0)
+ pkg_check_modules(WNCK REQUIRED libwnck-3.0)
+- pkg_check_modules(BAMF REQUIRED libbamf3)
+ else (${GTK3_FOUND})
+ pkg_check_modules(GTK2 REQUIRED gtk+-2.0)
+ pkg_check_modules(INDICATOR appindicator-0.1)
+ pkg_check_modules(UNIQUE REQUIRED unique-1.0)
+ pkg_check_modules(WNCK REQUIRED libwnck-1.0)
+- pkg_check_modules(BAMF REQUIRED libbamf)
+ endif (${GTK3_FOUND})
+
+ pkg_check_modules(GIO REQUIRED gio-unix-2.0)
+@@ -180,13 +178,11 @@
+ if (${GTK3_FOUND})
+ LIST(APPEND VALA_PKGS gtk+-3.0)
+ LIST(APPEND VALA_PKGS gdk-x11-3.0)
+- LIST(APPEND VALA_PKGS libbamf3)
+ LIST(APPEND VALA_PKGS libwnck-3.0)
+ LIST(APPEND VALA_PKGS unique-3.0)
+ else (${GTK3_FOUND})
+ LIST(APPEND VALA_PKGS gtk+-2.0)
+ LIST(APPEND VALA_PKGS gdk-x11-2.0)
+- LIST(APPEND VALA_PKGS bamf)
+ LIST(APPEND VALA_PKGS libwnck-1.0)
+ LIST(APPEND VALA_PKGS unique-1.0)
+ endif (${GTK3_FOUND})
diff --git a/x11/gnome-pie/files/patch-resources__gnome-pie.desktop b/x11/gnome-pie/files/patch-resources__gnome-pie.desktop
new file mode 100644
index 000000000000..019a50600d0b
--- /dev/null
+++ b/x11/gnome-pie/files/patch-resources__gnome-pie.desktop
@@ -0,0 +1,8 @@
+--- ./resources/gnome-pie.desktop.orig 2013-01-23 23:33:16.000000000 +0100
++++ ./resources/gnome-pie.desktop 2013-01-24 21:41:21.000000000 +0100
+@@ -4,4 +4,4 @@
+ Comment=Cakes don't lie.
+ Exec=gnome-pie
+ Icon=gnome-pie
+-Categories=GNOME;Utility;
++Categories=GTK;GNOME;Utility;
diff --git a/x11/gnome-pie/files/patch-src__CMakeLists.txt b/x11/gnome-pie/files/patch-src__CMakeLists.txt
new file mode 100644
index 000000000000..b35444807d24
--- /dev/null
+++ b/x11/gnome-pie/files/patch-src__CMakeLists.txt
@@ -0,0 +1,43 @@
+--- ./src/CMakeLists.txt.orig 2013-01-23 23:33:16.000000000 +0100
++++ ./src/CMakeLists.txt 2013-01-24 21:41:57.000000000 +0100
+@@ -43,6 +43,7 @@
+ ${CMAKE_INSTALL_PREFIX}/bin
+ )
+
++if (INSTALL_DOCS)
+ # install credits
+ install(
+ FILES
+@@ -50,7 +51,9 @@
+ DESTINATION
+ ${CMAKE_INSTALL_PREFIX}/share/doc/gnome-pie
+ )
++endif()
+
++if (INSTALL_NLS)
+ # install locales
+ install(
+ DIRECTORY
+@@ -61,6 +64,7 @@
+ PATTERN *.pot EXCLUDE
+ PATTERN *.sh EXCLUDE
+ )
++endif()
+
+ # install themes
+ install(
+@@ -95,11 +99,12 @@
+ ${CMAKE_INSTALL_PREFIX}/share/applications
+ )
+
++if (NOT NO_INSTALL_MANPAGES)
+ # install manpage
+ install(
+ FILES
+ ${CMAKE_SOURCE_DIR}/resources/gnome-pie.1
+ DESTINATION
+- ${CMAKE_INSTALL_PREFIX}/share/man/man1
++ ${CMAKE_INSTALL_PREFIX}/man/man1
+ )
+-
++endif()
diff --git a/x11/gnome-pie/files/patch-src__actionGroups__windowListGroup.vala b/x11/gnome-pie/files/patch-src__actionGroups__windowListGroup.vala
new file mode 100644
index 000000000000..5c4a903744c0
--- /dev/null
+++ b/x11/gnome-pie/files/patch-src__actionGroups__windowListGroup.vala
@@ -0,0 +1,28 @@
+--- ./src/actionGroups/windowListGroup.vala.orig 2013-01-23 23:33:16.000000000 +0100
++++ ./src/actionGroups/windowListGroup.vala 2013-01-24 21:41:21.000000000 +0100
+@@ -76,13 +76,13 @@
+ private void load() {
+ unowned GLib.List<Wnck.Window?> windows = this.screen.get_windows();
+
+- var matcher = Bamf.Matcher.get_default();
++ //var matcher = Bamf.Matcher.get_default();
+
+ foreach (var window in windows) {
+ if (window.get_window_type() == Wnck.WindowType.NORMAL
+ && !window.is_skip_pager() && !window.is_skip_tasklist()) {
+ var application = window.get_application();
+- var bamf_app = matcher.get_application_for_xid((uint32)window.get_xid());
++ //var bamf_app = matcher.get_application_for_xid((uint32)window.get_xid());
+
+ string name = window.get_name();
+
+@@ -91,7 +91,8 @@
+
+ var action = new SigAction(
+ name,
+- (bamf_app == null) ? application.get_icon_name().down() : bamf_app.get_icon(),
++ //(bamf_app == null) ? application.get_icon_name().down() : bamf_app.get_icon(),
++ application.get_icon_name().down(),
+ "%lu".printf(window.get_xid())
+ );
+ action.activated.connect(() => {
diff --git a/x11/gnome-pie/files/patch-src__actions__actionRegistry.vala b/x11/gnome-pie/files/patch-src__actions__actionRegistry.vala
new file mode 100644
index 000000000000..3a963e11e3c1
--- /dev/null
+++ b/x11/gnome-pie/files/patch-src__actions__actionRegistry.vala
@@ -0,0 +1,11 @@
+--- ./src/actions/actionRegistry.vala.orig 2013-01-23 23:33:16.000000000 +0100
++++ ./src/actions/actionRegistry.vala 2013-01-24 21:41:21.000000000 +0100
+@@ -108,7 +108,7 @@
+ case "application":
+ var file_name = uri.split("//")[1];
+
+- var desktop_file = GLib.File.new_for_path("/usr/share/applications/" + file_name);
++ var desktop_file = GLib.File.new_for_path("%%DESKTOPDIR%%/" + file_name);
+ if (desktop_file.query_exists())
+ return new_for_desktop_file(desktop_file.get_path());
+
diff --git a/x11/gnome-pie/files/patch-src__utilities__paths.vala b/x11/gnome-pie/files/patch-src__utilities__paths.vala
new file mode 100644
index 000000000000..72bdf2ff2693
--- /dev/null
+++ b/x11/gnome-pie/files/patch-src__utilities__paths.vala
@@ -0,0 +1,27 @@
+--- ./src/utilities/paths.vala.orig 2013-01-23 23:33:16.000000000 +0100
++++ ./src/utilities/paths.vala 2013-01-24 21:41:21.000000000 +0100
+@@ -71,21 +71,21 @@
+ /// usually /usr/share/gnome-pie/themes.
+ /////////////////////////////////////////////////////////////////////
+
+- public static string global_themes { get; private set; default=""; }
++ public static string global_themes { get; private set; default="%%DATADIR%%/themes"; }
+
+ /////////////////////////////////////////////////////////////////////
+ /// The directory containing locale files
+ /// usually /usr/share/locale.
+ /////////////////////////////////////////////////////////////////////
+
+- public static string locales { get; private set; default=""; }
++ public static string locales { get; private set; default="%%PREFIX%%/share/locale"; }
+
+ /////////////////////////////////////////////////////////////////////
+ /// The directory containing UI declaration files
+ /// usually /usr/share/gnome-pie/ui/.
+ /////////////////////////////////////////////////////////////////////
+
+- public static string ui_files { get; private set; default=""; }
++ public static string ui_files { get; private set; default="%%DATADIR%%/ui"; }
+
+ /////////////////////////////////////////////////////////////////////
+ /// The autostart file of gnome-pie_config
diff --git a/x11/gnome-pie/files/pkg-message.in b/x11/gnome-pie/files/pkg-message.in
new file mode 100644
index 000000000000..0d31b94780dd
--- /dev/null
+++ b/x11/gnome-pie/files/pkg-message.in
@@ -0,0 +1,13 @@
+***************************************************************
+
+If you do not use GNOME as window manager, and do not see any
+icon in Gnome-Pie preferences, then run the following command:
+
+ (cd %%PORTSDIR%%/x11/gnome-pie && make gnome-pie-user)
+
+and add this line to your ~/.xinitrc
+
+ %%LOCALBASE%%/libexec/gnome-settings-daemon&
+ (sleep 2 && gnome-pie)&
+
+***************************************************************
diff --git a/x11/gnome-pie/pkg-descr b/x11/gnome-pie/pkg-descr
new file mode 100644
index 000000000000..64a63b9c949e
--- /dev/null
+++ b/x11/gnome-pie/pkg-descr
@@ -0,0 +1,6 @@
+Gnome-Pie is a circular application launcher. It is made of several pies,
+each consisting of multiple slices. The user presses a key stroke which
+opens the desired pie. By activating one of its slices, applications may
+be launched, key presses may be simulated or files can be opened.
+
+WWW: http://gnome-pie.simonschneegans.de/
diff --git a/x11/gnome-pie/pkg-plist b/x11/gnome-pie/pkg-plist
new file mode 100644
index 000000000000..17d2f87c2a87
--- /dev/null
+++ b/x11/gnome-pie/pkg-plist
@@ -0,0 +1,98 @@
+@comment FreeBSD$
+bin/gnome-pie
+%%DESKTOPDIR%%/gnome-pie.desktop
+%%PORTDOCS%%%%DOCSDIR%%/README.md
+%%DATADIR%%/themes/adwaita/arrow.svg
+%%DATADIR%%/themes/adwaita/caption_mask.svg
+%%DATADIR%%/themes/adwaita/icon_active.svg
+%%DATADIR%%/themes/adwaita/icon_inactive.svg
+%%DATADIR%%/themes/adwaita/preview.png
+%%DATADIR%%/themes/adwaita/ring.svg
+%%DATADIR%%/themes/adwaita/theme.xml
+%%DATADIR%%/themes/bright/arrow.svg
+%%DATADIR%%/themes/bright/caption.svg
+%%DATADIR%%/themes/bright/caption_mask.svg
+%%DATADIR%%/themes/bright/gloss.svg
+%%DATADIR%%/themes/bright/icon_active.svg
+%%DATADIR%%/themes/bright/icon_inactive.svg
+%%DATADIR%%/themes/bright/preview.png
+%%DATADIR%%/themes/bright/ring.svg
+%%DATADIR%%/themes/bright/theme.xml
+%%DATADIR%%/themes/elementary/icon_bg.svg
+%%DATADIR%%/themes/elementary/preview.png
+%%DATADIR%%/themes/elementary/ring.svg
+%%DATADIR%%/themes/elementary/slice_caption.svg
+%%DATADIR%%/themes/elementary/theme.xml
+%%DATADIR%%/themes/funky/bg.svg
+%%DATADIR%%/themes/funky/blue.svg
+%%DATADIR%%/themes/funky/caption.svg
+%%DATADIR%%/themes/funky/icon_bg.svg
+%%DATADIR%%/themes/funky/icon_fg.svg
+%%DATADIR%%/themes/funky/preview.png
+%%DATADIR%%/themes/funky/red.svg
+%%DATADIR%%/themes/funky/slice_caption.svg
+%%DATADIR%%/themes/funky/star.svg
+%%DATADIR%%/themes/funky/theme.xml
+%%DATADIR%%/themes/gloss/arrow.svg
+%%DATADIR%%/themes/gloss/glow_bg.svg
+%%DATADIR%%/themes/gloss/icon_bg.svg
+%%DATADIR%%/themes/gloss/icon_fg.svg
+%%DATADIR%%/themes/gloss/icon_fg_active.svg
+%%DATADIR%%/themes/gloss/icon_mask.svg
+%%DATADIR%%/themes/gloss/preview.png
+%%DATADIR%%/themes/gloss/slice_caption.svg
+%%DATADIR%%/themes/gloss/theme.xml
+%%DATADIR%%/themes/minimalistic_text/bg.svg
+%%DATADIR%%/themes/minimalistic_text/fg.svg
+%%DATADIR%%/themes/minimalistic_text/preview.png
+%%DATADIR%%/themes/minimalistic_text/theme.xml
+%%DATADIR%%/themes/o-pie/arrow.svg
+%%DATADIR%%/themes/o-pie/caption1.svg
+%%DATADIR%%/themes/o-pie/caption2.svg
+%%DATADIR%%/themes/o-pie/preview.png
+%%DATADIR%%/themes/o-pie/ring.svg
+%%DATADIR%%/themes/o-pie/theme.xml
+%%DATADIR%%/themes/slim/bg.svg
+%%DATADIR%%/themes/slim/dot.svg
+%%DATADIR%%/themes/slim/preview.png
+%%DATADIR%%/themes/slim/slice_caption.svg
+%%DATADIR%%/themes/slim/theme.xml
+%%DATADIR%%/themes/unity/arrow.svg
+%%DATADIR%%/themes/unity/caption.svg
+%%DATADIR%%/themes/unity/caption_mask.svg
+%%DATADIR%%/themes/unity/gloss.svg
+%%DATADIR%%/themes/unity/icon_active.svg
+%%DATADIR%%/themes/unity/icon_inactive.svg
+%%DATADIR%%/themes/unity/preview.png
+%%DATADIR%%/themes/unity/ring.svg
+%%DATADIR%%/themes/unity/theme.xml
+%%DATADIR%%/ui/icon_select.ui
+%%DATADIR%%/ui/preferences.ui
+%%DATADIR%%/ui/rename_pie.ui
+%%DATADIR%%/ui/settings.ui
+%%DATADIR%%/ui/slice_select.ui
+%%DATADIR%%/ui/trigger_select.ui
+share/icons/hicolor/scalable/apps/gnome-pie-symbolic.svg
+share/icons/hicolor/scalable/apps/gnome-pie.svg
+%%NLS%%share/locale/bg/LC_MESSAGES/gnomepie.mo
+%%NLS%%share/locale/de/LC_MESSAGES/gnomepie.mo
+%%NLS%%share/locale/es/LC_MESSAGES/gnomepie.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/gnomepie.mo
+%%NLS%%share/locale/it/LC_MESSAGES/gnomepie.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/gnomepie.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/gnomepie.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/gnomepie.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/gnomepie.mo
+@dirrm %%DATADIR%%/ui
+@dirrm %%DATADIR%%/themes/unity
+@dirrm %%DATADIR%%/themes/slim
+@dirrm %%DATADIR%%/themes/o-pie
+@dirrm %%DATADIR%%/themes/minimalistic_text
+@dirrm %%DATADIR%%/themes/gloss
+@dirrm %%DATADIR%%/themes/funky
+@dirrm %%DATADIR%%/themes/elementary
+@dirrm %%DATADIR%%/themes/bright
+@dirrm %%DATADIR%%/themes/adwaita
+@dirrm %%DATADIR%%/themes
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%