aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2013-01-19 21:06:45 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2013-01-19 21:06:45 +0000
commite367b617267d8d72c4021de67cca0731c7d4e8b2 (patch)
tree23c62fef435570b7cd5e429723eef3fe151e0f0c /x11
parentc51fef486aa785c49fb66ed67d41cd6dfbac74ab (diff)
downloadports-e367b617267d8d72c4021de67cca0731c7d4e8b2.tar.gz
ports-e367b617267d8d72c4021de67cca0731c7d4e8b2.zip
Add patch, which fixes help page, when Help button is pressed.
Approved by: rene, miwi (mentors, implicit)
Notes
Notes: svn path=/head/; revision=310659
Diffstat (limited to 'x11')
-rw-r--r--x11/xfce4-screenshooter-plugin/Makefile2
-rw-r--r--x11/xfce4-screenshooter-plugin/files/patch-lib__screenshooter-utils.c22
2 files changed, 23 insertions, 1 deletions
diff --git a/x11/xfce4-screenshooter-plugin/Makefile b/x11/xfce4-screenshooter-plugin/Makefile
index 219060651784..abe2873d72dd 100644
--- a/x11/xfce4-screenshooter-plugin/Makefile
+++ b/x11/xfce4-screenshooter-plugin/Makefile
@@ -4,7 +4,7 @@
PORTNAME= xfce4-screenshooter-plugin
PORTVERSION= 1.8.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR=src/apps/xfce4-screenshooter/${PORTVERSION:R}
diff --git a/x11/xfce4-screenshooter-plugin/files/patch-lib__screenshooter-utils.c b/x11/xfce4-screenshooter-plugin/files/patch-lib__screenshooter-utils.c
new file mode 100644
index 000000000000..669313c7dcd0
--- /dev/null
+++ b/x11/xfce4-screenshooter-plugin/files/patch-lib__screenshooter-utils.c
@@ -0,0 +1,22 @@
+--- ./lib/screenshooter-utils.c.orig 2010-05-21 08:11:35.000000000 +0000
++++ ./lib/screenshooter-utils.c 2013-01-19 21:15:00.000000000 +0000
+@@ -345,10 +345,17 @@
+ void screenshooter_open_help (void)
+ {
+ GError *error_help = NULL;
++ gboolean result;
+
+ /* Launch the help page and show an error dialog if there was an error. */
+- if (!g_spawn_command_line_async ("xfhelp4 xfce4-screenshooter.html",
+- &error_help))
++#if LIBXFCE4UTIL_CHECK_VERSION (4, 10, 0)
++ result = g_spawn_command_line_async("exo-open --launch TerminalEmulator man xfce4-screenshooter",
++ &error_help);
++#else
++ result = g_spawn_command_line_async ("xfhelp4 xfce4-screenshooter.html",
++ &error_help);
++#endif
++ if (G_UNLIKELY (result == FALSE))
+ {
+ screenshooter_error ("%s", error_help->message);
+ g_error_free (error_help);