aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-28 11:51:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-28 11:51:05 +0000
commit932db7c46c9a269808dfa67ea02746b350c194d8 (patch)
tree5182ef394eeef9bff78abf27f4a3a05f7fb8ff43 /x11
parentb9b5e71f19dfde1a969d42e0660cc786432b3500 (diff)
downloadports-932db7c46c9a269808dfa67ea02746b350c194d8.tar.gz
ports-932db7c46c9a269808dfa67ea02746b350c194d8.zip
New USES imake to handle the dependency on imake.
This uses accept 'env' as an argument for ports that do use their own or a different do-configure target. Modify xmkmf so it accept IMAKECPPFLAGS as default flags for imake and pass it to the called imake. Modify xorg-cf-files (the FreeBSD.cf configuration file) to allow CppCmd to be overwritten. Pass CppCmd CcCmd and CplusplusCmd via command line to each call of imake via IMAKECPPFLAGS Pass IMAKE_DEFINE with the above arguments to MAKE_ARGS so that imake spawned from Makefile generated by a previous imake also inherit the defined CppCmd CcCmd and CplusplusCmd. Make imake use devel/tradcpp all the time, so that when buidling with clang we do not depend on gcc's cpp. Make imake respect CC and CXX Make imake respect USE_GCC (if set imake will use gcc's cpp). While here: - Remove a couple of indefinite articles from comments - Trim headers - Fix a couple of ports to build with clang or use: USE_GCC=any - Fix a now useless redefinition of the extraction chain - Fix a typo in japanese/Wnn7-lib bundled imake template definitions - Fix some XMKMF execution with no env specified - Use options helper in x11/xautolock to simplify the port
Notes
Notes: svn path=/head/; revision=321957
Diffstat (limited to 'x11')
-rw-r--r--x11/bricons/Makefile8
-rw-r--r--x11/dynamag/Makefile2
-rw-r--r--x11/kdebase3/Makefile4
-rw-r--r--x11/props/Makefile8
-rw-r--r--x11/x3270/Makefile9
-rw-r--r--x11/xascii/Makefile8
-rw-r--r--x11/xautolock/Makefile8
-rw-r--r--x11/xcb/Makefile2
-rw-r--r--x11/xcoloredit/Makefile8
-rw-r--r--x11/xgrab/Makefile3
-rw-r--r--x11/xlogout/Makefile2
-rw-r--r--x11/xmotd/Makefile11
-rw-r--r--x11/xorg-cf-files/Makefile9
-rw-r--r--x11/xorg-cf-files/files/patch-FreeBSD.cf20
-rw-r--r--x11/xprompt/Makefile2
-rw-r--r--x11/xstroke/Makefile3
-rw-r--r--x11/xvkbd/Makefile2
-rw-r--r--x11/xwit/Makefile8
-rw-r--r--x11/xxkb/Makefile4
19 files changed, 45 insertions, 76 deletions
diff --git a/x11/bricons/Makefile b/x11/bricons/Makefile
index 6799c3cbbe64..0bce7f4e6984 100644
--- a/x11/bricons/Makefile
+++ b/x11/bricons/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bricons
-# Date created: 31 Jul 1996
-# Whom: shanee@augusta.de
-#
+# Created by: shanee@augusta.de
# $FreeBSD$
-#
PORTNAME= bricons
PORTVERSION= 3.0
@@ -18,9 +14,9 @@ COMMENT= Quick start up utility for applications on an X display
WRKSRC= ${WRKDIR}/${PORTNAME}
+USES= imake
USE_PERL5_BUILD=yes
USE_XORG= xaw
-USE_IMAKE= yes
MAKE_JOBS_SAFE= yes
MAN1= bricons.1
diff --git a/x11/dynamag/Makefile b/x11/dynamag/Makefile
index d9057d8a51ae..1ecf0896ba7d 100644
--- a/x11/dynamag/Makefile
+++ b/x11/dynamag/Makefile
@@ -15,7 +15,7 @@ COMMENT= Magnifying utility which updates continuously
ALL_TARGET= dynamag
NO_INSTALL_MANPAGES= yes
PLIST_FILES= bin/dynamag
-USE_IMAKE= yes
+USES= imake
USE_XORG= x11 xaw xext xmu xt xpm sm ice
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/x11/kdebase3/Makefile b/x11/kdebase3/Makefile
index 14bfff77dfb5..94d727165100 100644
--- a/x11/kdebase3/Makefile
+++ b/x11/kdebase3/Makefile
@@ -14,8 +14,7 @@ COMMENT= Basic applications for the KDE system
RUN_DEPENDS= ${KDE_PREFIX}/env/xdg-env.sh:${PORTSDIR}/misc/kde-xdg-env \
kompmgr:${PORTSDIR}/x11-wm/kompmgr \
${LOCALBASE}/etc/pam.d/kde:${PORTSDIR}/security/pam_kde
-BUILD_DEPENDS= imake:${PORTSDIR}/devel/imake \
- bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf \
+BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf \
mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
LIB_DEPENDS= sasl2:${PORTSDIR}/security/cyrus-sasl2 \
smbclient:${PORTSDIR}/net/samba-libsmbclient
@@ -27,6 +26,7 @@ EXPIRATION_DATE= 2013-07-01
USE_KDELIBS_VER=3
+USES= imake:env
USE_OPENLDAP= yes
USE_OPENSSL= yes
diff --git a/x11/props/Makefile b/x11/props/Makefile
index c91bf7526af2..8d3f428360ec 100644
--- a/x11/props/Makefile
+++ b/x11/props/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: props
-# Date created: 3 January 1998
-# Whom: jraynard
-#
+# Created by: jraynard
# $FreeBSD$
-#
PORTNAME= props
PORTVERSION= 1.0
@@ -21,7 +17,7 @@ CONFLICTS= xview-clients-3.2.1.4.19*
LIB_DEPENDS= xview.3:${PORTSDIR}/x11-toolkits/xview
WRKSRC= ${WRKDIR}/props
-USE_IMAKE= yes
+USES= imake
USE_XORG= x11 xext
MAKE_ARGS= INFOFILES=""
diff --git a/x11/x3270/Makefile b/x11/x3270/Makefile
index 221fdbf4206c..a11fd4264aff 100644
--- a/x11/x3270/Makefile
+++ b/x11/x3270/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: x3270
-# Date created: 31 January 1995
-# Whom: janek
-#
+# Created by: janek
# $FreeBSD$
-#
PORTNAME= x3270
PORTVERSION= 3.3.10
@@ -18,8 +14,7 @@ BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf \
mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
-USE_IMAKE= yes
-USES= iconv
+USES= iconv imake:env
USE_XORG= ice sm x11 xaw xext xmu xt
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-fontdir=${PREFIX}/lib/X11/fonts/local --disable-dbcs
diff --git a/x11/xascii/Makefile b/x11/xascii/Makefile
index c274aae531dc..adf21721e12d 100644
--- a/x11/xascii/Makefile
+++ b/x11/xascii/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xascii
-# Date created: 10 April 2012
-# Whom: Cy Schubert <cy@FreeBSD.org>
-#
+# Created by: Cy Schubert <cy@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= xascii
PORTVERSION= 1.0
@@ -17,7 +13,7 @@ MAINTAINER= cy@FreeBSD.org
COMMENT= Display an ASCII table in decimal, octal, and hexadecimal.
MAKE_ARGS+= PREFIX=${PREFIX}
-USE_IMAKE= YES
+USES= imake
USE_XORG= x11 xt xaw
MAN1= xascii.1
PLIST_FILES= bin/xascii
diff --git a/x11/xautolock/Makefile b/x11/xautolock/Makefile
index efdab93e50a9..32b2adfd2ff5 100644
--- a/x11/xautolock/Makefile
+++ b/x11/xautolock/Makefile
@@ -16,13 +16,9 @@ OPTIONS_DEFINE= XLOCK
OPTIONS_DEFAULT= XLOCK
XLOCK_DESC= Force dependency on x11/xlockmore
-.include <bsd.port.options.mk>
+XLOCK_RUN_DEPENDS= xlock:${PORTSDIR}/x11/xlockmore
-.if ${PORT_OPTIONS:MXLOCK}
-RUN_DEPENDS+= xlock:${PORTSDIR}/x11/xlockmore
-.endif
-
-USE_IMAKE= yes
+USES= imake
USE_XORG= x11 xext xscrnsaver
MAN1= xautolock.1
PLIST_FILES= bin/xautolock
diff --git a/x11/xcb/Makefile b/x11/xcb/Makefile
index aa1fc49fccdb..e4746017f79e 100644
--- a/x11/xcb/Makefile
+++ b/x11/xcb/Makefile
@@ -14,7 +14,7 @@ COMMENT= Tool for managing x11 cut-buffers
LICENSE= MIT
-USE_IMAKE= yes
+USES= imake
USE_XORG= ice sm x11 xaw xext xmu xt
MAN1= xcb.1
diff --git a/x11/xcoloredit/Makefile b/x11/xcoloredit/Makefile
index 18f5ad7a48e8..bf5aab8dac8c 100644
--- a/x11/xcoloredit/Makefile
+++ b/x11/xcoloredit/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xcoloredit
-# Date created: 6 Jun 1997
-# Whom: Satoshi TAOKA
-#
+# Created by: Satoshi TAOKA
# $FreeBSD$
-#
PORTNAME= xcoloredit
PORTVERSION= 1.2
@@ -16,8 +12,8 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= Find colour values by graphical colour mixing
+USES= imake
USE_XORG= ice sm x11 xaw xext xmu xpm xt
-USE_IMAKE= yes
MAKE_JOBS_SAFE= yes
MANCOMPRESSED= yes
diff --git a/x11/xgrab/Makefile b/x11/xgrab/Makefile
index ca0a5773da1a..7cc45a890fad 100644
--- a/x11/xgrab/Makefile
+++ b/x11/xgrab/Makefile
@@ -15,9 +15,8 @@ COMMENT= X11 image grabber
BUILD_DEPENDS= xrdb:${PORTSDIR}/x11/xrdb
-USES= display:build
+USES= display:build imake
USE_XORG= x11
-USE_IMAKE= yes
MAKE_FLAGS= BINDIR=${PREFIX}/bin MANDIR=${PREFIX}/man/man1 \
XAPPLOADDIR=${PREFIX}/lib/X11/app-defaults -f
diff --git a/x11/xlogout/Makefile b/x11/xlogout/Makefile
index ea37841677c8..a9ea9517dec1 100644
--- a/x11/xlogout/Makefile
+++ b/x11/xlogout/Makefile
@@ -10,8 +10,8 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= naddy@FreeBSD.org
COMMENT= Simple logout button
+USES= imake
WRKSRC= ${WRKDIR}/xlogout
-USE_IMAKE= yes
USE_XORG= ice sm x11 xaw xext xmu xpm xt
MAKE_JOBS_SAFE= yes
MAN1= xlogout.1
diff --git a/x11/xmotd/Makefile b/x11/xmotd/Makefile
index 82f98843c228..87dbef6bf9b9 100644
--- a/x11/xmotd/Makefile
+++ b/x11/xmotd/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xmotd
-# Date created: 29 January 2001
-# Whom: Matthew West <mwest@uct.ac.za>
-#
+# Created by: Matthew West <mwest@uct.ac.za>
# $FreeBSD$
-#
PORTNAME= xmotd
DISTVERSION= 1.17.3b
@@ -12,9 +8,9 @@ CATEGORIES= x11
MASTER_SITES= http://www.ee.ryerson.ca/~elf/pub/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A message-of-the-day browser for X11 and dumb-terminals
+COMMENT= message-of-the-day browser for X11 and dumb-terminals
-USE_IMAKE= yes
+USES= imake
USE_XORG= ice sm x11 xaw xext xmu xt
NO_INSTALL_MANPAGES= yes
XFREE86_HTML_MAN= no
@@ -25,6 +21,7 @@ PLIST_FILES= bin/xmotd
OPTIONS_DEFINE= HTML MOTIF XPM
HTML_DESC= Use HTML widget instead of ASCII text
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MHTML}
diff --git a/x11/xorg-cf-files/Makefile b/x11/xorg-cf-files/Makefile
index 3e3bd6a51645..7fa17e150a38 100644
--- a/x11/xorg-cf-files/Makefile
+++ b/x11/xorg-cf-files/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xorg-cf-files
PORTVERSION= 1.0.4
+PORTREVISION= 1
CATEGORIES= x11
MAINTAINER= x11@FreeBSD.org
@@ -12,14 +13,8 @@ LICENSE= MIT
XORG_CAT= util
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} 's|\(define ExtraXaw[^ ]*\) [$$].*|\1 /**/|' \
${WRKSRC}/X11.tmpl
-.if defined(CC) && ${CC:T:M*clang*} == "clang"
- ${REINPLACE_CMD} -e 's|/usr/bin/cpp|${LOCALBASE}/bin/ucpp|' \
- -e 's|-traditional|-s|' ${WRKSRC}/FreeBSD.cf
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11/xorg-cf-files/files/patch-FreeBSD.cf b/x11/xorg-cf-files/files/patch-FreeBSD.cf
index 524dee86e0ae..827c369e239a 100644
--- a/x11/xorg-cf-files/files/patch-FreeBSD.cf
+++ b/x11/xorg-cf-files/files/patch-FreeBSD.cf
@@ -1,5 +1,5 @@
---- FreeBSD.cf.orig Sat Aug 14 17:03:36 2004
-+++ FreeBSD.cf Fri Sep 10 19:52:31 2004
+--- ./FreeBSD.cf.orig 2009-10-16 23:45:42.000000000 +0200
++++ ./FreeBSD.cf 2013-06-27 17:14:30.661790922 +0200
@@ -78,6 +78,7 @@
#define HasIssetugid YES
#define HasPoll YES
@@ -25,7 +25,17 @@
#endif
/* This fixes linking C programs against libGLU on FreeBSD 3.x */
-@@ -338,7 +333,7 @@
+@@ -178,7 +173,9 @@
+ #ifndef CplusplusCmd
+ #define CplusplusCmd c++
+ #endif
++#ifndef CppCmd
+ #define CppCmd /usr/bin/cpp
++#endif
+ #define PreProcessCmd CppCmd
+ #define StandardCppOptions -traditional
+ #define StandardCppDefines /**/
+@@ -338,7 +335,7 @@
#ifndef LibraryRpathLoadFlags
# if UseRpath
# if UseElfFormat
@@ -34,7 +44,7 @@
# else
# define LibraryRpathLoadFlags -R $(USRLIBDIRPATH)
# endif
-@@ -466,14 +461,14 @@
+@@ -470,14 +467,14 @@
/* The GCC strength-reduce bug is fixed for FreeBSD 2.1.5 and later */
#ifndef DefaultGcc2i386Opt
#if OSMajorVersion > 2 || (OSMajorVersion == 2 && OSMinorVersion > 1) || (OSMajorVersion == 2 && OSMinorVersion == 1 && OSTeenyVersion >= 5)
@@ -51,7 +61,7 @@
#endif
#ifndef PreIncDir
-@@ -493,6 +493,10 @@
+@@ -498,6 +495,10 @@
#define SystemManDirectory /usr/share/man
#endif
diff --git a/x11/xprompt/Makefile b/x11/xprompt/Makefile
index ded1c4239601..6351ac16ca71 100644
--- a/x11/xprompt/Makefile
+++ b/x11/xprompt/Makefile
@@ -11,7 +11,7 @@ MASTER_SITE_SUBDIR= mph
MAINTAINER= ports@FreeBSD.org
COMMENT= Displays a dialog box and prompts user for text
-USE_IMAKE= yes
+USES= imake
USE_XORG= ice sm x11 xaw xext xmu xt
MAN1= xprompt.1
diff --git a/x11/xstroke/Makefile b/x11/xstroke/Makefile
index 140cc46a35f4..28bb36b81015 100644
--- a/x11/xstroke/Makefile
+++ b/x11/xstroke/Makefile
@@ -13,9 +13,8 @@ COMMENT= Fullscreen gesture recognition
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-USES= bison
+USES= bison imake
USE_XORG= xft x11 xext xi xtst
-USE_IMAKE= yes
MAN1= xstroke.1
PLIST_FILES= bin/xstroke %%ETCDIR%%/alphabet
diff --git a/x11/xvkbd/Makefile b/x11/xvkbd/Makefile
index 2b649cbb1e9f..6a12a8c75861 100644
--- a/x11/xvkbd/Makefile
+++ b/x11/xvkbd/Makefile
@@ -16,8 +16,8 @@ OPTIONS_DEFAULT= XTEST
XAW3D_DESC= Xaw3d widget library support
XTEST_DESC= XTEST extensions support
+USES= imake
USE_XORG= ice sm x11 xaw xext xmu xpm xt
-USE_IMAKE= yes
MAN1= xvkbd.1
diff --git a/x11/xwit/Makefile b/x11/xwit/Makefile
index 7feecc94d08a..b4ce68db9cde 100644
--- a/x11/xwit/Makefile
+++ b/x11/xwit/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xwit
-# Date created: 15 June 1998
-# Whom: Thomas Gellekum <tg@FreeBSD.org>
-#
+# Created by: Thomas Gellekum <tg@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= xwit
PORTVERSION= 3.4
@@ -16,7 +12,7 @@ DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}:source1 \
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= X interface tool
-USE_IMAKE= yes
+USES= imake
USE_XORG= x11 xext
MAKE_JOBS_SAFE= yes
diff --git a/x11/xxkb/Makefile b/x11/xxkb/Makefile
index 971ef09f0f5d..87aab5d552e5 100644
--- a/x11/xxkb/Makefile
+++ b/x11/xxkb/Makefile
@@ -12,10 +12,8 @@ COMMENT= XKB keyboard layout indicator and switcher
LICENSE= ART10
-BUILD_DEPENDS= iconv:${PORTSDIR}/converters/libiconv
-
+USES= iconv imake
USE_XORG= xpm
-USE_IMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
MAN1= ${PORTNAME}.1