aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>2000-06-18 09:26:54 +0000
committerSatoshi Asami <asami@FreeBSD.org>2000-06-18 09:26:54 +0000
commitdbb2b8a5bb93332148f0e8741945da7857360702 (patch)
tree22fc2da6c94ee3f23ec86f9982705d256fac9424 /x11
parenteed2477df8ed61d7c2b7845bca092c5c277ffb72 (diff)
downloadports-dbb2b8a5bb93332148f0e8741945da7857360702.tar.gz
ports-dbb2b8a5bb93332148f0e8741945da7857360702.zip
Back out LDCONFIG_DIRS change -- they don't work with a.out libs.
Reported by: bento
Notes
Notes: svn path=/head/; revision=29671
Diffstat (limited to 'x11')
-rw-r--r--x11/XFree86-aoutlibs/Makefile2
-rw-r--r--x11/XFree86-aoutlibs/pkg-plist2
2 files changed, 3 insertions, 1 deletions
diff --git a/x11/XFree86-aoutlibs/Makefile b/x11/XFree86-aoutlibs/Makefile
index e6437405a39e..98f69e91d914 100644
--- a/x11/XFree86-aoutlibs/Makefile
+++ b/x11/XFree86-aoutlibs/Makefile
@@ -18,7 +18,6 @@ ONLY_FOR_ARCHS= i386
WRKSRC= ${WRKDIR}/lib
NO_BUILD= yes
-INSTALLS_SHLIB= yes
PORTOBJFORMAT= aout
USE_X_PREFIX= yes
@@ -34,5 +33,6 @@ do-install:
${SETENV} OBJFORMAT=${PORTOBJFORMAT} \
${INSTALL_PROGRAM} $$l ${PREFIX}/lib/aout; \
done
+ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib/aout
.include <bsd.port.mk>
diff --git a/x11/XFree86-aoutlibs/pkg-plist b/x11/XFree86-aoutlibs/pkg-plist
index 7a0b3db44d11..f6793c5a33d3 100644
--- a/x11/XFree86-aoutlibs/pkg-plist
+++ b/x11/XFree86-aoutlibs/pkg-plist
@@ -11,3 +11,5 @@ lib/aout/libXi.so.6.0
lib/aout/libXtst.so.6.1
lib/aout/libPEX5.so.6.0
lib/aout/libXp.so.6.2
+@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
+@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R