aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-08-06 06:28:17 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-08-06 06:28:17 +0000
commit3029fafde3306ae30ed23176fb53307f0e6f260e (patch)
treec0c8afcf591a016bd1283c869c33454da514c226 /x11
parente159b27cd5a2560fd0e7eb0c098c31b95673a19f (diff)
downloadports-3029fafde3306ae30ed23176fb53307f0e6f260e.tar.gz
ports-3029fafde3306ae30ed23176fb53307f0e6f260e.zip
Fix a crash that can occur in gnome-panel when GNOME and KDE are on the
same machine. See http://bugzilla.gnome.org/show_bug.cgi?id=312502 for more details. PR: 84594 Submitted by: Marcus Grando <marcus@corp.grupos.com.br> Obtained from: GNOME CVS Approved by: portmgr (implicit)
Notes
Notes: svn path=/head/; revision=140795
Diffstat (limited to 'x11')
-rw-r--r--x11/gnome-menus/Makefile1
-rw-r--r--x11/gnome-menus/files/patch-bugzilla-31250212
2 files changed, 13 insertions, 0 deletions
diff --git a/x11/gnome-menus/Makefile b/x11/gnome-menus/Makefile
index 4ba3bb1e7934..c0415bed871e 100644
--- a/x11/gnome-menus/Makefile
+++ b/x11/gnome-menus/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnome-menus
PORTVERSION= 2.10.2
+PORTREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.10
diff --git a/x11/gnome-menus/files/patch-bugzilla-312502 b/x11/gnome-menus/files/patch-bugzilla-312502
new file mode 100644
index 000000000000..0fa77890b7a9
--- /dev/null
+++ b/x11/gnome-menus/files/patch-bugzilla-312502
@@ -0,0 +1,12 @@
+diff -u -p -r1.7.4.1 desktop-entries.c
+--- libmenu/desktop-entries.c 5 Apr 2005 21:04:31 -0000 1.7.4.1
++++ libmenu/desktop-entries.c 5 Aug 2005 07:57:37 -0000
+@@ -554,7 +554,7 @@ desktop_entry_add_legacy_category (Deskt
+ for (; entry->categories[i]; i++);
+ }
+
+- categories = g_new0 (GQuark, i + 1);
++ categories = g_new0 (GQuark, i + 2);
+
+ i = 0;
+ if (entry->categories != NULL)