aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2005-06-17 22:59:29 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2005-06-17 22:59:29 +0000
commit23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d (patch)
treefa03305e656151ebe33c7e94eacc947b13d1c273 /x11
parentb347391f9ad81dd1ebc74b80d713888404b304bd (diff)
downloadports-23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d.tar.gz
ports-23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d.zip
Mega-patch to cleanup the ports infrastructure regarding our linux bits:
- USE_LINUX now implies NO_FILTER_SHLIBS=yes. It also doesn't use FreeBSD tools to strip binaries anymore, so it's not neccesary anymore to override STRIP and STRIP_CMD. - USE_LINUX_PREFIX implies NO_MTREE now. - In the USE_LINUX case, USE_XLIB now depends upon the linux X11 libraries instead upon the native FreeBSD libraries. - The variable LINUX_BASE_PORT contains a string which is suitable as an item in *_DEPENDS, so if a port BATCH_DEPENDS or FETCH_DEPENDS upon the default (or overriden) linux base, ${LINUX_BASE_PORT} should be used instead of a hardcoded reference. - Change all ports to comply to the "new world order". - The Ports Collection now allows to override the default linux_base port. Specify e.g. OVERRIDE_LINUX_BASE_PORT=rh-9 in /etc/make.conf to use ${PORTSDIR}/emulators/linux_base-rh-9 (the logic is to use ${PORTSDIR}/emulators/linux_base-${OVERRIDE_LINUX_BASE_PORT}). - If USE_LINUX or OVERRIDE_LINUX_BASE doesn't point to an existing linux_base port and if USE_LINUX isn't set to "yes" (case insensitive), the port will be marked as IGNORE. [1] - Readd USE_LINUX knobs into several ports and make several uses of a conditional dependency ("USE_LINUX?=") into an unconditional one ("USE_LINUX=") which where removed/changed by Trevor to allow the use of alternative linux_base ports. While this is a nice goal, the implementation resulted in missing dependencies. The OVERRIDE_LINUX_BASE_PORT knob in this commit is supposed to fix the problem while keeping the feature. Basicaly this includes a backout of Trevor's commit, to prevent confusion I mention it here explicitely. - Use the correct prefix (X11- instead of LOCAL- or LINUX-) for some ports. Chase dependencies for this. - Changes to make linux_devtools installable on amd64, remove some stray device nodes (they don't work on recent OS versions and aren't really needed). - Make linux_base-8 PREFIX clean and remove some stray device nodes. Additionally tell a little bit more about how to setup NIS/YP [2]. - Update the PGSQL dependency in the linux-opengroupware port to a recent version (the old one isn't available anymore), I don't know if this works (at least it isn't more broken than before). - Use PREFIX/usr/share/doc instead of PREFIX/usr/doc in the divx4linux ports, the former path exists already and gets populated by other packages too (PREFIX=LINUXPREFIX!). - Fix some obvious (non-linuxolator) bugs in some linux ports while being there. - Bump PORTREVISION where neccesary. Requested by: portmgr (linimon) [1] Submittted by: Gerrit Kuehn <gerrit_huehn@gruft.fido.de [2] Approved by: portmgr (kris, linimon), maintainers (or maintainer timeout) Tested on: ports cluster (kris) Reviewed by: silence on emulation@ Superseedes PR: 69997 Maintainer approval from: chris@chrisburkert.de cracauer@cons.org des girgen jamie@bishopston.net mezz mi nivit@users.sf.net pat simond@irrelevant.org riggs@rrr.de Udo.Schweigert@Siemens.com
Notes
Notes: svn path=/head/; revision=137660
Diffstat (limited to 'x11')
-rw-r--r--x11/XFree86/files/patch-e81
-rw-r--r--x11/linux-XFree86-libs/Makefile9
-rw-r--r--x11/linux-gnomelibs/Makefile8
-rw-r--r--x11/linux-gnomelibs/pkg-plist.i38612
-rw-r--r--x11/nvidia-driver/Makefile4
5 files changed, 22 insertions, 92 deletions
diff --git a/x11/XFree86/files/patch-e b/x11/XFree86/files/patch-e
index cee217ed5cac..e69de29bb2d1 100644
--- a/x11/XFree86/files/patch-e
+++ b/x11/XFree86/files/patch-e
@@ -1,81 +0,0 @@
---- config/cf/FreeBSD.cf.orig Wed Jan 9 15:04:16 2002
-+++ config/cf/FreeBSD.cf Wed Jan 9 16:17:59 2002
-@@ -78,7 +78,7 @@
- #endif
-
- #define CcCmd cc
--#define CppCmd /usr/libexec/cpp
-+#define CppCmd /usr/bin/cpp
- #define PreProcessCmd CppCmd
- #define StandardCppDefines -traditional
- #if defined(UseInstalled) && (!defined(XF86LinkKit) || !XF86LinkKit)
-@@ -141,12 +141,12 @@
- * reason for FreeBSD to assume that it knows where X libraries are installed
- * and they can remove it from the list of directories they add to ld.so.cache
- * in their /etc/rc file.
-+ *
-+ * For the ELF case, we default to the ExtraLoadFlags in bsdLib.rules
- */
- #if OSMajorVersion > 2 || (OSMajorVersion == 2 && OSMinorVersion >= 2)
- #ifndef ExtraLoadFlags
--#if UseElfFormat
--#define ExtraLoadFlags -Wl,-rpath,$(USRLIBDIRPATH)
--#else
-+#if !UseElfFormat
- #define ExtraLoadFlags -Wl,-R,$(USRLIBDIRPATH)
- #endif
- #endif
-@@ -330,7 +330,13 @@
- # define AsmDefines AsmElfDefines
- #endif
-
-+#ifdef i386Architecture
- #define ServerExtraDefines GccGasOption XFree86ServerDefines
-+#endif
-+#ifdef AlphaArchitecture
-+#define ServerExtraDefines GccGasOption XFree86ServerDefines -D_XSERVER64
-+#define XFree86ConsoleDefines -DSYSCONS_SUPPORT
-+#endif
-
- #define StandardDefines -DCSRG_BASED
-
-@@ -355,14 +361,14 @@
- /* The GCC strength-reduce bug is fixed for FreeBSD 2.1.5 and later */
- #ifndef DefaultGcc2i386Opt
- #if OSMajorVersion > 2 || (OSMajorVersion == 2 && OSMinorVersion > 1) || (OSMajorVersion == 2 && OSMinorVersion == 1 && OSTeenyVersion >= 5)
--#define DefaultGcc2i386Opt -O2
-+#define DefaultGcc2i386Opt
- #endif
- #endif
-
- #ifdef i386Architecture
- # define OptimizedCDebugFlags DefaultGcc2i386Opt
- #else
--# define OptimizedCDebugFlags -O2
-+# define OptimizedCDebugFlags
- #endif
-
- #ifndef PreIncDir
-@@ -471,14 +477,18 @@
- #define DlLibrary /**/
- #endif
-
-+#ifdef AlphaArchitecture
-+#define IoLibrary -lio
-+#else
-+#define IoLibrary /**/
-+#endif
-+
- #if BuildDynamicLoading
--#define ServerExtraSysLibs DlLibrary
-+#define ServerExtraSysLibs DlLibrary IoLibrary
- #else
--#define ServerExtraSysLibs /**/
-+#define ServerExtraSysLibs IoLibrary
- #endif
-
- #include <bsdLib.rules>
-
--#ifdef i386Architecture
- #include <xfree86.cf>
--#endif
diff --git a/x11/linux-XFree86-libs/Makefile b/x11/linux-XFree86-libs/Makefile
index ec25e4589a29..8163679953d5 100644
--- a/x11/linux-XFree86-libs/Makefile
+++ b/x11/linux-XFree86-libs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= XFree86-libs
PORTVERSION= 4.3.99.902
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 linux
MASTER_SITES= ${MASTER_SITE_SUSE} \
ftp://ftp.in2p3.fr/pub/linux/suse/update/9.1/rpm/i586/ \
@@ -27,13 +27,16 @@ RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux
CONFLICTS= linux_base-7* linux_base-deb*
USE_LINUX_PREFIX=yes
+USE_LINUX= yes
MD5_FILE= ${MASTERDIR}/distinfo.i386
NO_BUILD= yes
-NO_FILTER_SHLIBS= yes
ONLY_FOR_ARCHS= amd64 i386
PKGINSTALL= ${WRKDIR}/pkg-install
PLIST= ${WRKDIR}/plist
-PLIST_DIRS= usr/X11R6/lib/X11
+PLIST_DIRS= usr/X11R6/lib/X11 \
+ usr/X11R6/lib \
+ usr/X11R6/bin \
+ usr/X11R6
pre-install:
@${RM} -f ${PLIST}
diff --git a/x11/linux-gnomelibs/Makefile b/x11/linux-gnomelibs/Makefile
index 2abe16032092..a56da1166bf3 100644
--- a/x11/linux-gnomelibs/Makefile
+++ b/x11/linux-gnomelibs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnomelibs
PORTVERSION= 1.2.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 linux
MAINTAINER= freebsd-emulation@FreeBSD.org
@@ -17,8 +17,4 @@ RPM_SET= gnome-libs-${PORTVERSION}-11.${MACHINE_ARCH}.rpm
.include "../../x11-toolkits/linux-gtk/Makefile"
-.if (${MACHINE_ARCH} == "i386")
-MASTER_SITES+= ftp://ftp.redhat.com/pub/redhat/linux/7.1/en/os/i386/RedHat/RPMS/
-.elif (${MACHINE_ARCH} == "alpha")
-MASTER_SITES+= ftp://ftp.redhat.com/pub/redhat/linux/7.1/en/os/alpha/RedHat/RPMS/
-.endif
+MASTER_SITES+= ftp://ftp.redhat.com/pub/redhat/linux/7.1/en/os/${MACHINE_ARCH}/RedHat/RPMS/
diff --git a/x11/linux-gnomelibs/pkg-plist.i386 b/x11/linux-gnomelibs/pkg-plist.i386
index 9f3fbc95a4de..371c3647bf78 100644
--- a/x11/linux-gnomelibs/pkg-plist.i386
+++ b/x11/linux-gnomelibs/pkg-plist.i386
@@ -116,3 +116,15 @@ usr/lib/libzvt.so.2
@dirrm etc/sound/events
@dirrm etc/sound
@dirrm etc/gnome
+@unexec rmdir %D/usr/share/locale/eu/LC_MESSAGES 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/eu 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/ga/LC_MESSAGES 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/ga 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/lt/LC_MESSAGES 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/lt 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/nn/LC_MESSAGES 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/nn 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/sp/LC_MESSAGES 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/sp 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/zh_TW.Big5/LC_MESSAGES 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/zh_TW.Big5 2>&1 >/dev/null || true
diff --git a/x11/nvidia-driver/Makefile b/x11/nvidia-driver/Makefile
index ba2f48c63fcc..d7d6c150aaa4 100644
--- a/x11/nvidia-driver/Makefile
+++ b/x11/nvidia-driver/Makefile
@@ -56,8 +56,8 @@ PLIST_SUB+= XSERVVERSION=${XSERVVERSION} XLIBVERSION=${XLIBVERSION} \
LINUXBASE=${LINUXBASE} NVVERSION=${NVVERSION}
.if !defined(WITHOUT_LINUX)
-USE_LINUX?= yes
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
+USE_LINUX= yes
+USE_XLIB= yes
PLIST_SUB+= LINUX=""
.else
PLIST_SUB+= LINUX="@comment "