aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2003-12-22 00:54:18 +0000
committerEric Anholt <anholt@FreeBSD.org>2003-12-22 00:54:18 +0000
commit986e4c9ac5afff1fd077ca2b30a444e51e2206c6 (patch)
tree8f6e9310784f2a5c979f1b846f1f32ad67b4adde /x11
parent497a54c6ce2b586282e3942b352c6b31b00a0ef5 (diff)
downloadports-986e4c9ac5afff1fd077ca2b30a444e51e2206c6.tar.gz
ports-986e4c9ac5afff1fd077ca2b30a444e51e2206c6.zip
New port: Prerelease version of libXi from freedesktop.org:
X Input extension library Testing is encouraged, but please do not use these ports as dependencies until they are updated to release tarballs and the XFree86 ports have been updated to depend on them.
Notes
Notes: svn path=/head/; revision=96388
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/libXi/Makefile32
-rw-r--r--x11/libXi/distinfo1
-rw-r--r--x11/libXi/files/patch-Makefile.in11
-rw-r--r--x11/libXi/pkg-descr6
-rw-r--r--x11/libXi/pkg-plist5
6 files changed, 56 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 5c119b0f2759..d0b9f5ecd393 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -79,6 +79,7 @@
SUBDIR += libXau
SUBDIR += libXdmcp
SUBDIR += libXfont
+ SUBDIR += libXi
SUBDIR += libXres
SUBDIR += libXtrans
SUBDIR += libXv
diff --git a/x11/libXi/Makefile b/x11/libXi/Makefile
new file mode 100644
index 000000000000..e472f80a9777
--- /dev/null
+++ b/x11/libXi/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: libXi
+# Date Created: 22 Nov, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libXi
+PORTVERSION= 6.0.1.p1
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X Input extension library
+
+LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/x11.pc:${PORTSDIR}/x11/libX11
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
+ ${X11BASE}/libdata/pkgconfig/xproto.pc:${PORTSDIR}/x11/xproto \
+ ${LIB_PC_DEPENDS}
+RUN_DEPENDS= ${LIB_PC_DEPENDS}
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CFLAGS+= -DMALLOC_0_RETURNS_NULL
+WRKSRC= ${WRKDIR}/${PORTNAME}-6.0.1
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/x11/libXi/distinfo b/x11/libXi/distinfo
new file mode 100644
index 000000000000..d7275b90aefc
--- /dev/null
+++ b/x11/libXi/distinfo
@@ -0,0 +1 @@
+MD5 (libXi-6.0.1.p1.tar.bz2) = aa12952eb784777ec43ea1e0e597cfbc
diff --git a/x11/libXi/files/patch-Makefile.in b/x11/libXi/files/patch-Makefile.in
new file mode 100644
index 000000000000..288a87145ab3
--- /dev/null
+++ b/x11/libXi/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sat Nov 22 16:27:47 2003
++++ Makefile.in Sat Nov 22 16:45:46 2003
+@@ -184,7 +184,7 @@
+ XUngrDvK.c
+
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = xi.pc
+
+ EXTRA_DIST = xi.pc.in
diff --git a/x11/libXi/pkg-descr b/x11/libXi/pkg-descr
new file mode 100644
index 000000000000..8fefae4c5a48
--- /dev/null
+++ b/x11/libXi/pkg-descr
@@ -0,0 +1,6 @@
+This package contains the X11 Damage extension library.
+
+WWW: http://www.freedesktop.org/Software/xlibs
+
+- Eric Anholt
+anholt@FreeBSD.org
diff --git a/x11/libXi/pkg-plist b/x11/libXi/pkg-plist
new file mode 100644
index 000000000000..e1cbeac40e06
--- /dev/null
+++ b/x11/libXi/pkg-plist
@@ -0,0 +1,5 @@
+lib/libXi.a
+lib/libXi.la
+lib/libXi.so
+lib/libXi.so.6
+libdata/pkgconfig/xi.pc