aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2009-05-30 21:37:01 +0000
committerThierry Thomas <thierry@FreeBSD.org>2009-05-30 21:37:01 +0000
commita636c69c2263cc8c91a342341832fbfcaab9d807 (patch)
treeba5674ffe03e9eac74b360b11840581e052add12 /x11
parentb6f8f0c14757236907958eb399ed1487e0809068 (diff)
downloadports-a636c69c2263cc8c91a342341832fbfcaab9d807.tar.gz
ports-a636c69c2263cc8c91a342341832fbfcaab9d807.zip
Add a WITH_XTERM_COLOR knob to x11/rxvt-unicode port, which enable xterm
colors (256 colors) instead of rxvt's 88 colors. This can be useful for some vim colorschemes, elinks, or any apps able to use 256 colors. :) It's disabled by default, so it doesn't affect already installed rxvt-unicode packages, so I think it doesn't need a version bump. PR: ports/134910 Submitted by: Pierre Guinoiseau <geekounet (at) poildetroll.net>
Notes
Notes: svn path=/head/; revision=234875
Diffstat (limited to 'x11')
-rw-r--r--x11/rxvt-unicode/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/x11/rxvt-unicode/Makefile b/x11/rxvt-unicode/Makefile
index 2b49c920e7b4..88d03519bde2 100644
--- a/x11/rxvt-unicode/Makefile
+++ b/x11/rxvt-unicode/Makefile
@@ -137,6 +137,11 @@ CONFIGURE_ARGS+= --enable-afterimage
CONFIGURE_ENV+= LIBS="-lutil"
+# enable support for xterm 256 colors
+.if defined(WITH_XTERM_COLOR)
+CONFIGURE_ARGS+= --enable-xterm-colors=256
+.endif
+
.include <bsd.port.pre.mk>
# compile in support for additional codeset groups
@@ -179,6 +184,7 @@ pre-everything::
@${ECHO_MSG} "WITHOUT_IMLOCALE_FIX disable imlocale encoding conversion fix"
@${ECHO_MSG} "WITHOUT_TERMINFO don't register urxvt in the terminfo database"
@${ECHO_MSG} "WITHOUT_AFTERIMAGE disable integration with libAfterImage for background images"
+ @${ECHO_MSG} "WITH_XTERM_COLOR enable support for xterm 256 colors"
@${ECHO_MSG}
.ifndef(WITH_ENCODING)
@${ECHO_MSG} "==> You can compile in support for additional codeset groups by setting the WITH_ENCODING variable"
@@ -192,11 +198,16 @@ pre-everything::
@${ECHO_MSG}
.endif
-.if !defined(WITHOUT_IMLOCALE_FIX)
+.if !defined(WITHOUT_IMLOCALE_FIX) || defined(WITH_XTERM_COLOR)
post-patch:
+.if !defined(WITHOUT_IMLOCALE_FIX)
@${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-imlocale
@cd ${WRKSRC}/src && ./gentables
.endif
+.if defined(WITH_XTERM_COLOR)
+ @${PATCH} ${PATCH_ARGS} -p1 < ${WRKSRC}/doc/urxvt-8.2-256color.patch
+.endif
+.endif
pre-configure:
@${RM} ${WRKSRC}/src/perl/kuake.orig