aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2012-08-09 19:13:56 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2012-08-09 19:13:56 +0000
commit469c6b398e8e76b66b722cdf8d902228402be2ab (patch)
tree4ca98e46bc8a085791e071e66056d55fc2dcc34d /x11
parent47b38cdde1a873e6f55c28d53d68ada568c69865 (diff)
downloadports-469c6b398e8e76b66b722cdf8d902228402be2ab.tar.gz
ports-469c6b398e8e76b66b722cdf8d902228402be2ab.zip
- Use USE_PKGCONFIG macro
- Add patch when NLS is unset - Remove USE_AUTOTOOLS (libtool) macro Submitted by: myself Approved by: miwi, rene (mentors)
Notes
Notes: svn path=/head/; revision=302350
Diffstat (limited to 'x11')
-rw-r--r--x11/libxfce4menu/Makefile12
-rw-r--r--x11/libxfce4menu/pkg-plist2
2 files changed, 9 insertions, 5 deletions
diff --git a/x11/libxfce4menu/Makefile b/x11/libxfce4menu/Makefile
index 8729cac23d12..adb44c4b6e6c 100644
--- a/x11/libxfce4menu/Makefile
+++ b/x11/libxfce4menu/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libxfce4menu
PORTVERSION= 4.10.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
DISTNAME= libxfce4ui-${PORTVERSION}
@@ -16,14 +16,14 @@ DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
COMMENT= Widgets library for the Xfce desktop environment
-USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= glib20 gnomehack gtk20 intltool intlhack pkgconfig desktopfileutils
+USE_GNOME= glib20 gnomehack gtk20 intltool intlhack desktopfileutils
USE_LDCONFIG= yes
USE_XFCE= configenv libutil xfconf
INSTALLS_ICONS= yes
+USE_PKGCONFIG= build
CONFIGURE_ARGS= --disable-gtk-doc-html \
--with-vendor-info=FreeBSD
@@ -64,4 +64,10 @@ CONFIGURE_ARGS+=--enable-gladeui
CONFIGURE_ARGS+=--disable-gladeui
.endif
+.if empty(PORT_OPTIONS:MNLS)
+post-patch:
+ @${REINPLACE_CMD} -e 's|docs \\|docs|| ; \
+ s|po||' ${WRKSRC}/Makefile.in
+.endif
+
.include <bsd.port.mk>
diff --git a/x11/libxfce4menu/pkg-plist b/x11/libxfce4menu/pkg-plist
index cd3dcf8cd32c..3e935fc6b75a 100644
--- a/x11/libxfce4menu/pkg-plist
+++ b/x11/libxfce4menu/pkg-plist
@@ -13,11 +13,9 @@ include/xfce4/libxfce4ui-1/libxfce4ui/xfce-gtk-extensions.h
include/xfce4/libxfce4ui-1/libxfce4ui/xfce-sm-client.h
include/xfce4/libxfce4ui-1/libxfce4ui/xfce-spawn.h
include/xfce4/libxfce4ui-1/libxfce4ui/xfce-titled-dialog.h
-lib/libxfce4kbd-private-2.a
lib/libxfce4kbd-private-2.la
lib/libxfce4kbd-private-2.so
lib/libxfce4kbd-private-2.so.0
-lib/libxfce4ui-1.a
lib/libxfce4ui-1.la
lib/libxfce4ui-1.so
lib/libxfce4ui-1.so.0