aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-08-03 02:30:07 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-08-03 02:30:07 +0000
commitdb8a630740d7952632fca1d12503a442fc625335 (patch)
tree8ee3a15fcf61eb9a77ce79ffe7cc567f6e56e480 /x11
parent336cf4f81e31ae43ff7b5ec434e2305615de4392 (diff)
downloadports-db8a630740d7952632fca1d12503a442fc625335.tar.gz
ports-db8a630740d7952632fca1d12503a442fc625335.zip
- Teach the Haskell Cabal ports to use the new options framework
- Remove some cruft Obtained from: FreeBSD Haskell
Notes
Notes: svn path=/head/; revision=301879
Diffstat (limited to 'x11')
-rw-r--r--x11/hs-X11-xft/Makefile2
-rw-r--r--x11/hs-X11/Makefile10
-rw-r--r--x11/hs-xmobar/Makefile20
3 files changed, 18 insertions, 14 deletions
diff --git a/x11/hs-X11-xft/Makefile b/x11/hs-X11-xft/Makefile
index c736c4390aaa..c33663b18ef3 100644
--- a/x11/hs-X11-xft/Makefile
+++ b/x11/hs-X11-xft/Makefile
@@ -7,7 +7,7 @@
PORTNAME= X11-xft
PORTVERSION= 0.3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/x11/hs-X11/Makefile b/x11/hs-X11/Makefile
index 45adc59235c3..4543b1659853 100644
--- a/x11/hs-X11/Makefile
+++ b/x11/hs-X11/Makefile
@@ -6,7 +6,7 @@
PORTNAME= X11
PORTVERSION= 1.5.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 haskell
MAINTAINER= haskell@FreeBSD.org
@@ -18,12 +18,14 @@ CABAL_SETUP= Setup.hs
USE_CABAL= syb
USE_XORG= x11 xext sm
-OPTIONS= XINERAMA "Build with Xinerama support" on
+OPTIONS_DEFINE= XINERAMA
+OPTIONS_DEFAULT= XINERAMA
+
+XINERAMA_DESC= Build with Xinerama support
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.include <bsd.port.options.mk>
-.if defined(WITH_XINERAMA)
+.if ${PORT_OPTIONS:MXINERAMA}
USE_XORG+= xinerama
CONFIGURE_ARGS+= --configure-option="--with-xinerama"
.else
diff --git a/x11/hs-xmobar/Makefile b/x11/hs-xmobar/Makefile
index 0ec95c7b56cb..a3cb9ad3dbbf 100644
--- a/x11/hs-xmobar/Makefile
+++ b/x11/hs-xmobar/Makefile
@@ -6,7 +6,7 @@
PORTNAME= xmobar
PORTVERSION= 0.14
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 haskell
MAINTAINER= haskell@FreeBSD.org
@@ -22,33 +22,35 @@ STANDALONE= yes
INSTALL_PORTDATA= ${INSTALL_DATA} ${WRKSRC}/samples/xmobar.config ${DATADIR}
-OPTIONS= XFT "Use Xft to render text (UTF-8 support included)" off \
- UTF8 "UTF-8 support" on \
- MPD "mpd support" off
+OPTIONS_DEFINE= XFT UTF8 MPD
+OPTIONS_DEFAULT= UFT8
+
+XFT_DESC= Use Xft to render text (UTF-8 support included)
+UTF8_DESC= UTF-8 support
+MPD_DESC= mpd support
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.include <bsd.port.options.mk>
# Disable Linux-only options
CONFIGURE_ARGS+= --flags="-with_inotify -with_iwlib"
-.if defined(WITH_XFT)
+.if ${PORT_OPTIONS:MXFT}
CONFIGURE_ARGS+= --flags="with_xft"
USE_CABAL+= utf8-string X11-xft>=0.2
.else
CONFIGURE_ARGS+= --flags="-with_xft"
.endif
-.if defined(WITH_UTF8)
+.if ${PORT_OPTIONS:MUTF8}
CONFIGURE_ARGS+= --flags="with_utf8"
-.if !defined(WITH_XFT)
+.if empty(PORT_OPTIONS:MXFT)
USE_CABAL+= utf8-string
.endif
.else
CONFIGURE_ARGS+= --flags="-with_utf8"
.endif
-.if defined(WITH_MPD)
+.if ${PORT_OPTIONS:MMPD}
CONFIGURE_ARGS+= --flags="with_mpd"
USE_CABAL+= libmpd
.else