aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/hanazono-fonts-ttf/Makefile46
-rw-r--r--x11-fonts/hanazono-fonts-ttf/distinfo2
-rw-r--r--x11-fonts/hanazono-fonts-ttf/files/pkg-message.in8
-rw-r--r--x11-fonts/hanazono-fonts-ttf/pkg-descr7
-rw-r--r--x11-fonts/hanazono-fonts-ttf/pkg-plist5
6 files changed, 69 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index b8a99ab0a3d0..90f6a086e762 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -84,6 +84,7 @@
SUBDIR += gnome-font-sampler
SUBDIR += gnu-unifont
SUBDIR += gnu-unifont-ttf
+ SUBDIR += hanazono-fonts-ttf
SUBDIR += inconsolata-ttf
SUBDIR += indic-ttf
SUBDIR += intlfonts
diff --git a/x11-fonts/hanazono-fonts-ttf/Makefile b/x11-fonts/hanazono-fonts-ttf/Makefile
new file mode 100644
index 000000000000..dc5440fbc5e5
--- /dev/null
+++ b/x11-fonts/hanazono-fonts-ttf/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: hanazono-fonts-ttf
+# Date created: 2011/08/09
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hanazono-fonts-ttf
+PORTVERSION= 20110516
+CATEGORIES= x11-fonts
+MASTER_SITES= http://fonts.jp/hanazono/
+DISTNAME= ${PORTNAME:C/-.*//}-${PORTVERSION}
+
+MAINTAINER= lichray@gmail.com
+COMMENT= CJK Mincho-typeface developed by Hanazono University
+
+LICENSE= OFL
+LICENSE_NAME= Open Font License
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+LICENSE_PERMS= auto-accept
+
+BUILD_DEPENDS= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
+ mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
+
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+
+FONTDIR= lib/X11/fonts/Hana
+PKGMESSAGE= ${WRKDIR}/pkg-message
+PLIST_SUB= FONTDIR=${FONTDIR}
+SUB_FILES= pkg-message
+SUB_LIST= FONTDIR=${FONTDIR}
+
+do-build:
+ @cd ${WRKSRC}/ && \
+ ${LOCALBASE}/bin/mkfontscale && \
+ ${LOCALBASE}/bin/mkfontdir
+
+do-install:
+ ${MKDIR} ${PREFIX}/${FONTDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} *.ttf fonts.* ${PREFIX}/${FONTDIR}/
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/hanazono-fonts-ttf/distinfo b/x11-fonts/hanazono-fonts-ttf/distinfo
new file mode 100644
index 000000000000..4c3144c7708d
--- /dev/null
+++ b/x11-fonts/hanazono-fonts-ttf/distinfo
@@ -0,0 +1,2 @@
+SHA256 (hanazono-20110516.zip) = 4a7fe7b7beb11b550ba18c27da191ee114c20a2370eab3f50d8cb9bd43a9e5eb
+SIZE (hanazono-20110516.zip) = 22405252
diff --git a/x11-fonts/hanazono-fonts-ttf/files/pkg-message.in b/x11-fonts/hanazono-fonts-ttf/files/pkg-message.in
new file mode 100644
index 000000000000..798a45125c89
--- /dev/null
+++ b/x11-fonts/hanazono-fonts-ttf/files/pkg-message.in
@@ -0,0 +1,8 @@
+
+You can start using the fonts by following these instructions:
+
+Add the following line to the "Files" section of your X.org configuration
+file:
+
+ FontPath "%%PREFIX%%/%%FONTDIR%%/"
+
diff --git a/x11-fonts/hanazono-fonts-ttf/pkg-descr b/x11-fonts/hanazono-fonts-ttf/pkg-descr
new file mode 100644
index 000000000000..3e16a53f6ab7
--- /dev/null
+++ b/x11-fonts/hanazono-fonts-ttf/pkg-descr
@@ -0,0 +1,7 @@
+Hanazono Mincho typeface is a CJK TrueType font that developed with a
+support of Grant-in-Aid for Publication of Scientific Research Results
+from Japan Society for the Promotion of Science and the International
+Research Institute for Zen Buddhism (IRIZ), Hanazono University. also
+with volunteers who work together on glyphwiki.org.
+
+WWW: http://fonts.jp/hanazono/
diff --git a/x11-fonts/hanazono-fonts-ttf/pkg-plist b/x11-fonts/hanazono-fonts-ttf/pkg-plist
new file mode 100644
index 000000000000..006402e681b0
--- /dev/null
+++ b/x11-fonts/hanazono-fonts-ttf/pkg-plist
@@ -0,0 +1,5 @@
+%%FONTDIR%%/HanaMinA.ttf
+%%FONTDIR%%/HanaMinB.ttf
+%%FONTDIR%%/fonts.dir
+%%FONTDIR%%/fonts.scale
+@dirrm %%FONTDIR%%