aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/libdbusmenu-qt/Makefile30
-rw-r--r--devel/libdbusmenu-qt/distinfo3
-rw-r--r--devel/libdbusmenu-qt/files/patch-CMakeLists.txt10
-rw-r--r--devel/libdbusmenu-qt/pkg-descr5
-rw-r--r--devel/libdbusmenu-qt/pkg-plist9
5 files changed, 57 insertions, 0 deletions
diff --git a/devel/libdbusmenu-qt/Makefile b/devel/libdbusmenu-qt/Makefile
new file mode 100644
index 000000000000..b71401f4625c
--- /dev/null
+++ b/devel/libdbusmenu-qt/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: libdbusmenu-qt
+# Date created: 2010-05-10
+# Whom: Dima Panov <fluffy@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libdbusmenu-qt
+PORTVERSION= 0.6.0
+CATEGORIES= devel
+MASTER_SITES= http://launchpadlibrarian.net/53980131/
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt4 implementation of the DBusMenu protocol
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+USE_QT_VER= 4
+QT_COMPONENTS= dbus gui xml \
+ moc_build qmake_build rcc_build uic_build
+USE_LDCONFIG= yes
+
+CMAKE_OUTSOURCE= yes
+MAKE_JOBS_SAFE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e '/pkgconfig/ s/$${LIB_SUFFIX}/data/' \
+ ${WRKSRC}/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/devel/libdbusmenu-qt/distinfo b/devel/libdbusmenu-qt/distinfo
new file mode 100644
index 000000000000..aaeba2acfa7f
--- /dev/null
+++ b/devel/libdbusmenu-qt/distinfo
@@ -0,0 +1,3 @@
+MD5 (libdbusmenu-qt-0.6.0.tar.bz2) = 327d2b401f06b41f92250278cdb1b4e8
+SHA256 (libdbusmenu-qt-0.6.0.tar.bz2) = 881866db3db08ba1dc62a716d11f108554148d2fe90d4521d4da1f4a49fc7f15
+SIZE (libdbusmenu-qt-0.6.0.tar.bz2) = 30491
diff --git a/devel/libdbusmenu-qt/files/patch-CMakeLists.txt b/devel/libdbusmenu-qt/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..103ddad46921
--- /dev/null
+++ b/devel/libdbusmenu-qt/files/patch-CMakeLists.txt
@@ -0,0 +1,10 @@
+--- ./CMakeLists.txt.orig 2010-08-19 12:55:12.000000000 +0400
++++ ./CMakeLists.txt 2010-09-01 23:35:53.634132670 +0400
+@@ -56,7 +56,3 @@
+ option(BUILD_TESTS "Build tests" ON)
+
+ add_subdirectory(src)
+-if (BUILD_TESTS)
+- add_subdirectory(tests)
+-endif (BUILD_TESTS)
+-add_subdirectory(tools)
diff --git a/devel/libdbusmenu-qt/pkg-descr b/devel/libdbusmenu-qt/pkg-descr
new file mode 100644
index 000000000000..aef13fcb7fd2
--- /dev/null
+++ b/devel/libdbusmenu-qt/pkg-descr
@@ -0,0 +1,5 @@
+A library that provides Qt4 implementation of the DBusMenu protocol.
+The DBusMenu protocol makes it possible for applications to export
+and import their menus over DBus.
+
+WWW: http://people.canonical.com/~agateau/dbusmenu/
diff --git a/devel/libdbusmenu-qt/pkg-plist b/devel/libdbusmenu-qt/pkg-plist
new file mode 100644
index 000000000000..db3a2d80b8cf
--- /dev/null
+++ b/devel/libdbusmenu-qt/pkg-plist
@@ -0,0 +1,9 @@
+include/dbusmenu-qt/dbusmenu_export.h
+include/dbusmenu-qt/dbusmenu_version.h
+include/dbusmenu-qt/dbusmenuexporter.h
+include/dbusmenu-qt/dbusmenuimporter.h
+lib/libdbusmenu-qt.so
+lib/libdbusmenu-qt.so.2
+lib/libdbusmenu-qt.so.2.3.0
+libdata/pkgconfig/dbusmenu-qt.pc
+@dirrm include/dbusmenu-qt