aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/pidgin-bs/Makefile27
-rw-r--r--net-im/pidgin-bs/distinfo3
-rw-r--r--net-im/pidgin-bs/pkg-descr6
4 files changed, 37 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index a4eead8bebb1..0b2a88720545 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -111,6 +111,7 @@
SUBDIR += pecl-stomp
SUBDIR += pidgin
SUBDIR += pidgin-birthday_reminder
+ SUBDIR += pidgin-bs
SUBDIR += pidgin-facebookchat
SUBDIR += pidgin-fetion
SUBDIR += pidgin-guifications
diff --git a/net-im/pidgin-bs/Makefile b/net-im/pidgin-bs/Makefile
new file mode 100644
index 000000000000..379e914d350c
--- /dev/null
+++ b/net-im/pidgin-bs/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: pidgin-bs
+# Date created: 15 Mar 2010
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pidgin-bs
+PORTVERSION= 1.3.0
+CATEGORIES= net-im
+MASTER_SITES= SF/${PORTNAME}/bot-sentry/${PORTVERSION}
+DISTNAME= bot-sentry-${PORTVERSION}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Pidgin plugin to prevent instant message spam
+
+LIB_DEPENDS= purple.6:${PORTSDIR}/net-im/libpurple
+RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GNOME= gtk20
+USE_LDCONFIG= ${PREFIX}/lib/pidgin
+
+PLIST_FILES= lib/purple-2/bot-sentry.so lib/purple-2/bot-sentry.la
+
+.include <bsd.port.mk>
diff --git a/net-im/pidgin-bs/distinfo b/net-im/pidgin-bs/distinfo
new file mode 100644
index 000000000000..5af2a8396b75
--- /dev/null
+++ b/net-im/pidgin-bs/distinfo
@@ -0,0 +1,3 @@
+MD5 (bot-sentry-1.3.0.tar.bz2) = 81ed178b982fbaa176c96da792464e43
+SHA256 (bot-sentry-1.3.0.tar.bz2) = e65581328a508a82cd32d246f4037ea3b044eafd223c3c967947f847db28e736
+SIZE (bot-sentry-1.3.0.tar.bz2) = 280673
diff --git a/net-im/pidgin-bs/pkg-descr b/net-im/pidgin-bs/pkg-descr
new file mode 100644
index 000000000000..3bd3de7b647d
--- /dev/null
+++ b/net-im/pidgin-bs/pkg-descr
@@ -0,0 +1,6 @@
+Bot Sentry is a Pidgin (libpurple) plugin to prevent Instant Message (IM) spam.
+It allows you to ignore IMs unless the sender is in your Buddy List, the sender
+is in your Allow List, or the sender correctly answers a question you have
+predefined.
+
+WWW: http://sourceforge.net/projects/pidgin-bs/