aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/pidgin-manualsize/Makefile28
-rw-r--r--net-im/pidgin-manualsize/distinfo3
-rw-r--r--net-im/pidgin-manualsize/pkg-descr6
4 files changed, 38 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index c49f82951957..619e48961aae 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -107,6 +107,7 @@
SUBDIR += pidgin-hotkeys
SUBDIR += pidgin-latex
SUBDIR += pidgin-libnotify
+ SUBDIR += pidgin-manualsize
SUBDIR += pidgin-rhythmbox
SUBDIR += pork
SUBDIR += psi
diff --git a/net-im/pidgin-manualsize/Makefile b/net-im/pidgin-manualsize/Makefile
new file mode 100644
index 000000000000..d1efc1a39203
--- /dev/null
+++ b/net-im/pidgin-manualsize/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: pidgin-manualsize
+# Date created: 8 May 2008
+# Whom: Joseph S. Atkinson <jsatkinson@embarqmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= manualsize
+PORTVERSION= 0.0.2
+CATEGORIES= net-im
+MASTER_SITES= http://leapster.org/patches/pidgin/source/ \
+ http://autocthonia.net/freebsd/distfiles/
+PKGNAMEPREFIX= pidgin-
+DISTNAME= ${PKGNAMEPREFIX}plugin-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= jsatkinson@embarqmail.com
+COMMENT= Plugin to allow manual resizing of Pidgin's message input area
+
+BUILD_DEPENDS= ${LOCALBASE}/include/pidgin/pidgin.h:${PORTSDIR}/net-im/pidgin
+RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
+
+PLIST_FILES= lib/pidgin/manualsize.la \
+ lib/pidgin/manualsize.so
+
+GNU_CONFIGURE= yes
+USE_GNOME= gnometarget
+
+.include <bsd.port.mk>
diff --git a/net-im/pidgin-manualsize/distinfo b/net-im/pidgin-manualsize/distinfo
new file mode 100644
index 000000000000..f77d19b937ed
--- /dev/null
+++ b/net-im/pidgin-manualsize/distinfo
@@ -0,0 +1,3 @@
+MD5 (pidgin-plugin-manualsize-0.0.2.tar.gz) = ef3077d9b58d078cf428b6bc7493fd2f
+SHA256 (pidgin-plugin-manualsize-0.0.2.tar.gz) = 4628d971c204e0da156ace98e5fe5adaea67f1804599f2214e4c6ad805821da3
+SIZE (pidgin-plugin-manualsize-0.0.2.tar.gz) = 320582
diff --git a/net-im/pidgin-manualsize/pkg-descr b/net-im/pidgin-manualsize/pkg-descr
new file mode 100644
index 000000000000..c580e3cb4705
--- /dev/null
+++ b/net-im/pidgin-manualsize/pkg-descr
@@ -0,0 +1,6 @@
+This is Paul Dwerryhouse's standalone version of Artemy Kapitula's manualsize
+plugin. This plugin restores the ability for users to resize the text input area
+of the message window. This functionality was the default behaviour in Pidgin
+prior to version 2.4.
+
+WWW: http://leapster.org/patches/pidgin/