aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/bg-mythes/Makefile7
-rw-r--r--textproc/cs-mythes/Makefile6
-rw-r--r--textproc/en-mythes/Makefile11
-rw-r--r--textproc/it-mythes/Makefile7
-rw-r--r--textproc/nl-mythes/Makefile12
-rw-r--r--textproc/ro-mythes/Makefile7
-rw-r--r--textproc/sk-mythes/Makefile7
-rw-r--r--textproc/sl-mythes/Makefile7
-rw-r--r--textproc/sv-mythes/Makefile11
9 files changed, 32 insertions, 43 deletions
diff --git a/textproc/bg-mythes/Makefile b/textproc/bg-mythes/Makefile
index a4dac9808f15..b71983e733b7 100644
--- a/textproc/bg-mythes/Makefile
+++ b/textproc/bg-mythes/Makefile
@@ -15,16 +15,15 @@ COMMENT= Bulgarian thesaurus
LICENSE= GPLv2 LGPL21 MPL
LICENSE_COMB= dual
-USE_ZIP= yes
+EXTRACT_SUFX= .zip
NO_BUILD= yes
PLIST_FILES= %%DATADIR%%/th_bg_BG.dat \
%%DATADIR%%/th_bg_BG.idx
PLIST_DIRSTRY= %%DATADIR%%
-NO_STAGE= yes
do-install:
- ${MKDIR} ${DATADIR}/
- ${INSTALL_DATA} ${WRKSRC}/th_bg_BG.dat ${WRKSRC}/th_bg_BG.idx ${DATADIR}/
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_bg_BG.dat ${WRKSRC}/th_bg_BG.idx ${STAGEDIR}${DATADIR}/
.include <bsd.port.mk>
diff --git a/textproc/cs-mythes/Makefile b/textproc/cs-mythes/Makefile
index 026c2ef74245..f57a931bc850 100644
--- a/textproc/cs-mythes/Makefile
+++ b/textproc/cs-mythes/Makefile
@@ -14,7 +14,6 @@ COMMENT= Czech thesaurus
LICENSE= BSD
-USE_ZIP= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -22,9 +21,8 @@ PLIST_FILES= %%DATADIR%%/th_cs_CZ_v2.dat \
%%DATADIR%%/th_cs_CZ_v2.idx
PLIST_DIRSTRY= %%DATADIR%%
-NO_STAGE= yes
do-install:
- ${MKDIR} ${DATADIR}/
- ${INSTALL_DATA} ${WRKSRC}/th_cs_CZ_v2.dat ${WRKSRC}/th_cs_CZ_v2.idx ${DATADIR}/
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_cs_CZ_v2.dat ${WRKSRC}/th_cs_CZ_v2.idx ${STAGEDIR}${DATADIR}/
.include <bsd.port.mk>
diff --git a/textproc/en-mythes/Makefile b/textproc/en-mythes/Makefile
index a892673cafca..0899c91bacfc 100644
--- a/textproc/en-mythes/Makefile
+++ b/textproc/en-mythes/Makefile
@@ -14,7 +14,7 @@ COMMENT= English thesaurus
LICENSE= LGPL21
-USE_ZIP= yes
+EXTRACT_SUFX= .zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -29,13 +29,12 @@ PLIST_FILES+= %%DATADIR%%/th_${ALIAS}_v2.dat \
%%DATADIR%%/th_${ALIAS}_v2.idx
.endfor
-NO_STAGE= yes
do-install:
- ${MKDIR} ${DATADIR}/
- ${INSTALL_DATA} ${WRKSRC}/th_en_US_v2.dat ${WRKSRC}/th_en_US_v2.idx ${DATADIR}/
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_en_US_v2.dat ${WRKSRC}/th_en_US_v2.idx ${STAGEDIR}${DATADIR}/
.for ALIAS in ${USALIASES}
- ${LN} -s th_en_US_v2.dat ${DATADIR}/th_${ALIAS}_v2.dat
- ${LN} -s th_en_US_v2.idx ${DATADIR}/th_${ALIAS}_v2.idx
+ ${LN} -s th_en_US_v2.dat ${STAGEDIR}${DATADIR}/th_${ALIAS}_v2.dat
+ ${LN} -s th_en_US_v2.idx ${STAGEDIR}${DATADIR}/th_${ALIAS}_v2.idx
.endfor
.include <bsd.port.mk>
diff --git a/textproc/it-mythes/Makefile b/textproc/it-mythes/Makefile
index 156719f5df31..6fcc048c502a 100644
--- a/textproc/it-mythes/Makefile
+++ b/textproc/it-mythes/Makefile
@@ -12,7 +12,7 @@ DIST_SUBDIR= ${PORTNAME}
MAINTAINER= office@FreeBSD.org
COMMENT= Italian thesaurus
-USE_ZIP= yes
+EXTRACT_SUFX= .zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -20,9 +20,8 @@ PLIST_FILES= %%DATADIR%%/th_it_IT.dat \
%%DATADIR%%/th_it_IT.idx
PLIST_DIRSTRY= %%DATADIR%%
-NO_STAGE= yes
do-install:
- ${MKDIR} ${DATADIR}/
- ${INSTALL_DATA} ${WRKSRC}/th_it_IT.dat ${WRKSRC}/th_it_IT.idx ${DATADIR}/
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_it_IT.dat ${WRKSRC}/th_it_IT.idx ${STAGEDIR}${DATADIR}/
.include <bsd.port.mk>
diff --git a/textproc/nl-mythes/Makefile b/textproc/nl-mythes/Makefile
index 0fe186511e1e..ba77d8ddb0cc 100644
--- a/textproc/nl-mythes/Makefile
+++ b/textproc/nl-mythes/Makefile
@@ -14,7 +14,6 @@ COMMENT= Dutch thesaurus
LICENSE= BSD
-USE_ZIP= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -28,14 +27,13 @@ PLIST_FILES+= %%DATADIR%%/th_${ALIAS}_v2.dat \
%%DATADIR%%/th_${ALIAS}_v2.idx
.endfor
-NO_STAGE= yes
do-install:
- ${MKDIR} ${DATADIR}/
- ${INSTALL_DATA} ${WRKSRC}/th_nl_v2.dat ${DATADIR}/th_nl_NL_v2.dat
- ${INSTALL_DATA} ${WRKSRC}/th_nl_v2.dat ${DATADIR}/th_nl_NL_v2.idx
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_nl_v2.dat ${STAGEDIR}${DATADIR}/th_nl_NL_v2.dat
+ ${INSTALL_DATA} ${WRKSRC}/th_nl_v2.dat ${STAGEDIR}${DATADIR}/th_nl_NL_v2.idx
.for ALIAS in ${NLALIASES}
- ${LN} -s th_nl_NL_v2.dat ${DATADIR}/th_${ALIAS}_v2.dat
- ${LN} -s th_nl_NL_v2.idx ${DATADIR}/th_${ALIAS}_v2.idx
+ ${LN} -s th_nl_NL_v2.dat ${STAGEDIR}${DATADIR}/th_${ALIAS}_v2.dat
+ ${LN} -s th_nl_NL_v2.idx ${STAGEDIR}${DATADIR}/th_${ALIAS}_v2.idx
.endfor
.include <bsd.port.mk>
diff --git a/textproc/ro-mythes/Makefile b/textproc/ro-mythes/Makefile
index 8734f40abbdd..dad03ec32382 100644
--- a/textproc/ro-mythes/Makefile
+++ b/textproc/ro-mythes/Makefile
@@ -14,7 +14,7 @@ COMMENT= Romanian thesaurus
LICENSE= GPLv2
-USE_ZIP= yes
+EXTRACT_SUFX= .zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -22,9 +22,8 @@ PLIST_FILES= %%DATADIR%%/th_ro_RO.dat \
%%DATADIR%%/th_ro_RO.idx
PLIST_DIRSTRY= %%DATADIR%%
-NO_STAGE= yes
do-install:
- ${MKDIR} ${DATADIR}/
- ${INSTALL_DATA} ${WRKSRC}/th_ro_RO.dat ${WRKSRC}/th_ro_RO.idx ${DATADIR}/
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_ro_RO.dat ${WRKSRC}/th_ro_RO.idx ${STAGEDIR}${DATADIR}/
.include <bsd.port.mk>
diff --git a/textproc/sk-mythes/Makefile b/textproc/sk-mythes/Makefile
index cd4b82eeef64..fdcdd94597a2 100644
--- a/textproc/sk-mythes/Makefile
+++ b/textproc/sk-mythes/Makefile
@@ -13,7 +13,7 @@ COMMENT= Slovak thesaurus
LICENSE= BSD
-USE_ZIP= yes
+EXTRACT_SUFX= .zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -21,9 +21,8 @@ PLIST_FILES= %%DATADIR%%/th_sk_SK_v2.dat \
%%DATADIR%%/th_sk_SK_v2.idx
PLIST_DIRSTRY= %%DATADIR%%
-NO_STAGE= yes
do-install:
- ${MKDIR} ${DATADIR}/
- ${INSTALL_DATA} ${WRKSRC}/th_sk_SK_v2.dat ${WRKSRC}/th_sk_SK_v2.idx ${DATADIR}/
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_sk_SK_v2.dat ${WRKSRC}/th_sk_SK_v2.idx ${STAGEDIR}${DATADIR}/
.include <bsd.port.mk>
diff --git a/textproc/sl-mythes/Makefile b/textproc/sl-mythes/Makefile
index 1fa1b68f6a49..8c4a7a2664ce 100644
--- a/textproc/sl-mythes/Makefile
+++ b/textproc/sl-mythes/Makefile
@@ -13,7 +13,7 @@ COMMENT= Slovenian thesaurus
LICENSE= LGPL21
-USE_ZIP= yes
+EXTRACT_SUFX= .zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -21,9 +21,8 @@ PLIST_FILES= %%DATADIR%%/th_sl_SI_v2.dat \
%%DATADIR%%/th_sl_SI_v2.idx
PLIST_DIRSTRY= %%DATADIR%%
-NO_STAGE= yes
do-install:
- ${MKDIR} ${DATADIR}/
- ${INSTALL_DATA} ${WRKSRC}/th_sl_SI_v2.dat ${WRKSRC}/th_sl_SI_v2.idx ${DATADIR}/
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_sl_SI_v2.dat ${WRKSRC}/th_sl_SI_v2.idx ${STAGEDIR}${DATADIR}/
.include <bsd.port.mk>
diff --git a/textproc/sv-mythes/Makefile b/textproc/sv-mythes/Makefile
index 53b1fa7414c4..c3d1874ca376 100644
--- a/textproc/sv-mythes/Makefile
+++ b/textproc/sv-mythes/Makefile
@@ -14,7 +14,7 @@ COMMENT= Swedish thesaurus
LICENSE= MIT
-USE_ZIP= yes
+EXTRACT_SUFX= .zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -24,11 +24,10 @@ PLIST_FILES= %%DATADIR%%/th_sv_SE.dat \
%%DATADIR%%/th_sv_FI.idx
PLIST_DIRSTRY= %%DATADIR%%
-NO_STAGE= yes
do-install:
- ${MKDIR} ${DATADIR}/
- ${INSTALL_DATA} ${WRKSRC}/th_sv_SE.dat ${WRKSRC}/th_sv_SE.idx ${DATADIR}/
- ${LN} -s th_sv_SE.dat ${DATADIR}/th_sv_FI.dat
- ${LN} -s th_sv_SE.idx ${DATADIR}/th_sv_FI.idx
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_sv_SE.dat ${WRKSRC}/th_sv_SE.idx ${STAGEDIR}${DATADIR}/
+ ${LN} -s th_sv_SE.dat ${STAGEDIR}${DATADIR}/th_sv_FI.dat
+ ${LN} -s th_sv_SE.idx ${STAGEDIR}${DATADIR}/th_sv_FI.idx
.include <bsd.port.mk>