aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/asbutton/Makefile14
-rw-r--r--misc/asbutton/distinfo2
-rw-r--r--misc/asbutton/files/patch-aa33
-rw-r--r--print/asprint/Makefile3
-rw-r--r--print/asprint/files/patch-aa13
-rw-r--r--sysutils/asapm/Makefile6
-rw-r--r--sysutils/asmon/Makefile6
-rw-r--r--sysutils/asmon/distinfo1
-rw-r--r--sysutils/asmon/files/patch-aa6
-rw-r--r--x11-fm/asfiles/Makefile6
-rw-r--r--x11-fm/asfiles/distinfo2
11 files changed, 62 insertions, 30 deletions
diff --git a/misc/asbutton/Makefile b/misc/asbutton/Makefile
index 372671efa77f..d7cbb4e28742 100644
--- a/misc/asbutton/Makefile
+++ b/misc/asbutton/Makefile
@@ -8,29 +8,27 @@
PORTNAME= asbutton
PORTVERSION= 0.3
CATEGORIES= misc windowmaker afterstep
-MASTER_SITES= http://www.tigr.net/afterstep/as-apps/download/asbutton/ \
- ftp://ftp.afterstep.org/apps/asbutton/
+MASTER_SITES= ${MASTER_SITE_AFTERSTEP}
+MASTER_SITE_SUBDIR= apps/asbutton
MAINTAINER= jim@FreeBSD.org
LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
USE_X_PREFIX= yes
-
-do-build:
- (cd ${WRKSRC} && make)
+ALL_TARGET= asbutton
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/asbutton ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/asbutton ${PREFIX}/bin
@${ECHO} "===> Installing icons in ${PREFIX}/share/asbutton"
@${MKDIR} ${PREFIX}/share/asbutton && ${CHMOD} a+rx ${PREFIX}/share/asbutton
- @${INSTALL_DATA} ${WRKSRC}/icons/*.xpm ${PREFIX}/share/asbutton
+ ${INSTALL_DATA} ${WRKSRC}/icons/*.xpm ${PREFIX}/share/asbutton
post-install:
@${ECHO} "===> Installing sample asbuttonrc in ${PREFIX}/share/examples/asbutton"
@${ECHO} "===> Copy to ~/.asbuttonrc and modify to desired config."
@${MKDIR} ${PREFIX}/share/examples/asbutton && ${CHMOD} a+rx ${PREFIX}/share/examples/asbutton
- @${INSTALL_DATA} ${WRKSRC}/.asbuttonrc ${PREFIX}/share/examples/asbutton/asbuttonrc && ${CHMOD} u+rw ${PREFIX}/share/examples/asbutton/asbuttonrc
+ ${INSTALL_DATA} ${WRKSRC}/.asbuttonrc ${PREFIX}/share/examples/asbutton/asbuttonrc && ${CHMOD} u+rw ${PREFIX}/share/examples/asbutton/asbuttonrc
@${ECHO} "===> Use 'asbutton -h' for help."
.include <bsd.port.mk>
diff --git a/misc/asbutton/distinfo b/misc/asbutton/distinfo
index 679e98de0ca9..7bc72ed48709 100644
--- a/misc/asbutton/distinfo
+++ b/misc/asbutton/distinfo
@@ -1 +1 @@
-MD5 (asbutton-0.3.tar.gz) = febcc9db3eb615856bbebdc966ea4f27
+MD5 (asbutton-0.3.tar.gz) = bfb9445670946654814333d707e6cb86
diff --git a/misc/asbutton/files/patch-aa b/misc/asbutton/files/patch-aa
new file mode 100644
index 000000000000..72fad3b2c948
--- /dev/null
+++ b/misc/asbutton/files/patch-aa
@@ -0,0 +1,33 @@
+--- Makefile.orig Sat Jul 17 07:16:39 1999
++++ Makefile Wed Jun 21 02:54:42 2000
+@@ -1,12 +1,12 @@
+-INCLUDES =-I/usr/X11R6/include/X11 -I/usr/local/include -I/usr/include/X11R6/X11 -I/usr/X11R6/include
+-LIBINC =-L/usr/X11R6/lib -L/usr/include/lib
++INCLUDES =-I${X11BASE}/include/X11 -I${X11BASE}/include
++LIBINC =-L${X11BASE}/lib
+ LIBS = -lm -lX11 -lXpm -lXext
+ #CCFLAGS = -O6 -mpentiumpro -march=pentiumpro
+-CCFLAGS = -O2
++CCFLAGS = ${CFLAGS}
+ TARGET = asbutton
+ OBJECTS = asbutton.o readline.o
+-BINDIR = /usr/local/bin
+-ICONDIR = /usr/share/afterstep/desktop/icons/16bpp
++BINDIR = ${PREFIX}/bin
++ICONDIR = ${PREFIX}/share/asbutton
+
+ ICONS = asb4-1.xpm asb4-2.xpm asb4-3.xpm asb4-4.xpm asb4-blank.xpm asb4-bullethole.xpm \
+ asb4-filingcabinet.xpm asb4-gear.xpm asb4-gnu-button-thang.xpm \
+@@ -23,10 +23,10 @@
+ asb9-corel.xpm asb9-gqview.xpm asb9-vim.xpm asb9-xmms.xpm
+
+ .c.o:
+- gcc ${CCFLAGS} -c -Wall ${INCLUDES} ${FLAGS} $< -o $*.o
++ ${CC} ${CCFLAGS} -c -Wall ${INCLUDES} ${FLAGS} $< -o $*.o
+
+ ${TARGET}: ${OBJECTS}
+- gcc ${CCFLAGS} -o ${TARGET} ${OBJECTS} ${LIBINC} ${LIBS}
++ ${CC} ${CCFLAGS} -o ${TARGET} ${OBJECTS} ${LIBINC} ${LIBS}
+
+ clean::
+ for i in ${OBJECTS}; do if [ -e $$i ] ; then rm $$i; fi; done
diff --git a/print/asprint/Makefile b/print/asprint/Makefile
index ce21542234c8..c71a808d455d 100644
--- a/print/asprint/Makefile
+++ b/print/asprint/Makefile
@@ -8,7 +8,8 @@
PORTNAME= asprint
PORTVERSION= 1.0
CATEGORIES= print
-MASTER_SITES= ftp://ftp.afterstep.org/apps/asprint/
+MASTER_SITES= ${MASTER_SITE_AFTERSTEP}
+MASTER_SITE_SUBDIR= apps/asprint
DISTNAME= asprint
MAINTAINER= brett@peloton.runet.edu
diff --git a/print/asprint/files/patch-aa b/print/asprint/files/patch-aa
index 218c399741ae..756ef0f0d9bc 100644
--- a/print/asprint/files/patch-aa
+++ b/print/asprint/files/patch-aa
@@ -1,11 +1,14 @@
---- makefile.orig Fri Mar 14 04:34:48 1997
-+++ makefile Mon Oct 12 19:17:11 1998
-@@ -2,17 +2,18 @@
+--- makefile.orig Fri Mar 14 19:34:48 1997
++++ makefile Wed Jun 21 02:59:31 2000
+@@ -1,18 +1,19 @@
+ .KEEP_STATE:
- CFLAGS = -O2
- CC = gcc
+-CFLAGS = -O2
+-CC = gcc
-XLIB = -L/usr/X11/lib -lXaw3d -lXmu -lXt
-
++CFLAGS ?= -O2
++CC ?= gcc
+XLIB = -L$(X11BASE)/lib -lXaw -lXmu -lXt
+.if $(PORTOBJFORMAT) == "elf"
+XLIB+= -Wl,-rpath,$(X11BASE)/lib
diff --git a/sysutils/asapm/Makefile b/sysutils/asapm/Makefile
index 7bcc9cda2528..88219a056860 100644
--- a/sysutils/asapm/Makefile
+++ b/sysutils/asapm/Makefile
@@ -8,8 +8,8 @@
PORTNAME= asapm
PORTVERSION= 2.7
CATEGORIES= sysutils
-MASTER_SITES= ftp://ftp.afterstep.org/apps/asapm/ \
- http://www.tigr.net/afterstep/as-apps/download/asapm/
+MASTER_SITES= ${MASTER_SITE_AFTERSTEP}
+MASTER_SITE_SUBDIR= apps/asapm
MAINTAINER= handy@physics.montana.edu
@@ -23,6 +23,4 @@ INSTALL_TARGET= install install.man
MAN1= asapm.1
-FETCH_BEFORE_ARGS= -b
-
.include <bsd.port.mk>
diff --git a/sysutils/asmon/Makefile b/sysutils/asmon/Makefile
index 82b58d7edc57..3fe26a16b7d0 100644
--- a/sysutils/asmon/Makefile
+++ b/sysutils/asmon/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: asfsm
+# New ports collection makefile for: asmon
# Date created: 27 Sep 1999
# Whom: jack
#
@@ -8,8 +8,8 @@
PORTNAME= asmon
PORTVERSION= 0.60
CATEGORIES= sysutils afterstep
-MASTER_SITES= ftp://ftp.afterstep.org/apps/asmon/ \
- http://www.tigr.net/afterstep/as-apps/download/asmon/
+MASTER_SITES= ${MASTER_SITE_AFTERSTEP}
+MASTER_SITE_SUBDIR= apps/asmon
MAINTAINER= jack@germanium.xtalwind.net
diff --git a/sysutils/asmon/distinfo b/sysutils/asmon/distinfo
index fa0d6fcb4b49..ade3ba79b0fe 100644
--- a/sysutils/asmon/distinfo
+++ b/sysutils/asmon/distinfo
@@ -1,2 +1 @@
-MD5 (asmon-0.60.tar.gz) = d33e59597f56368f180ca1b4b4c126e8
MD5 (asmon-0.60.tar.gz) = 781d273283b307b5089afbfa6aa35f18
diff --git a/sysutils/asmon/files/patch-aa b/sysutils/asmon/files/patch-aa
index 390d9c3b0817..3fde759d3512 100644
--- a/sysutils/asmon/files/patch-aa
+++ b/sysutils/asmon/files/patch-aa
@@ -3,7 +3,7 @@
***************
*** 0 ****
--- 1,20 ----
-+ LIBDIR = -L/usr/X11R6/lib
++ LIBDIR = -L${X11BASE}/lib
+ LIBS = -lXpm -lXext -lX11 -lkvm
+ OBJS = asmon/asmon.o \
+ wmgeneral/wmgeneral.o \
@@ -13,10 +13,10 @@
+ all: asmon
+
+ .c.o:
-+ cc -c -Wall -I/usr/X11R6/include $< -o $*.o
++ $(CC) $(CFLAGS) -c -Wall -I${X11BASE}/include $< -o $*.o
+
+ asmon: $(OBJS)
-+ cc -o asmon/asmon $^ $(LIBDIR) $(LIBS)
++ $(CC) -o asmon/asmon $^ $(LIBDIR) $(LIBS)
+
+ clean::
+ for i in $(OBJS) ; do \
diff --git a/x11-fm/asfiles/Makefile b/x11-fm/asfiles/Makefile
index b3c4bc2fc1e8..d5099b70f5a1 100644
--- a/x11-fm/asfiles/Makefile
+++ b/x11-fm/asfiles/Makefile
@@ -7,9 +7,9 @@
PORTNAME= asfiles
PORTVERSION= 1.0
-CATEGORIES= x11-fm windowmaker
-MASTER_SITES= ftp://ftp.cs.tu-berlin.de/pub/X/afterstep/apps/ASFiles/ \
- ftp://ftp.uni-trier.de/pub/unix/X11/window-manager/AfterStep/apps/ASFiles/
+CATEGORIES= x11-fm afterstep windowmaker
+MASTER_SITES= ${MASTER_SITE_AFTERSTEP}
+MASTER_SITE_SUBDIR= apps/ASFiles
DISTNAME= ASFiles-${PORTVERSION}
MAINTAINER= lukin@okbmei.msk.su
diff --git a/x11-fm/asfiles/distinfo b/x11-fm/asfiles/distinfo
index e86ca8ad9822..c9091b21b7ff 100644
--- a/x11-fm/asfiles/distinfo
+++ b/x11-fm/asfiles/distinfo
@@ -1 +1 @@
-MD5 (ASFiles-1.0.tar.gz) = 1e38eb7b37e1e53de7711cd410e66ef8
+MD5 (ASFiles-1.0.tar.gz) = cd385e5bd93a75cb110c7544f86cc303