aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.port.subdir.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/Mk/bsd.port.subdir.mk b/Mk/bsd.port.subdir.mk
index 5a6511c54f6f..61cdec288761 100644
--- a/Mk/bsd.port.subdir.mk
+++ b/Mk/bsd.port.subdir.mk
@@ -207,12 +207,14 @@ README.html:
@echo "===> Creating README.html"
@> $@.tmp
.for entry in ${SUBDIR}
+.if exists(${entry})
.if defined(PORTSTOP)
@echo -n '<a href="'${entry}/README.html'">'"`echo ${entry} | ${HTMLIFY}`"'</a>: ' >> $@.tmp
.else
@echo -n '<a href="'${entry}/README.html'">'"`cd ${entry}; make package-name | ${HTMLIFY}`</a>: " >> $@.tmp
.endif
@cat `cd ${entry}; make -V COMMENT` | ${HTMLIFY} >> $@.tmp
+.endif
.endfor
@sort -t '>' +1 -2 $@.tmp > $@.tmp2
.if exists(${DESCR})