aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/py-python-lzo/Makefile22
-rw-r--r--archivers/py-python-lzo/distinfo3
-rw-r--r--archivers/py-python-lzo/pkg-descr10
4 files changed, 36 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 10dadea3a089..5704793aa8b1 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -173,6 +173,7 @@
SUBDIR += py-lzma
SUBDIR += py-pyliblzma
SUBDIR += py-python-lhafile
+ SUBDIR += py-python-lzo
SUBDIR += py-python-snappy
SUBDIR += py-rarfile
SUBDIR += py-rcssmin
diff --git a/archivers/py-python-lzo/Makefile b/archivers/py-python-lzo/Makefile
new file mode 100644
index 000000000000..04ca7aba8ffb
--- /dev/null
+++ b/archivers/py-python-lzo/Makefile
@@ -0,0 +1,22 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= python-lzo
+PORTVERSION= 1.11
+CATEGORIES= archivers python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Python bindings for the LZO data compression library
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= liblzo2.so:archivers/lzo2
+
+USES= python:2
+USE_PYTHON= autoplist distutils
+CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/lzo
+
+.include <bsd.port.mk>
diff --git a/archivers/py-python-lzo/distinfo b/archivers/py-python-lzo/distinfo
new file mode 100644
index 000000000000..b14183fc7c6b
--- /dev/null
+++ b/archivers/py-python-lzo/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1492589752
+SHA256 (python-lzo-1.11.tar.gz) = 38a0ea4ceb27cdd8e3526509fe1b7a936e5dfa57c64608fd32085c129e8be386
+SIZE (python-lzo-1.11.tar.gz) = 13823
diff --git a/archivers/py-python-lzo/pkg-descr b/archivers/py-python-lzo/pkg-descr
new file mode 100644
index 000000000000..2fd66859fa7b
--- /dev/null
+++ b/archivers/py-python-lzo/pkg-descr
@@ -0,0 +1,10 @@
+This module provides Python bindings for the LZO data compression library.
+
+LZO is a portable lossless data compression library written in ANSI C.
+It offers pretty fast compression and very fast decompression. Decompression
+requires no memory.
+
+In addition there are slower compression levels achieving a quite competitive
+compression ratio while still decompressing at this very high speed.
+
+WWW: https://pypi.python.org/pypi/python-lzo