aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/mixxx/Makefile12
-rw-r--r--devel/mingw-gcc/Makefile4
-rw-r--r--games/macopix/Makefile8
-rw-r--r--games/magiccube4d/Makefile8
-rw-r--r--net-mgmt/mbrowse/Makefile8
-rw-r--r--net-p2p/mldonkey-devel/Makefile8
-rw-r--r--net-p2p/mldonkey/Makefile8
-rw-r--r--net/mldonkey-devel/Makefile8
-rw-r--r--net/mldonkey/Makefile8
-rw-r--r--www/mod_v2h/Makefile4
10 files changed, 65 insertions, 11 deletions
diff --git a/audio/mixxx/Makefile b/audio/mixxx/Makefile
index 7c424ae335a3..e3ce471afb5e 100644
--- a/audio/mixxx/Makefile
+++ b/audio/mixxx/Makefile
@@ -37,6 +37,14 @@ CONFIGURE_ENV= QTDIR="${X11BASE}" \
NOPORTDOCS="${NOPORTDOCS}"
MAKE_ENV= QTDIR="${X11BASE}"
+.include <bsd.port.pre.mk>
+
+CONFIGURE_ARGS= --prefix=${PREFIX}
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-patch:
@${REINPLACE_CMD} \
-e 's|@LOCALBASE@|${LOCALBASE}|g' \
@@ -50,8 +58,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/Mixxx-Manual.pdf ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.pre.mk>
-
-CONFIGURE_ARGS= --prefix=${PREFIX}
-
.include <bsd.port.post.mk>
diff --git a/devel/mingw-gcc/Makefile b/devel/mingw-gcc/Makefile
index 08f93aae83d1..19c7500b3d9b 100644
--- a/devel/mingw-gcc/Makefile
+++ b/devel/mingw-gcc/Makefile
@@ -42,6 +42,10 @@ INFO= cpp g77 gcc
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if ${ARCH} != "i386"
BROKEN= "Does not compile on !i386"
.endif
diff --git a/games/macopix/Makefile b/games/macopix/Makefile
index 251b087ace76..08062147c272 100644
--- a/games/macopix/Makefile
+++ b/games/macopix/Makefile
@@ -53,6 +53,12 @@ CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
MAN1= macopix.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-install:
${STRIP_CMD} ${PREFIX}/bin/macopix
# install mascot file
@@ -107,4 +113,4 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/NKR.README.jp ${PREFIX}/share/doc/macopix
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/magiccube4d/Makefile b/games/magiccube4d/Makefile
index ed77bbf85f73..0322e5b7f443 100644
--- a/games/magiccube4d/Makefile
+++ b/games/magiccube4d/Makefile
@@ -22,6 +22,12 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-src-${PORTVERSION:S/./_/}
DOCS= ChangeLog Intro.txt MagicCube4D-unix.txt \
ideas.txt readme-unix.txt
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/magiccube4d ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@@ -31,4 +37,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/mbrowse/Makefile b/net-mgmt/mbrowse/Makefile
index c77e12e9e81d..e31696929beb 100644
--- a/net-mgmt/mbrowse/Makefile
+++ b/net-mgmt/mbrowse/Makefile
@@ -33,4 +33,10 @@ CONFIGURE_ENV+= LDFLAGS="`net-snmp-config --libs`" \
CONFIGURE_ARGS+= --with-snmp-type=net
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-p2p/mldonkey-devel/Makefile b/net-p2p/mldonkey-devel/Makefile
index 24a3d5fffebc..d74459c19109 100644
--- a/net-p2p/mldonkey-devel/Makefile
+++ b/net-p2p/mldonkey-devel/Makefile
@@ -48,6 +48,12 @@ PLIST_SUB+= CORE="" GUICORE=""
DOCFILES= Authors.txt Bugs.txt ChangeLog Developers.txt FAQ.html \
Install.txt Readme.txt Todo.txt ed2k_links.txt
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
pre-everything::
.if !defined(WITHOUT_GUI) && !defined(WITHOUT_CORE)
@${ECHO_MSG} "You can disable the GUI by defining WITHOUT_GUI."
@@ -93,4 +99,4 @@ install-user: extract
${HOME}/.mldonkey_gui_messages.ini
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-p2p/mldonkey/Makefile b/net-p2p/mldonkey/Makefile
index 24a3d5fffebc..d74459c19109 100644
--- a/net-p2p/mldonkey/Makefile
+++ b/net-p2p/mldonkey/Makefile
@@ -48,6 +48,12 @@ PLIST_SUB+= CORE="" GUICORE=""
DOCFILES= Authors.txt Bugs.txt ChangeLog Developers.txt FAQ.html \
Install.txt Readme.txt Todo.txt ed2k_links.txt
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
pre-everything::
.if !defined(WITHOUT_GUI) && !defined(WITHOUT_CORE)
@${ECHO_MSG} "You can disable the GUI by defining WITHOUT_GUI."
@@ -93,4 +99,4 @@ install-user: extract
${HOME}/.mldonkey_gui_messages.ini
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/mldonkey-devel/Makefile b/net/mldonkey-devel/Makefile
index 24a3d5fffebc..d74459c19109 100644
--- a/net/mldonkey-devel/Makefile
+++ b/net/mldonkey-devel/Makefile
@@ -48,6 +48,12 @@ PLIST_SUB+= CORE="" GUICORE=""
DOCFILES= Authors.txt Bugs.txt ChangeLog Developers.txt FAQ.html \
Install.txt Readme.txt Todo.txt ed2k_links.txt
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
pre-everything::
.if !defined(WITHOUT_GUI) && !defined(WITHOUT_CORE)
@${ECHO_MSG} "You can disable the GUI by defining WITHOUT_GUI."
@@ -93,4 +99,4 @@ install-user: extract
${HOME}/.mldonkey_gui_messages.ini
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/mldonkey/Makefile b/net/mldonkey/Makefile
index 24a3d5fffebc..d74459c19109 100644
--- a/net/mldonkey/Makefile
+++ b/net/mldonkey/Makefile
@@ -48,6 +48,12 @@ PLIST_SUB+= CORE="" GUICORE=""
DOCFILES= Authors.txt Bugs.txt ChangeLog Developers.txt FAQ.html \
Install.txt Readme.txt Todo.txt ed2k_links.txt
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
pre-everything::
.if !defined(WITHOUT_GUI) && !defined(WITHOUT_CORE)
@${ECHO_MSG} "You can disable the GUI by defining WITHOUT_GUI."
@@ -93,4 +99,4 @@ install-user: extract
${HOME}/.mldonkey_gui_messages.ini
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/mod_v2h/Makefile b/www/mod_v2h/Makefile
index 08005b0d778c..971534361ae3 100644
--- a/www/mod_v2h/Makefile
+++ b/www/mod_v2h/Makefile
@@ -25,6 +25,10 @@ USE_PERL5_RUN= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if ${ARCH} == "amd64"
BROKEN= "Does not compile on amd64 (missing -fPIC)"
.endif