aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-File-Policy/Makefile28
-rw-r--r--devel/p5-File-Policy/distinfo3
-rw-r--r--devel/p5-File-Policy/pkg-descr17
-rw-r--r--devel/p5-File-Policy/pkg-plist9
5 files changed, 58 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1a5591f1b60f..62770304beae 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1188,6 +1188,7 @@
SUBDIR += p5-File-Path-Expand
SUBDIR += p5-File-PathConvert
SUBDIR += p5-File-Pid
+ SUBDIR += p5-File-Policy
SUBDIR += p5-File-Random
SUBDIR += p5-File-ReadBackwards
SUBDIR += p5-File-Remove
diff --git a/devel/p5-File-Policy/Makefile b/devel/p5-File-Policy/Makefile
new file mode 100644
index 000000000000..54840c45d3d6
--- /dev/null
+++ b/devel/p5-File-Policy/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-File-Policy
+# Date created: August 27, 2007
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Policy
+PORTVERSION= 1.005
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Simple policy for file I/O functions
+
+BUILD_DEPENDS= p5-Log-Trace>0:${PORTSDIR}/devel/p5-Log-Trace \
+ p5-File-Slurp>0:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-Test-Assertions>0:${PORTSDIR}/devel/p5-Test-Assertions
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= File::Policy.3 \
+ File::Policy::Default.3 \
+ File::Slurp::WithinPolicy.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-Policy/distinfo b/devel/p5-File-Policy/distinfo
new file mode 100644
index 000000000000..d2fb95baba79
--- /dev/null
+++ b/devel/p5-File-Policy/distinfo
@@ -0,0 +1,3 @@
+MD5 (File-Policy-1.005.tar.gz) = 735ee869bf623861724bd3960f482e0d
+SHA256 (File-Policy-1.005.tar.gz) = 56be77e527a708c4403212ffefd9ee280aef2aa8794bac625ce8035dc854f7b9
+SIZE (File-Policy-1.005.tar.gz) = 14254
diff --git a/devel/p5-File-Policy/pkg-descr b/devel/p5-File-Policy/pkg-descr
new file mode 100644
index 000000000000..e096e0c4b210
--- /dev/null
+++ b/devel/p5-File-Policy/pkg-descr
@@ -0,0 +1,17 @@
+This defines the policy for file I/O with modules such as
+File::Slurp::WithinPolicy. The purpose is to allow systems administrators to
+define locations and restrictions for applications' file I/O and give app
+developers a policy to follow. Note that the module doesn't ENFORCE the
+policy - application developers can choose to ignore it
+(and systems administrators can choose not to install their applications
+ if they do!).
+
+You may control which policy gets applied by creating a File::Policy::Config
+module with an IMPLEMENTATION constant. You may write your own policy as a
+module within the File::Policy:: namespace.
+
+By default (if no File::Policy::Config is present), the File::Policy::Default
+policy gets applied which doesn't impose any restrictions and provides
+reasonable default locations for temporary and log files.
+
+WWW: http://search.cpan.org/dist/File-Policy/
diff --git a/devel/p5-File-Policy/pkg-plist b/devel/p5-File-Policy/pkg-plist
new file mode 100644
index 000000000000..ad52df60fbb4
--- /dev/null
+++ b/devel/p5-File-Policy/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/File/Policy.pm
+%%SITE_PERL%%/File/Policy/Default.pm
+%%SITE_PERL%%/File/Slurp/WithinPolicy.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Policy/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Policy
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File
+@dirrmtry %%SITE_PERL%%/File/Slurp
+@dirrmtry %%SITE_PERL%%/File/Policy
+@dirrmtry %%SITE_PERL%%/File