aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/icegenerator/Makefile2
-rw-r--r--benchmarks/sysbench/Makefile2
-rw-r--r--databases/fpc-postgres/Makefile2
-rw-r--r--databases/libdbi-drivers/Makefile2
-rw-r--r--databases/p5-DBIx-Class-Schema-Loader/Makefile2
-rw-r--r--devel/apr1/Makefile2
-rw-r--r--devel/apr2/Makefile2
-rw-r--r--dns/mydns-ng/Makefile2
-rw-r--r--editors/calligra/Makefile2
-rw-r--r--ftp/pure-ftpd/Makefile2
-rw-r--r--ftp/smbftpd/Makefile2
-rw-r--r--ftp/wzdftpd/Makefile2
-rw-r--r--games/ldmud/Makefile2
-rw-r--r--graphics/gdal/Makefile2
-rw-r--r--lang/smalltalk/Makefile2
-rw-r--r--mail/cyrus-imapd23/Makefile2
-rw-r--r--mail/cyrus-imapd24/Makefile2
-rw-r--r--mail/dbmail22/Makefile2
-rw-r--r--mail/dovecot/Makefile2
-rw-r--r--mail/dovecot2/Makefile2
-rw-r--r--mail/opensmtpd-devel/Makefile2
-rw-r--r--mail/opensmtpd/Makefile2
-rw-r--r--misc/krecipes-kde4/Makefile4
-rw-r--r--net-im/jabberd/Makefile2
-rw-r--r--net-mgmt/flow-tools-ng/Makefile2
-rw-r--r--net-mgmt/netams/Makefile2
-rw-r--r--security/barnyard2/Makefile2
-rw-r--r--security/cyrus-sasl2/Makefile2
-rw-r--r--sysutils/msyslog/Makefile2
-rw-r--r--www/kannel/Makefile2
-rw-r--r--www/owncloud/Makefile3
31 files changed, 33 insertions, 32 deletions
diff --git a/audio/icegenerator/Makefile b/audio/icegenerator/Makefile
index ce47c87a23df..686a7c9bfed7 100644
--- a/audio/icegenerator/Makefile
+++ b/audio/icegenerator/Makefile
@@ -20,7 +20,7 @@ OPTIONS_DEFINE= DOCS MYSQL PGSQL
MYSQL_USE= MYSQL=YES
MYSQL_CONFIGURE_ON= --with-mysql
-PGSQL_USE= PGSQL=YES
+PGSQL_USES= pgsql
PGSQL_CONFIGURE_ON= --with-pgsql
post-install:
diff --git a/benchmarks/sysbench/Makefile b/benchmarks/sysbench/Makefile
index 7539f1d68a82..6e4f6a891550 100644
--- a/benchmarks/sysbench/Makefile
+++ b/benchmarks/sysbench/Makefile
@@ -35,6 +35,6 @@ MYSQL_USE= MYSQL=yes
PGSQL_CONFIGURE_ON= --with-pgsql
PGSQL_CONFIGURE_OFF= --with-pgsql=no
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
.include <bsd.port.mk>
diff --git a/databases/fpc-postgres/Makefile b/databases/fpc-postgres/Makefile
index 36af9ad1c00b..7e7cb071189b 100644
--- a/databases/fpc-postgres/Makefile
+++ b/databases/fpc-postgres/Makefile
@@ -18,6 +18,6 @@ OPTIONS_DEFINE= PGSQL
PGSQL_DESC= Install PostgreSQL client
OPTIONS_DEFAULT= PGSQL
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
.include "${MASTERDIR}/Makefile"
diff --git a/databases/libdbi-drivers/Makefile b/databases/libdbi-drivers/Makefile
index c7d71331b5c0..e7269410436d 100644
--- a/databases/libdbi-drivers/Makefile
+++ b/databases/libdbi-drivers/Makefile
@@ -31,7 +31,7 @@ OPTIONS_SUB= yes
MYSQL_USE= MYSQL=yes
MYSQL_CONFIGURE_WITH= mysql
MYSQL_PLIST_FILES= lib/dbd/libdbdmysql.so
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= pgsql
PGSQL_PLIST_FILES= lib/dbd/libdbdpgsql.so
SQLITE3_LIB_DEPENDS= libsqlite3.so:${PORTSDIR}/databases/sqlite3
diff --git a/databases/p5-DBIx-Class-Schema-Loader/Makefile b/databases/p5-DBIx-Class-Schema-Loader/Makefile
index 04aa4c67fc03..5e772b4211f7 100644
--- a/databases/p5-DBIx-Class-Schema-Loader/Makefile
+++ b/databases/p5-DBIx-Class-Schema-Loader/Makefile
@@ -52,7 +52,7 @@ USE_PERL5= configure
MYSQL_USE= MYSQL=yes
ORACLE_BUILD_DEPENDS= p5-DBD-Oracle>=0.19:${PORTSDIR}/databases/p5-DBD-Oracle
ORACLE_RUN_DEPENDS= p5-DBD-Oracle>=0.19:${PORTSDIR}/databases/p5-DBD-Oracle
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
SQLITE_USE= SQLITE=yes
.include <bsd.port.mk>
diff --git a/devel/apr1/Makefile b/devel/apr1/Makefile
index 7aaf8ce20a63..c9f4f720437f 100644
--- a/devel/apr1/Makefile
+++ b/devel/apr1/Makefile
@@ -47,7 +47,7 @@ GDBM_LIB_DEPENDS= libgdbm.so:${PORTSDIR}/databases/gdbm
LDAP_USE= OPENLDAP=yes
MYSQL_USE= MYSQL=yes
NSS_LIB_DEPENDS= libnss3.so:${PORTSDIR}/security/nss
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
SQLITE_USE= SQLITE=yes
SSL_USE= OPENSSL=yes
diff --git a/devel/apr2/Makefile b/devel/apr2/Makefile
index d7c0888e0c1c..7e3ed164428b 100644
--- a/devel/apr2/Makefile
+++ b/devel/apr2/Makefile
@@ -59,7 +59,7 @@ MYSQL_USE= MYSQL=yes
NDBM_CONFIGURE_WITH= ndbm=/usr
PGSQL_CONFIGURE_ENV= ac_cv_path_PGSQL_CONFIG=""
PGSQL_CONFIGURE_WITH= pgsql=${LOCALBASE}
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
SQLITE_CONFIGURE_WITH= sqlite3=${LOCALBASE}
SQLITE_USE= SQLITE=yes
diff --git a/dns/mydns-ng/Makefile b/dns/mydns-ng/Makefile
index 4c003300da9c..1bcd568e4085 100644
--- a/dns/mydns-ng/Makefile
+++ b/dns/mydns-ng/Makefile
@@ -37,7 +37,7 @@ SSL_CONFIGURE_ON= --with-openssl \
--with-openssl-include=${OPENSSLINC} \
--with-openssl-lib=${OPENSSLLIB}
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
PGSQL_CONFIGURE_ON= --with-pgsql \
--with-pgsql-include=${LOCALBASE}/include \
--with-pgsql-lib=${LOCALBASE}/lib
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 1449091ac8a5..e5494c30cbbd 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -70,7 +70,7 @@ MYSQL_CMAKE_OFF=-DWITH_MySQL:BOOL=FALSE
PGSQL_DESC= PostgreSQL database support in Kexi
PGSQL_LIB_DEPENDS=libpqxx-3.1.so:${PORTSDIR}/databases/postgresql-libpqxx3
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
PGSQL_CMAKE_OFF=-DWITH_PostgreSQL:BOOL=FALSE
SYBASE_DESC= Sybase database support in Kexi
diff --git a/ftp/pure-ftpd/Makefile b/ftp/pure-ftpd/Makefile
index 855cbebf7818..e581d276dbe2 100644
--- a/ftp/pure-ftpd/Makefile
+++ b/ftp/pure-ftpd/Makefile
@@ -71,7 +71,7 @@ MYSQL_USE= MYSQL=yes
PAM_CONFIGURE_WITH= pam
PERUSERLIMITS_CONFIGURE_WITH= peruserlimits
PGSQL_CONFIGURE_WITH= pgsql
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
PRIVSEP_CONFIGURE_WITH= privsep
SENDFILE_CONFIGURE_WITH=sendfile
THROTTLING_CONFIGURE_WITH= throttling
diff --git a/ftp/smbftpd/Makefile b/ftp/smbftpd/Makefile
index 6af7ab979182..800ec66a4571 100644
--- a/ftp/smbftpd/Makefile
+++ b/ftp/smbftpd/Makefile
@@ -22,7 +22,7 @@ USE_RC_SUBR= ${PORTNAME}
MYSQL_USE= MYSQL=yes
MYSQL_CONFIGURE_WITH= mysql
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= pgsql
ICONV_USES= iconv
ICONV_CONFIGURE_WITH= iconv
diff --git a/ftp/wzdftpd/Makefile b/ftp/wzdftpd/Makefile
index f4029e04256d..ed319fc880c8 100644
--- a/ftp/wzdftpd/Makefile
+++ b/ftp/wzdftpd/Makefile
@@ -57,7 +57,7 @@ MYSQL_USE= MYSQL=yes
PGSQL_CONFIGURE_ON= --with-pgsql=${LOCALBASE}
PGSQL_CONFIGURE_OFF= --disable-pgsql
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
SQLITE_CONFIGURE_ENABLE= sqlite3
SQLITE_USE= SQLITE=3
diff --git a/games/ldmud/Makefile b/games/ldmud/Makefile
index 656b0f865af5..5cb716d12e23 100644
--- a/games/ldmud/Makefile
+++ b/games/ldmud/Makefile
@@ -39,7 +39,7 @@ LPMUD_DESC= Install default mudlib (LP-245)
IPV6_CONFIGURE_ENABLE= use-ipv6
MYSQL_USE= MYSQL=yes
MYSQL_CONFIGURE_ENABLE= use-mysql
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
PGSQL_CONFIGURE_ENABLE= use-pgsql
SQLITE_USE= SQLITE=yes
SQLITE_CONFIGURE_ENABLE=use-sqlite
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index b847257eca72..8b960c6aea71 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -113,7 +113,7 @@ PCRE_CONFIGURE_ON= --with-pcre=${LOCALBASE}
PCRE_LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
PGSQL_CONFIGURE_OFF= --with-pg=no
PGSQL_CONFIGURE_ON= --with-pg=${LOCALBASE}/bin/pg_config
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
PNG_CONFIGURE_OFF= --with-png=internal
PNG_CONFIGURE_ON= --with-png=${LOCALBASE}
PNG_LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
diff --git a/lang/smalltalk/Makefile b/lang/smalltalk/Makefile
index d3cefa78b43d..3587021113f6 100644
--- a/lang/smalltalk/Makefile
+++ b/lang/smalltalk/Makefile
@@ -21,7 +21,7 @@ OPTIONS_DEFAULT=TK PGSQL SDL
OPTIONS_SUB= yes
TK_USES= tk:84
TK_CONFIGURE_WITH=tcl=${LOCALBASE}/lib/tcl8.4 tk=${LOCALBASE}/lib/tk8.4
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
SDL_USE= SDL=image,mixer,sdl,sound,ttf
USES= gmake iconv libtool makeinfo pkgconfig shebangfix tar:xz
diff --git a/mail/cyrus-imapd23/Makefile b/mail/cyrus-imapd23/Makefile
index e8d651bd5071..fa24ee0d6763 100644
--- a/mail/cyrus-imapd23/Makefile
+++ b/mail/cyrus-imapd23/Makefile
@@ -74,7 +74,7 @@ NETSCAPEHACK_CONFIGURE_ENABLE=netscapehack
NNTP_DESC= Enable NNTP support
NNTP_CONFIGURE_ENABLE= nntp
PGSQL_DESC= Enable PostgreSQL backend (experimental)
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
PGSQL_CONFIGURE_ON= --with-pgsql=${LOCALBASE}
REPLICATION_DESC= Enable replication
REPLICATION_CONFIGURE_ENABLE=replication
diff --git a/mail/cyrus-imapd24/Makefile b/mail/cyrus-imapd24/Makefile
index cbcc623a21ab..efdf05464296 100644
--- a/mail/cyrus-imapd24/Makefile
+++ b/mail/cyrus-imapd24/Makefile
@@ -70,7 +70,7 @@ NETSCAPEHACK_DESC= Enable X-NETSCAPE extensions
NETSCAPEHACK_CONFIGURE_ENABLE=netscapehack
NNTP_DESC= Enable NNTP support
NNTP_CONFIGURE_ENABLE= nntp
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
PGSQL_CONFIGURE_ON= --with-pgsql=${LOCALBASE}
REPLICATION_DESC= Enable replication (experimental)
REPLICATION_CONFIGURE_ENABLE=replication
diff --git a/mail/dbmail22/Makefile b/mail/dbmail22/Makefile
index defb75f71f27..311011474d4d 100644
--- a/mail/dbmail22/Makefile
+++ b/mail/dbmail22/Makefile
@@ -29,7 +29,7 @@ MYSQL_USE= MYSQL=yes
MYSQL_CONFIGURE_WITH= mysql
SQLITE_USE= SQLITE=3
SQLITE_CONFIGURE_WITH= sqlite
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= pgsql
SIEVE_CONFIGURE_WITH= sieve
SIEVE_LIB_DEPENDS= libsieve.so:${PORTSDIR}/mail/libsieve
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index 7fec0d4bf140..c0adcba95e55 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -75,7 +75,7 @@ LDAP_USE= OPENLDAP=yes
MYSQL_CONFIGURE_WITH= mysql
MYSQL_USE= MYSQL=yes
PGSQL_CONFIGURE_WITH= pgsql
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
SQLITE_CONFIGURE_WITH= sqlite
SQLITE_USE= SQLITE=3
SSL_CONFIGURE_OFF= --without-ssl
diff --git a/mail/dovecot2/Makefile b/mail/dovecot2/Makefile
index a2df5b6724dd..ba20ebc5f842 100644
--- a/mail/dovecot2/Makefile
+++ b/mail/dovecot2/Makefile
@@ -88,7 +88,7 @@ MYSQL_USE= MYSQL=yes
MYSQL_CONFIGURE_WITH= mysql
MYSQL_RC_REQUIRE= mysql
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= pgsql
PGSQL_RC_REQUIRE= postgresql
diff --git a/mail/opensmtpd-devel/Makefile b/mail/opensmtpd-devel/Makefile
index 71f3cb0f7139..74fd54518e8c 100644
--- a/mail/opensmtpd-devel/Makefile
+++ b/mail/opensmtpd-devel/Makefile
@@ -52,7 +52,7 @@ SQLITE_CFLAGS= -I${LOCALBASE}/include
SQLITE_LDFLAGS= -L${LOCALBASE}/lib
SQLITE_CONFIGURE_ON= --with-experimental-sqlite
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
PGSQL_CONFIGURE_ON= --with-experimental-postgres
LDAP_CONFIGURE_ON= --with-experimental-ldap
diff --git a/mail/opensmtpd/Makefile b/mail/opensmtpd/Makefile
index 500f3c57833c..c77646a8d9e6 100644
--- a/mail/opensmtpd/Makefile
+++ b/mail/opensmtpd/Makefile
@@ -52,7 +52,7 @@ SQLITE_CFLAGS= -I${LOCALBASE}/include
SQLITE_LDFLAGS= -L${LOCALBASE}/lib
SQLITE_CONFIGURE_ON= --with-experimental-sqlite
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
PGSQL_CONFIGURE_ON= --with-experimental-postgres
LDAP_CONFIGURE_ON= --with-experimental-ldap
diff --git a/misc/krecipes-kde4/Makefile b/misc/krecipes-kde4/Makefile
index 2701a7f6b84c..e75fde86b420 100644
--- a/misc/krecipes-kde4/Makefile
+++ b/misc/krecipes-kde4/Makefile
@@ -26,7 +26,7 @@ SQLITE_CMAKE_OFF= -DWITH_Sqlite:BOOL=OFF
MYSQL_USE= MYSQL=yes \
QT4=sql-mysql_run
-PGSQL_USE= PGSQL=yes \
- QT4=sql-pgsql_run
+PGSQL_USES= pgsql
+PGSQL_USE= QT4=sql-pgsql_run
.include <bsd.port.mk>
diff --git a/net-im/jabberd/Makefile b/net-im/jabberd/Makefile
index 6bbe741dbc9c..162b6b4a96e9 100644
--- a/net-im/jabberd/Makefile
+++ b/net-im/jabberd/Makefile
@@ -68,7 +68,7 @@ EIP+= ${OPENSSLINC}
DEBUG_CONFIGURE_ENABLE= debug
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
PGSQL_CONFIGURE_ENABLE= pgsql
SQLITE_CONFIGURE_ENABLE=sqlite
diff --git a/net-mgmt/flow-tools-ng/Makefile b/net-mgmt/flow-tools-ng/Makefile
index 183c46205ac6..d6c45c673412 100644
--- a/net-mgmt/flow-tools-ng/Makefile
+++ b/net-mgmt/flow-tools-ng/Makefile
@@ -16,7 +16,7 @@ LICENSE= BSD2CLAUSE
OPTIONS_DEFINE= MYSQL OPENSSL PGSQL
PGSQL_CONFIGURE_OFF= --without-postgresql
PGSQL_CONFIGURE_ON= --with-postgresql
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
MYSQL_CONFIGURE_OFF= --without-mysql
MYSQL_CONFIGURE_ON= --with-mysql="${PREFIX}"
MYSQL_USE= MYSQL=yes
diff --git a/net-mgmt/netams/Makefile b/net-mgmt/netams/Makefile
index c443c35e43c0..4424548ff8e7 100644
--- a/net-mgmt/netams/Makefile
+++ b/net-mgmt/netams/Makefile
@@ -31,7 +31,7 @@ OPTIONS_MULTI_DATABASE= MYSQL PGSQL
CGI_DESC= Install admin/user CGI scripts
OPTIONS_SUB= yes
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
MYSQL_USE= MYSQL=yes
.include <bsd.port.options.mk>
diff --git a/security/barnyard2/Makefile b/security/barnyard2/Makefile
index 801d2cb7611f..4036c2d4d72e 100644
--- a/security/barnyard2/Makefile
+++ b/security/barnyard2/Makefile
@@ -59,7 +59,7 @@ MYSQL_CONFIGURE_ON= --with-mysql-includes=${LOCALBASE}/include/mysql \
MYSQL_SSL_CONFIGURE_ENABLE= mysql-ssl-support
ODBC_LIB_DEPENDS= libodbc.so:${PORTSDIR}/databases/unixODBC
ODBC_WITH= odbc
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
PGSQL_CONFIGURE_ON= --with-postgresql=${LOCALBASE}/bin/pg_config --with-pgsql-includes=${LOCALBASE}/include/postgresql/server
PGSQL_CONFIGURE_OFF= --without-postgresql
TCL_USES= tcl
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index ec7d9b357630..7f9075a6382a 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -64,7 +64,7 @@ BDB_CONFIGURE_OFF= --with-dblib=ndbm
MYSQL_USE= MYSQL=yes
MYSQL_CONFIGURE_ON= --with-mysql=${LOCALBASE}
MYSQL_CONFIGURE_OFF= --without-mysql
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
PGSQL_CONFIGURE_ON= --with-pgsql=${LOCALBASE}
PGSQL_CONFIGURE_OFF= --without-pgsql
SQLITE2_DESC= SQLite 2 database
diff --git a/sysutils/msyslog/Makefile b/sysutils/msyslog/Makefile
index 1e7526b3085b..25770d738c01 100644
--- a/sysutils/msyslog/Makefile
+++ b/sysutils/msyslog/Makefile
@@ -19,7 +19,7 @@ OPTIONS_DEFINE= MYSQL PGSQL EXAMPLES
OPTIONS_SUB= yes
MYSQL_USE= MYSQL=yes
MYSQL_CONFIGURE_OFF= --without-mysql
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
PGSQL_CONFIGURE_OFF= --without-pgsql
WRKSRC= ${WRKDIR}/${DISTNAME:S/-src//}
diff --git a/www/kannel/Makefile b/www/kannel/Makefile
index 3419e56d9e91..a44c193079d2 100644
--- a/www/kannel/Makefile
+++ b/www/kannel/Makefile
@@ -35,7 +35,7 @@ SQLITE3_CONFIGURE_WITH= sqlite3
MYSQL_USE= MYSQL=yes
MYSQL_CONFIGURE_WITH= mysql
-PGSQL_USE= PGSQL=yes
+PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= pgsql
post-install:
diff --git a/www/owncloud/Makefile b/www/owncloud/Makefile
index a87f659a75a7..d968f010db5d 100644
--- a/www/owncloud/Makefile
+++ b/www/owncloud/Makefile
@@ -39,7 +39,8 @@ LDAP_USE= PHP=ldap
MP3INFO_BUILD_DEPENDS= mp3info:${PORTSDIR}/audio/mp3info
MP3INFO_RUN_DEPENDS= ${MP3INFO_BUILD_DEPENDS}
MYSQL_USE= MYSQL=client PHP=mysql,pdo_mysql
-PGSQL_USE= PGSQL=yes PHP=pdo_pgsql,pgsql
+PGSQL_USES= pgsql
+PGSQL_USE= PHP=pdo_pgsql,pgsql
SQLITE_USE= PHP=pdo_sqlite,sqlite3
SSL_USE= PHP=openssl