aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/tkmoo/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/games/tkmoo/Makefile b/games/tkmoo/Makefile
index 28cf7c040713..c58172880862 100644
--- a/games/tkmoo/Makefile
+++ b/games/tkmoo/Makefile
@@ -11,14 +11,13 @@ DISTNAME= tkMOO-light-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Tk-based M** client with scripting support
-USE_TK_RUN= yes
+USES= tk:run
MAKE_ENV+= TKMOO_LIB_DIR="${DATADIR}" \
TKMOO_BIN_DIR="${PREFIX}/bin" WISH8.3="${WISH}"
-NO_STAGE= yes
do-install:
- @${MKDIR} ${DATADIR}/plugins
- @${INSTALL_DATA} ${WRKSRC}/plugins/* ${DATADIR}/plugins
- @${INSTALL_SCRIPT} ${WRKSRC}/tkMOO-lite ${PREFIX}/bin/tkmoo
+ @${MKDIR} ${STAGEDIR}${DATADIR}/plugins
+ ${INSTALL_DATA} ${WRKSRC}/plugins/* ${STAGEDIR}${DATADIR}/plugins
+ ${INSTALL_SCRIPT} ${WRKSRC}/tkMOO-lite ${STAGEDIR}${PREFIX}/bin/tkmoo
.include <bsd.port.mk>