aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/vmware/Makefile15
-rw-r--r--emulators/vmware2/Makefile15
-rw-r--r--emulators/vmware3/Makefile15
3 files changed, 42 insertions, 3 deletions
diff --git a/emulators/vmware/Makefile b/emulators/vmware/Makefile
index be23c9f10ffc..a91041c92b86 100644
--- a/emulators/vmware/Makefile
+++ b/emulators/vmware/Makefile
@@ -117,6 +117,19 @@ pre-install: setoptions
.endif
post-install:
- ${LN} -s ${PREFIX}/etc/vmware /etc/vmware
+ @${LN} -s ${PREFIX}/etc/vmware /etc/vmware
+.if !defined(BATCH)
+ @${ECHO} "-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-"
+ @${ECHO} "Before launch vmware, execute the next command"
+ @${ECHO} ${PREFIX}/etc/rc.d/vmware.sh start
+ @${ECHO}
+ @${ECHO} "to load required kernel modules"
+ @${ECHO} "-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-"
+.endif
+
+
+pre-clean:
+ @${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc.linproc \
+ ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc.net
.include <bsd.port.post.mk>
diff --git a/emulators/vmware2/Makefile b/emulators/vmware2/Makefile
index be23c9f10ffc..a91041c92b86 100644
--- a/emulators/vmware2/Makefile
+++ b/emulators/vmware2/Makefile
@@ -117,6 +117,19 @@ pre-install: setoptions
.endif
post-install:
- ${LN} -s ${PREFIX}/etc/vmware /etc/vmware
+ @${LN} -s ${PREFIX}/etc/vmware /etc/vmware
+.if !defined(BATCH)
+ @${ECHO} "-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-"
+ @${ECHO} "Before launch vmware, execute the next command"
+ @${ECHO} ${PREFIX}/etc/rc.d/vmware.sh start
+ @${ECHO}
+ @${ECHO} "to load required kernel modules"
+ @${ECHO} "-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-"
+.endif
+
+
+pre-clean:
+ @${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc.linproc \
+ ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc.net
.include <bsd.port.post.mk>
diff --git a/emulators/vmware3/Makefile b/emulators/vmware3/Makefile
index be23c9f10ffc..a91041c92b86 100644
--- a/emulators/vmware3/Makefile
+++ b/emulators/vmware3/Makefile
@@ -117,6 +117,19 @@ pre-install: setoptions
.endif
post-install:
- ${LN} -s ${PREFIX}/etc/vmware /etc/vmware
+ @${LN} -s ${PREFIX}/etc/vmware /etc/vmware
+.if !defined(BATCH)
+ @${ECHO} "-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-"
+ @${ECHO} "Before launch vmware, execute the next command"
+ @${ECHO} ${PREFIX}/etc/rc.d/vmware.sh start
+ @${ECHO}
+ @${ECHO} "to load required kernel modules"
+ @${ECHO} "-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-"
+.endif
+
+
+pre-clean:
+ @${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc.linproc \
+ ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc.net
.include <bsd.port.post.mk>