diff options
-rw-r--r-- | MOVED | 1 | ||||
-rw-r--r-- | security/Makefile | 1 | ||||
-rw-r--r-- | security/labrea/Makefile | 44 | ||||
-rw-r--r-- | security/labrea/distinfo | 2 | ||||
-rw-r--r-- | security/labrea/files/patch-Data.c | 52 | ||||
-rw-r--r-- | security/labrea/files/patch-Makefile | 22 | ||||
-rw-r--r-- | security/labrea/pkg-descr | 6 | ||||
-rw-r--r-- | security/labrea/pkg-plist | 3 |
8 files changed, 1 insertions, 130 deletions
@@ -5996,3 +5996,4 @@ security/cfv||2014-04-13|Has expired: Unmaintained since 2001 graphics/camediaplay||2014-04-13|Has expired: Unmaintained since 2001 math/umatrix||2014-04-13|Has expired: Unmaintained since 2001 lang/f77||2014-04-13|Has expired: Unmaintained since 2001 +security/labrea||2014-04-14|Has expired: Unmaintained since 2003 diff --git a/security/Makefile b/security/Makefile index fef7af2121a1..a599046e5abd 100644 --- a/security/Makefile +++ b/security/Makefile @@ -247,7 +247,6 @@ SUBDIR += l0pht-watch SUBDIR += l0phtcrack SUBDIR += l5 - SUBDIR += labrea SUBDIR += lasso SUBDIR += libassuan SUBDIR += libbf diff --git a/security/labrea/Makefile b/security/labrea/Makefile deleted file mode 100644 index 81dd4c8abfdc..000000000000 --- a/security/labrea/Makefile +++ /dev/null @@ -1,44 +0,0 @@ -# Created by: nick@rogness.net -# $FreeBSD$ - -PORTNAME= LaBrea -PORTVERSION= 2.4 -PORTREVISION= 2 -CATEGORIES= security -MASTER_SITES= http://freebsd.rogness.net/ports/labrea/ -DISTNAME= ${PORTNAME}${PORTVERSION:S/./_/g} -EXTRACT_SUFX= .tgz - -MAINTAINER= nick@rogness.net -COMMENT= Security tarpit defense tool - -DEPRECATED= Unmaintained since 2003 -EXPIRATION_DATE= 2014-04-14 - -BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10 - -LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config - -NO_STAGE= yes -post-patch: - @${REINPLACE_CMD} -e \ - 's|libnet-config|${LIBNET_CONFIG}|; \ - s|--defines|& --cflags|' \ - ${WRKSRC}/${MAKEFILE} - -do-install: - ${INSTALL_PROGRAM} ${WRKSRC}/LaBrea ${PREFIX}/bin - -post-install: -.if !defined(NOPORTDOCS) - @${MKDIR} ${DOCSDIR} - ${INSTALL_MAN} ${WRKSRC}/LaBrea.README ${DOCSDIR} - @echo "******************************************" - @echo "You will need to read the LaBrea.README in" - @echo "${DOCSDIR}" - @echo "Before your run this!!" - @echo "******************************************" - @echo . -.endif - -.include <bsd.port.mk> diff --git a/security/labrea/distinfo b/security/labrea/distinfo deleted file mode 100644 index b9aa1a3969bd..000000000000 --- a/security/labrea/distinfo +++ /dev/null @@ -1,2 +0,0 @@ -SHA256 (LaBrea2_4.tgz) = 597ba3850aa1ee27ef6552fd658a0195b06217d42b2a819bcb68687ef463d0db -SIZE (LaBrea2_4.tgz) = 35529 diff --git a/security/labrea/files/patch-Data.c b/security/labrea/files/patch-Data.c deleted file mode 100644 index 624349f19ebe..000000000000 --- a/security/labrea/files/patch-Data.c +++ /dev/null @@ -1,52 +0,0 @@ ---- Data.c.orig Tue Feb 11 01:04:04 2003 -+++ Data.c Sat Jun 14 11:39:04 2003 -@@ -22,3 +22,6 @@ -+#ifndef CONFIG_PATH -+#define COFNIG_PATH "/etc" -+#endif - #ifdef OLDSTYLE
- #ifdef WIN32
- char HardExcludeName[] = "LaBreaHardExclude.cfg";
-@@ -30,14 +33,14 @@ - char IgnorePortName[] = "LaBreaIgnorePort.cfg";
- char IgnorePortNotFound[] = "LaBreaIgnorePort.cfg not found - nothing to ignore";
- #else
--char HardExcludeName[] = "/etc/LaBreaHardExclude";
--char HardExcludeNotFound[] = "/etc/LaBreaHardExclude not found - no hard exclusions";
--char IgnoreName[] = "/etc/LaBreaIgnoreIP";
--char IgnoreNotFound[] = "/etc/LaBreaIgnoreIP not found - nothing to ignore";
--char ExcludeName[] = "/etc/LaBreaExclude";
--char ExcludeNotFound[] = "/etc/LaBreaExclude not found - no hard exclusions";
--char IgnorePortName[] = "/etc/LaBreaIgnorePort";
--char IgnorePortNotFound[] = "/etc/LaBreaIgnorePort not found - nothing to ignore";
-+char HardExcludeName[] = CONFIG_PATH"/LaBreaHardExclude";
-+char HardExcludeNotFound[] = CONFIG_PATH"/LaBreaHardExclude not found - no hard exclusions";
-+char IgnoreName[] = CONFIG_PATH"/LaBreaIgnoreIP";
-+char IgnoreNotFound[] = CONFIG_PATH"/LaBreaIgnoreIP not found - nothing to ignore";
-+char ExcludeName[] = CONFIG_PATH"/LaBreaExclude";
-+char ExcludeNotFound[] = CONFIG_PATH"/LaBreaExclude not found - no hard exclusions";
-+char IgnorePortName[] = CONFIG_PATH"/LaBreaIgnorePort";
-+char IgnorePortNotFound[] = CONFIG_PATH"/LaBreaIgnorePort not found - nothing to ignore";
- #endif /* WIN32 */
- char format3[] = "Exclude: %i.%i.%i.%i\n";
- char format4[] = "HardExclude: %i.%i.%i.%i\n";
-@@ -46,8 +49,8 @@ - char ConfigName[] = "LaBrea.cfg";
- char ConfigNotFound[] = "LaBrea.cfg not found";
- #else
--char ConfigName[] = "/etc/LaBreaConfig";
--char ConfigNotFound[] = "/etc/LaBreaConfig not found";
-+char ConfigName[] = CONFIG_PATH"/LaBreaConfig";
-+char ConfigNotFound[] = CONFIG_PATH"/LaBreaConfig not found";
- #endif /* WIN32 */
- #endif /* OLDSTYLE */
-
-@@ -127,7 +130,7 @@ - char err17[] = "Invalid or missing interface!\n";
- char getoptstr[] = "HXPoOdTRqr:i:t:lvVxs?hzap:bE:I:Dfj";
- #else
--char strRandFileName[] = "/etc/LaBreaRandom";
-+char strRandFileName[] = CONFIG_PATH"/LaBreaRandom";
- char err18[] = "User specified netmask: %s\nUser specified network number: %s\n";
- char getoptstr[] = "HXPoOdTRqF:r:i:t:lvVxsn:m:?hzap:bfj";
- #endif
diff --git a/security/labrea/files/patch-Makefile b/security/labrea/files/patch-Makefile deleted file mode 100644 index b44a51908349..000000000000 --- a/security/labrea/files/patch-Makefile +++ /dev/null @@ -1,22 +0,0 @@ ---- Makefile.orig Thu Feb 21 00:27:56 2002 -+++ Makefile Wed Jun 25 10:36:50 2003 -@@ -3,14 +3,15 @@ - OPTFLAGS = -O6 -funroll-loops -frerun-cse-after-loop -finline-functions \ - -mcpu=i686 -fexpensive-optimizations -fomit-frame-pointer - #OPTFLAGS = -g --CC = gcc --CFLAGS = -Wall `libnet-config --defines` $(OPTFLAGS) $(INCLUDES) -+CC ?= gcc -+CFLAGS += -Wall `libnet-config --defines` -DCONFIG_PATH=\"$(PREFIX)/etc\" $(INCLUDES) - LDLIBS = `libnet-config --libs` -lpcap --LDFLAGS = -s --INCLUDES = -I/usr/include/pcap -+LDFLAGS = -s -L$(PREFIX)/lib -+INCLUDES = -I/usr/include/pcap -I$(PREFIX)/include - - LaBrea: LaBrea.o CleanExit.o FixArrays.o GoDaemon.o \ - PacketHandler.o ServiceTimer.o ToggleLogging.o -+ $(CC) -o LaBrea $> $(LDFLAGS) $(LDLIBS) - - LaBrea.o: LaBrea.c labrea.h defines.h - CleanExit.o: CleanExit.c labrea.h defines.h diff --git a/security/labrea/pkg-descr b/security/labrea/pkg-descr deleted file mode 100644 index 2ef2368f5ac4..000000000000 --- a/security/labrea/pkg-descr +++ /dev/null @@ -1,6 +0,0 @@ -LaBrea takes over unused IP addresses, and creates virtual servers that -are attractive to worms, hackers, and other denizens of the Internet. -The program answers connection attempts in such a way that the machine -at the other end gets "stuck", sometimes for a very long time. - -WWW: http://www.hackbusters.net diff --git a/security/labrea/pkg-plist b/security/labrea/pkg-plist deleted file mode 100644 index dd1f69546e82..000000000000 --- a/security/labrea/pkg-plist +++ /dev/null @@ -1,3 +0,0 @@ -bin/LaBrea -%%PORTDOCS%%share/doc/LaBrea/LaBrea.README -%%PORTDOCS%%@dirrm share/doc/LaBrea |