aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/astrometry/Makefile2
-rw-r--r--graphics/mypaint/Makefile4
-rw-r--r--math/rpy/Makefile4
-rw-r--r--math/rpy2/Makefile4
-rw-r--r--science/py-hcluster/Makefile2
-rw-r--r--science/py-mlpy/Makefile2
-rw-r--r--science/pycdf/Makefile2
7 files changed, 10 insertions, 10 deletions
diff --git a/astro/astrometry/Makefile b/astro/astrometry/Makefile
index db003a1d20a8..56edb9d13c15 100644
--- a/astro/astrometry/Makefile
+++ b/astro/astrometry/Makefile
@@ -11,7 +11,7 @@ DISTNAME= ${PORTNAME}.net-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Describes an astronomical image
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy
+BUILD_DEPENDS= ${PYNUMPY}
LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo \
libcfitsio.so:${PORTSDIR}/astro/cfitsio \
libjpeg.so:${PORTSDIR}/graphics/jpeg \
diff --git a/graphics/mypaint/Makefile b/graphics/mypaint/Makefile
index 4f0b9a78ed0d..2268e922cea9 100644
--- a/graphics/mypaint/Makefile
+++ b/graphics/mypaint/Makefile
@@ -11,8 +11,8 @@ MASTER_SITES= http://download.gna.org/mypaint/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Fast painting/scribbling program
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
- ${PYTHON_SITELIBDIR}/cairo:${PORTSDIR}/graphics/py-cairo \
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}cairo>0:${PORTSDIR}/graphics/py-cairo \
${PYTHON_PKGNAMEPREFIX}protobuf>0:${PORTSDIR}/devel/py-protobuf
LIB_DEPENDS= libjson-c.so:${PORTSDIR}/devel/json-c \
liblcms2.so:${PORTSDIR}/graphics/lcms2
diff --git a/math/rpy/Makefile b/math/rpy/Makefile
index d8e44fd1c8a0..7dff9087d150 100644
--- a/math/rpy/Makefile
+++ b/math/rpy/Makefile
@@ -13,9 +13,9 @@ COMMENT= Python interface to the R Programming Language
LICENSE= GPLv2 LGPL21 MPL
LICENSE_COMB= dual
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
+BUILD_DEPENDS= ${PYNUMPY} \
R:${PORTSDIR}/math/R
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
+RUN_DEPENDS= ${PYNUMPY} \
R:${PORTSDIR}/math/R
USES= python
diff --git a/math/rpy2/Makefile b/math/rpy2/Makefile
index e61002153f1a..fc729b8a0954 100644
--- a/math/rpy2/Makefile
+++ b/math/rpy2/Makefile
@@ -12,9 +12,9 @@ COMMENT= Python interface to the R Programming Language
LICENSE= GPLv2
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
+BUILD_DEPENDS= ${PYNUMPY} \
R:${PORTSDIR}/math/R
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
+RUN_DEPENDS= ${PYNUMPY} \
R:${PORTSDIR}/math/R
USES= python readline
diff --git a/science/py-hcluster/Makefile b/science/py-hcluster/Makefile
index 5ac1166b4a3b..31920625ce38 100644
--- a/science/py-hcluster/Makefile
+++ b/science/py-hcluster/Makefile
@@ -11,7 +11,7 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= wenheping@gmail.com
COMMENT= Hierarchical Clustering Package For Scipy
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
+BUILD_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}matplotlib>0:${PORTSDIR}/math/py-matplotlib
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/science/py-mlpy/Makefile b/science/py-mlpy/Makefile
index ed3c65a48656..3743998c6181 100644
--- a/science/py-mlpy/Makefile
+++ b/science/py-mlpy/Makefile
@@ -13,7 +13,7 @@ COMMENT= High performance Python package for predictive modeling
LICENSE= GPLv3
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
+BUILD_DEPENDS= ${PYNUMPY} \
cython>0:${PORTSDIR}/lang/cython
RUN_DEPENDS:= ${BUILD_DEPENDS}
LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl
diff --git a/science/pycdf/Makefile b/science/pycdf/Makefile
index 9bba30cfd41b..3b45a95f8eb9 100644
--- a/science/pycdf/Makefile
+++ b/science/pycdf/Makefile
@@ -11,7 +11,7 @@ DISTNAME= ${PORTNAME}-0.6-3b
MAINTAINER= ports@FreeBSD.org
COMMENT= Python Interface to the Unidata NetCDF Library
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy
+BUILD_DEPENDS= ${PYNUMPY}
LIB_DEPENDS= libnetcdf.so:${PORTSDIR}/science/netcdf
RUN_DEPENDS:= ${BUILD_DEPENDS}