aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/xed/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/editors/xed/Makefile b/editors/xed/Makefile
index 850b8fbf39e8..455c1258a50b 100644
--- a/editors/xed/Makefile
+++ b/editors/xed/Makefile
@@ -17,6 +17,10 @@ MAINTAINER= shanee@augusta.de
USE_IMAKE= yes
USE_XPM= yes
+USE_REINPLACE=yes
MAN1= xed.1
+pre-build:
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|extern char \*malloc();|/\* extern char \*malloc(); \*/|g'
.include <bsd.port.mk>