aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/heroes/Makefile11
-rw-r--r--games/heroes/distinfo4
-rw-r--r--games/heroes/files/patch-configure16
-rw-r--r--games/heroes/pkg-plist6
4 files changed, 21 insertions, 16 deletions
diff --git a/games/heroes/Makefile b/games/heroes/Makefile
index f633d3d96d17..0fa6853520f4 100644
--- a/games/heroes/Makefile
+++ b/games/heroes/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= heroes
-PORTVERSION= 0.11
+PORTVERSION= 0.21
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,9 +20,10 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
MAINTAINER= sobomax@FreeBSD.org
LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
- gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
+ iconv.3:${PORTSDIR}/converters/libiconv
-DATAVERSION= 1.1
+DATAVERSION= 1.5
SOUNDVERSION= 1.0
MUSICVERSION= 1.0
DATADISTNAME= ${PORTNAME}-data-${DATAVERSION}
@@ -40,11 +41,11 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-sdl_mixer=${LOCALBASE}
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
- LIBS="-L${LOCALBASE}/lib -lgnugetopt ${PTHREAD_LIBS} -lsmpeg" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt ${PTHREAD_LIBS} -lsmpeg" \
CPPFLAGS="-I${LOCALBASE}/include"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-MAN6= heroes.6
+MAN6= heroes.6 heroeslvl.6
pre-patch:
@for dir in ${DATASRC} ${SOUNDSRC} ${MUSICSRC}; do \
diff --git a/games/heroes/distinfo b/games/heroes/distinfo
index 96db61ae8f0b..13dc479262d4 100644
--- a/games/heroes/distinfo
+++ b/games/heroes/distinfo
@@ -1,4 +1,4 @@
-MD5 (heroes-0.11.tar.gz) = 09de470a5b77e26c2b57b88afaa4db62
-MD5 (heroes-data-1.1.tar.gz) = 553785cf7b55ce4662276fa8c1d77a48
+MD5 (heroes-0.21.tar.gz) = 3238290f219bc978894ba472fac95298
+MD5 (heroes-data-1.5.tar.gz) = 1a53e23b007f526a76df8bef97a41550
MD5 (heroes-sound-effects-1.0.tar.gz) = f4defb80baf765fceac034a408f7ad2e
MD5 (heroes-sound-tracks-1.0.tar.gz) = bcde6137a4b21b7395fd3d84b42b7888
diff --git a/games/heroes/files/patch-configure b/games/heroes/files/patch-configure
index 5b4339035d59..43de5115b89d 100644
--- a/games/heroes/files/patch-configure
+++ b/games/heroes/files/patch-configure
@@ -1,32 +1,32 @@
$FreeBSD$
---- configure.orig Sat Feb 24 13:04:23 2001
-+++ configure Sat Feb 24 22:40:31 2001
-@@ -9699,7 +9699,7 @@
+--- configure.orig Sat Mar 30 19:36:16 2002
++++ configure Sat Apr 6 16:11:51 2002
+@@ -13339,7 +13339,7 @@
CFLAGS="$CFLAGS -ggdb3"
else
if test "${ac_cv_prog_cc_g}" = yes; then
- CFLAGS="$CFLAGS -g"
-+# CFLAGS="$CFLAGS -g"
++ CFLAGS="$CFLAGS"
fi
fi
;;
-@@ -9707,7 +9707,7 @@
+@@ -13347,7 +13347,7 @@
;;
*)
if test "${ac_cv_prog_cc_g}" = yes; then
- CFLAGS="$CFLAGS -g"
-+# CFLAGS="$CFLAGS -g"
++ CFLAGS="$CFLAGS"
fi
;;
esac
-@@ -9727,7 +9727,7 @@
+@@ -13367,7 +13367,7 @@
int main(int argc, char *argv[]) { return argv[argc-1] == 0; }
EOF
cf_save_CFLAGS="$CFLAGS"
- ac_cv_prog_gcc_opt_flags="-O3"
-+# ac_cv_prog_gcc_opt_flags="-O3"
++ ac_cv_prog_gcc_opt_flags=""
for cf_opt in \
ffast-math \
fstrict-aliasing \
diff --git a/games/heroes/pkg-plist b/games/heroes/pkg-plist
index 31c269a74313..23393c84677f 100644
--- a/games/heroes/pkg-plist
+++ b/games/heroes/pkg-plist
@@ -1,8 +1,10 @@
@exec install-info --section="X11 Games" --entry="* heroes: (heroes). Game of yore similar to the "Tron" and "Nibbles"" %D/info/heroes.info %D/info/dir
@unexec install-info --delete %D/info/heroes.info %D/info/dir
bin/heroes
-info/dir
+bin/heroeslvl
info/heroes.info
+info/heroes.info-1
+info/heroes.info-2
lib/charset.alias
share/heroes/etc/heroesrc
share/heroes/levels/level.lst
@@ -131,6 +133,7 @@ share/heroes/pics/editp08.pcx
share/heroes/pics/editp09.pcx
share/heroes/pics/editp10.pcx
share/heroes/pics/erase.pcx
+share/heroes/pics/fontbig.pcx
share/heroes/pics/fontdeck.pcx
share/heroes/pics/fontem.pcx
share/heroes/pics/fontem2.pcx
@@ -213,6 +216,7 @@ share/locale/fr/LC_MESSAGES/heroes.mo
share/locale/it/LC_MESSAGES/heroes.mo
share/locale/locale.alias
share/locale/nl/LC_MESSAGES/heroes.mo
+share/locale/pt_BR/LC_MESSAGES/heroes.mo
@dirrm share/heroes/tilesets
@dirrm share/heroes/sfx
@dirrm share/heroes/pics